summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-03-18 22:52:33 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-03-18 22:52:33 +0000
commit4d8c737fee5de916cf03e143d7e85a800e335099 (patch)
tree132df322688878edd18c40451bc95cc0d3c98128 /sys-process
parentUm, don't break earlier fixes. (diff)
downloadgentoo-2-4d8c737fee5de916cf03e143d7e85a800e335099.tar.gz
gentoo-2-4d8c737fee5de916cf03e143d7e85a800e335099.tar.bz2
gentoo-2-4d8c737fee5de916cf03e143d7e85a800e335099.zip
small fixups
(Portage version: 2.1.2-r12)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/ChangeLog5
-rw-r--r--sys-process/fcron/fcron-3.0.2-r1.ebuild62
2 files changed, 34 insertions, 33 deletions
diff --git a/sys-process/fcron/ChangeLog b/sys-process/fcron/ChangeLog
index e9f14019f466..64d05bd8735d 100644
--- a/sys-process/fcron/ChangeLog
+++ b/sys-process/fcron/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/fcron
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.28 2007/03/18 22:31:35 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.29 2007/03/18 22:52:33 wschlich Exp $
+
+ 18 Mar 2007; Wolfram Schlich <wschlich@gentoo.org> fcron-3.0.2-r1.ebuild:
+ small fixups
*fcron-3.0.2-r1 (18 Mar 2007)
diff --git a/sys-process/fcron/fcron-3.0.2-r1.ebuild b/sys-process/fcron/fcron-3.0.2-r1.ebuild
index ddd76f883af5..06aeac8e569e 100644
--- a/sys-process/fcron/fcron-3.0.2-r1.ebuild
+++ b/sys-process/fcron/fcron-3.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.2-r1.ebuild,v 1.1 2007/03/18 22:31:35 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.2-r1.ebuild,v 1.2 2007/03/18 22:52:33 wschlich Exp $
inherit cron pam eutils
@@ -143,35 +143,6 @@ src_install() {
}
pkg_postinst() {
- ewarn
- ewarn "Fixing ownership of /var/spool/cron/fcrontabs"
- ewarn
-
- chown fcron:fcron /var/spool/cron/fcrontabs
- chmod 6770 /var/spool/cron/fcrontabs
- chown root:root /var/spool/cron/fcrontabs/*
- chmod 0600 /var/spool/cron/fcrontabs/*
- chown fcron:fcron /var/spool/cron/fcrontabs/*.orig
- chmod 0640 /var/spool/cron/fcrontabs/*.orig
-
- ewarn
- ewarn "WARNING: fcron now uses a dedicated user and group"
- ewarn "'fcron' for the suid/sgid programs/files instead of"
- ewarn "the user and group 'cron' that were previously used."
- ewarn
-
- ebeep 5
- epause 10
-
- ewarn
- ewarn "Each user who should be able to use fcron should only be"
- ewarn "added to the file /etc/fcron/fcron.allow and not to the"
- ewarn "group 'cron'!"
- ewarn
-
- ebeep 5
- epause 10
-
einfo
einfo "fcron has some important differences compared to vixie-cron:"
einfo
@@ -222,9 +193,36 @@ pkg_postinst() {
einfo "directories /etc/cron.{hourly|daily|weekly|monthly} by"
einfo "just generating a systab once from /etc/crontab:"
einfo
- einfo " fcrontab -u systab /etc/crontab"
- einfo
+ einfo " fcrontab -u systab /etc/crontab"
einfo
einfo "Happy fcron'ing!"
einfo
+
+ ewarn
+ ewarn "Fixing permissions and ownership of /var/spool/cron/fcrontabs"
+ chown fcron:fcron /var/spool/cron/fcrontabs
+ chmod 6770 /var/spool/cron/fcrontabs
+ chown root:root /var/spool/cron/fcrontabs/*
+ chmod 0600 /var/spool/cron/fcrontabs/*
+ chown fcron:fcron /var/spool/cron/fcrontabs/*.orig
+ chmod 0640 /var/spool/cron/fcrontabs/*.orig
+ ewarn "Fixing permissions and ownership of /usr/bin/fcron{tab,dyn,sighup}"
+ chown fcron:fcron /usr/bin/fcron{tab,dyn}
+ chown ${ROOTUSER:-root}:fcron /usr/bin/fcronsighup
+ chmod 6755 /usr/bin/fcron{tab,dyn,sighup}
+ ewarn
+ ewarn "WARNING: fcron now uses a dedicated user and group"
+ ewarn "'fcron' for the suid/sgid programs/files instead of"
+ ewarn "the user and group 'cron' that were previously used."
+ ewarn
+ ewarn "fcron usage can now only be restricted by adding users"
+ ewarn "to the following files instead of to the group 'cron':"
+ ewarn
+ ewarn " /etc/fcron/fcron.allow"
+ ewarn " /etc/fcron/fcron.deny"
+ ewarn
+
+ ebeep 5
+ epause 10
+
}