summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-02-12 00:00:33 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-02-12 00:00:33 +0000
commit24fd5ade4bba3553af1f3ba323666c4d24ebfd40 (patch)
tree6f28ab7c915d75c62960d0caa3470fe6fb465081 /sys-process
parentstable on amd64; security bug 141577 (diff)
downloadgentoo-2-24fd5ade4bba3553af1f3ba323666c4d24ebfd40.tar.gz
gentoo-2-24fd5ade4bba3553af1f3ba323666c4d24ebfd40.tar.bz2
gentoo-2-24fd5ade4bba3553af1f3ba323666c4d24ebfd40.zip
fix bug #156433, add warning about debug USE flag wrt bug #163126
(Portage version: 2.1.2)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/fcron/ChangeLog5
-rw-r--r--sys-process/fcron/fcron-3.0.2.ebuild16
2 files changed, 19 insertions, 2 deletions
diff --git a/sys-process/fcron/ChangeLog b/sys-process/fcron/ChangeLog
index c81e0484c7eb..4a8630134706 100644
--- a/sys-process/fcron/ChangeLog
+++ b/sys-process/fcron/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-process/fcron
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.24 2007/01/18 18:58:45 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/ChangeLog,v 1.25 2007/02/12 00:00:33 wschlich Exp $
+
+ 11 Feb 2007; Wolfram Schlich <wschlich@gentoo.org> fcron-3.0.2.ebuild:
+ fix bug #156433, add warning about debug USE flag wrt bug #163126
18 Jan 2007; Jeroen Roovers <jer@gentoo.org> fcron-3.0.1-r2.ebuild:
Stable for HPPA (bug #149376).
diff --git a/sys-process/fcron/fcron-3.0.2.ebuild b/sys-process/fcron/fcron-3.0.2.ebuild
index 56bd6ef515ae..39e7c704c4f4 100644
--- a/sys-process/fcron/fcron-3.0.2.ebuild
+++ b/sys-process/fcron/fcron-3.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.2.ebuild,v 1.1 2007/01/18 00:27:31 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/fcron/fcron-3.0.2.ebuild,v 1.2 2007/02/12 00:00:33 wschlich Exp $
inherit cron pam eutils
@@ -20,6 +20,18 @@ DEPEND="app-editors/nano
pkg_setup() {
ROOTUSER=$(egetent passwd 0 | cut -d ':' -f 1)
ROOTGROUP=$(egetent group 0 | cut -d ':' -f 1)
+ if useq debug; then
+ ewarn
+ ewarn "WARNING: debug USE flag active!"
+ ewarn "The debug USE flag makes fcron start in debug mode"
+ ewarn "by default, thus not detaching into background."
+ ewarn "This will make your system HANG on bootup if"
+ ewarn "fcron is to be started automatically by the"
+ ewarn "init system!"
+ ewarn
+ ebeep 5
+ epause 60
+ fi
}
src_unpack() {
@@ -105,6 +117,7 @@ src_install() {
newdoc files/fcron.conf fcron.conf.sample
dodoc ${FILESDIR}/crontab
dodoc doc/en/txt/{readme,thanks,faq,todo,relnotes,changes}.txt
+ rm -f doc/en/man/*.3 # ugly hack for bitstring.3 manpage
doman doc/en/man/*.[0-9]
use doc && dohtml doc/en/HTML/*.html
@@ -114,6 +127,7 @@ src_install() {
local lang
for lang in ${LANGUAGES}; do
hasq ${lang} ${LINGUAS} || continue
+ rm -f doc/${lang}/man/*.3 # ugly hack for bitstring.3 manpage
doman -i18n=${lang} doc/${lang}/man/*.[0-9]
use doc && docinto html/${lang} && dohtml doc/${lang}/HTML/*.html
done