summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-07-06 12:33:09 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-07-06 12:33:09 +0000
commit16a7f0b892273dad35604155c5345da676213ce8 (patch)
treecf6bf7e04505d7453996e6ca05e60c215bcfb97a /sys-process
parentVersion bump to the latest. Drop older. (diff)
downloadgentoo-2-16a7f0b892273dad35604155c5345da676213ce8.tar.gz
gentoo-2-16a7f0b892273dad35604155c5345da676213ce8.tar.bz2
gentoo-2-16a7f0b892273dad35604155c5345da676213ce8.zip
Version bump.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/psmisc/ChangeLog9
-rw-r--r--sys-process/psmisc/psmisc-22.14.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sys-process/psmisc/ChangeLog b/sys-process/psmisc/ChangeLog
index 107b473289aa..592a02ecab16 100644
--- a/sys-process/psmisc/ChangeLog
+++ b/sys-process/psmisc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/psmisc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.113 2010/09/20 18:17:27 armin76 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/ChangeLog,v 1.114 2011/07/06 12:33:09 ssuominen Exp $
+
+*psmisc-22.14 (06 Jul 2011)
+
+ 06 Jul 2011; Samuli Suominen <ssuominen@gentoo.org> +psmisc-22.14.ebuild:
+ Version bump.
20 Sep 2010; Raúl Porcel <armin76@gentoo.org> psmisc-22.12.ebuild:
arm/ia64/m68k/s390/sh/sparc stable wrt #336339
diff --git a/sys-process/psmisc/psmisc-22.14.ebuild b/sys-process/psmisc/psmisc-22.14.ebuild
new file mode 100644
index 000000000000..7136131e6fd9
--- /dev/null
+++ b/sys-process/psmisc/psmisc-22.14.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/psmisc/psmisc-22.14.ebuild,v 1.1 2011/07/06 12:33:09 ssuominen Exp $
+
+EAPI=3
+inherit autotools eutils
+
+DESCRIPTION="A set of tools that use the proc filesystem"
+HOMEPAGE="http://psmisc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/psmisc/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="ipv6 nls selinux X"
+
+RDEPEND=">=sys-libs/ncurses-5.2-r2
+ selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ use nls || epatch "${FILESDIR}"/${PN}-22.13-no-nls.patch
+ eautoreconf
+}
+
+src_configure() {
+ # the nls looks weird, but it's because we actually delete the nls stuff
+ # above when USE=-nls. this should get cleaned up so we dont have to patch
+ # it out, but until then, let's not confuse users ... #220787
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable selinux) \
+ $(use_enable ipv6) \
+ $(use nls && use_enable nls)
+}
+
+src_compile() {
+ # peekfd is a fragile crap hack #330631
+ emake -C src peekfd || touch src/peekfd{.o,}
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+ [[ -s ${D}/usr/bin/peekfd ]] || rm -f "${D}"/usr/bin/peekfd
+ use X || rm "${ED}"/usr/bin/pstree.x11
+ # fuser is needed by init.d scripts
+ dodir /bin
+ mv "${ED}"/usr/bin/fuser "${ED}"/bin/ || die
+ # easier to do this than forcing regen of autotools
+ [[ -e ${ED}/usr/bin/peekfd ]] || rm -f "${ED}"/usr/share/man/man1/peekfd.1
+}