summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-29 00:42:43 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-29 00:42:43 +0000
commit47380f92deb0685842b3d590ea6ed451be3a1b17 (patch)
tree3c1f34d2c8c3017df72ca96820647fded8e4014d /sys-process/runit
parentVersion bump to 1.1 and closing bug #127912. (diff)
downloadgentoo-2-47380f92deb0685842b3d590ea6ed451be3a1b17.tar.gz
gentoo-2-47380f92deb0685842b3d590ea6ed451be3a1b17.tar.bz2
gentoo-2-47380f92deb0685842b3d590ea6ed451be3a1b17.zip
Version bump #127877 by Radek Podgorny.
(Portage version: 2.1_pre7-r2)
Diffstat (limited to 'sys-process/runit')
-rw-r--r--sys-process/runit/ChangeLog7
-rw-r--r--sys-process/runit/files/digest-runit-1.4.13
-rw-r--r--sys-process/runit/runit-1.4.1.ebuild63
3 files changed, 72 insertions, 1 deletions
diff --git a/sys-process/runit/ChangeLog b/sys-process/runit/ChangeLog
index 8657cee93afb..e54cf012dbe7 100644
--- a/sys-process/runit/ChangeLog
+++ b/sys-process/runit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/runit
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.7 2006/02/08 23:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/ChangeLog,v 1.8 2006/03/29 00:42:43 vapier Exp $
+
+*runit-1.4.1 (29 Mar 2006)
+
+ 29 Mar 2006; Mike Frysinger <vapier@gentoo.org> +runit-1.4.1.ebuild:
+ Version bump #127877 by Radek Podgorny.
08 Feb 2006; Aron Griffis <agriffis@gentoo.org> runit-1.3.0.ebuild:
Mark 1.3.0 stable on alpha
diff --git a/sys-process/runit/files/digest-runit-1.4.1 b/sys-process/runit/files/digest-runit-1.4.1
new file mode 100644
index 000000000000..648a4248ab1c
--- /dev/null
+++ b/sys-process/runit/files/digest-runit-1.4.1
@@ -0,0 +1,3 @@
+MD5 fcc5cdace4c9d9e290cbbc82af433a8a runit-1.4.1.tar.gz 102747
+RMD160 eea2fa39e07150f211312c92469a91f6b8b6aefd runit-1.4.1.tar.gz 102747
+SHA256 136413fa835648cb16c6a4dc4f2a72285768db99b7f139c04619e17b89bcb2df runit-1.4.1.tar.gz 102747
diff --git a/sys-process/runit/runit-1.4.1.ebuild b/sys-process/runit/runit-1.4.1.ebuild
new file mode 100644
index 000000000000..dd88f45c3f8e
--- /dev/null
+++ b/sys-process/runit/runit-1.4.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/runit/runit-1.4.1.ebuild,v 1.1 2006/03/29 00:42:43 vapier Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A UNIX init scheme with service supervision"
+HOMEPAGE="http://smarden.org/runit/"
+SRC_URI="http://smarden.org/runit/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="static"
+
+DEPEND=""
+
+S=${WORKDIR}/admin/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # we either build everything or nothing static
+ sed -i -e 's:-static: :' src/Makefile
+ use static && append-ldflags -static
+
+ echo "$(tc-getCC) ${CFLAGS}" > src/conf-cc
+ echo "$(tc-getCC) ${LDFLAGS}" > src/conf-ld
+}
+
+src_compile() {
+ cd src
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /var
+ keepdir /etc/runit{,/runsvdir{,/default,/all}}
+ dosym default /etc/runit/runsvdir/current
+ dosym ../etc/runit/runsvdir/current /var/service
+
+ cd src
+ dobin $(<../package/commands) || die "dobin"
+ dodir /sbin
+ mv "${D}"/usr/bin/{runit-init,runit,utmpset} "${D}"/sbin/ || die "dosbin"
+
+ cd "${S}"
+ dodoc package/{CHANGES,README,THANKS,TODO}
+ dohtml doc/*.html
+ doman man/*.[18]
+
+ exeinto /etc/runit
+ doexe "${FILESDIR}"/{1,2,3,ctrlaltdel} || die
+ for tty in tty1 tty2 tty3 tty4 tty5 tty6; do
+ exeinto /etc/runit/runsvdir/all/getty-$tty/
+ for script in run finish; do
+ newexe "${FILESDIR}"/$script.getty $script
+ dosed "s:TTY:${tty}:g" /etc/runit/runsvdir/all/getty-$tty/$script
+ done
+ dosym ../all/getty-$tty /etc/runit/runsvdir/default/getty-$tty
+ done
+}