summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-06 20:22:11 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-06 20:22:11 +0000
commit820e341d6d2d8388ae0d0376b5df29274f613b4e (patch)
treef7fa13871319815136a1ebc0e68abec745a72bea /sys-process/iotop
parentOutput backend change for more versions (diff)
downloadgentoo-2-820e341d6d2d8388ae0d0376b5df29274f613b4e.tar.gz
gentoo-2-820e341d6d2d8388ae0d0376b5df29274f613b4e.tar.bz2
gentoo-2-820e341d6d2d8388ae0d0376b5df29274f613b4e.zip
sys-process/iotop: Fix for py3 and install script in /usr/sbin as intended by upstream #455888
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sys-process/iotop')
-rw-r--r--sys-process/iotop/ChangeLog7
-rw-r--r--sys-process/iotop/iotop-0.5-r1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/sys-process/iotop/ChangeLog b/sys-process/iotop/ChangeLog
index 11852637838c..d7c4d8fb10b4 100644
--- a/sys-process/iotop/ChangeLog
+++ b/sys-process/iotop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-process/iotop
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.58 2013/02/04 07:51:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/ChangeLog,v 1.59 2013/02/06 20:22:11 jlec Exp $
+
+*iotop-0.5-r1 (06 Feb 2013)
+
+ 06 Feb 2013; Justin Lecher <jlec@gentoo.org> +iotop-0.5-r1.ebuild:
+ Fix for py3 and install script in /usr/sbin as intended by upstream #455888
*iotop-0.5 (04 Feb 2013)
diff --git a/sys-process/iotop/iotop-0.5-r1.ebuild b/sys-process/iotop/iotop-0.5-r1.ebuild
new file mode 100644
index 000000000000..05e26a4f6093
--- /dev/null
+++ b/sys-process/iotop/iotop-0.5-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-process/iotop/iotop-0.5-r1.ebuild,v 1.1 2013/02/06 20:22:11 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+PYTHON_REQ_USE="ncurses"
+
+inherit distutils-r1 linux-info
+
+DESCRIPTION="Top-like UI used to show which process is using the I/O"
+HOMEPAGE="http://guichaz.free.fr/iotop/"
+SRC_URI="http://guichaz.free.fr/iotop//files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+CONFIG_CHECK="~TASK_IO_ACCOUNTING ~TASK_DELAY_ACCT ~TASKSTATS ~VM_EVENT_COUNTERS"
+DOCS=( NEWS README THANKS ChangeLog )
+
+pkg_setup() {
+ linux-info_pkg_setup
+}
+
+python_install() {
+ if [[ ${EPYTHON} == *python3* ]]; then
+ 2to3 -w -n "${BUILD_DIR}"/scripts/${PN} || die
+ fi
+ distutils-r1_python_install --install-scripts="${EPREFIX}"/usr/sbin
+}