summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2007-05-10 17:11:39 +0000
committerStefan Schweizer <genstef@gentoo.org>2007-05-10 17:11:39 +0000
commit76e2cf1f770e67796aef2c3ae138f0301ec3ccf2 (patch)
tree172af6285affe7e3d53307b86248d84ab58d9911 /sys-power
parentAdding Adobe Source Code License, covering everything from Adobe Labs (diff)
downloadgentoo-2-76e2cf1f770e67796aef2c3ae138f0301ec3ccf2.tar.gz
gentoo-2-76e2cf1f770e67796aef2c3ae138f0301ec3ccf2.tar.bz2
gentoo-2-76e2cf1f770e67796aef2c3ae138f0301ec3ccf2.zip
Clean up ebuild, use scripts from debian, maintainer back to mobile@, fixes bugs #126131 and #170213
(Portage version: 2.1.2.7)
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/acpid/ChangeLog9
-rw-r--r--sys-power/acpid/acpid-1.0.4-r5.ebuild71
-rw-r--r--sys-power/acpid/files/digest-acpid-1.0.4-r56
-rw-r--r--sys-power/acpid/metadata.xml4
4 files changed, 85 insertions, 5 deletions
diff --git a/sys-power/acpid/ChangeLog b/sys-power/acpid/ChangeLog
index 5865d81e226d..2e5da8c82f07 100644
--- a/sys-power/acpid/ChangeLog
+++ b/sys-power/acpid/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-power/acpid
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.25 2007/02/23 10:55:56 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/ChangeLog,v 1.26 2007/05/10 17:11:39 genstef Exp $
+
+*acpid-1.0.4-r5 (10 May 2007)
+
+ 10 May 2007; Stefan Schweizer <genstef@gentoo.org> metadata.xml,
+ +acpid-1.0.4-r5.ebuild:
+ Clean up ebuild, use scripts from debian, maintainer back to mobile@, fixes
+ bugs #126131 and #170213
*acpid-1.0.4-r4 (23 Feb 2007)
diff --git a/sys-power/acpid/acpid-1.0.4-r5.ebuild b/sys-power/acpid/acpid-1.0.4-r5.ebuild
new file mode 100644
index 000000000000..2c494de1aedf
--- /dev/null
+++ b/sys-power/acpid/acpid-1.0.4-r5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/acpid/acpid-1.0.4-r5.ebuild,v 1.1 2007/05/10 17:11:39 genstef Exp $
+
+inherit eutils toolchain-funcs
+
+DV="acpid_1.0.4-7.1"
+DESCRIPTION="Daemon for Advanced Configuration and Power Interface"
+HOMEPAGE="http://acpid.sourceforge.net"
+SRC_URI="mirror://sourceforge/acpid/${P}.tar.gz
+ mirror://debian/pool/main/a/acpid/${DV}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 -ppc ~x86"
+IUSE="doc logrotate"
+
+DEPEND="sys-apps/sed"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ../${DV}.diff
+}
+
+src_compile() {
+ # DO NOT COMPILE WITH OPTIMISATIONS (bug #22365)
+ # That is a note to the devs. IF you are a user, go ahead and optimise
+ # if you want, but we won't support bugs associated with that.
+ emake CC="$(tc-getCC)" INSTPREFIX="${D}" || die "emake failed"
+}
+
+src_install() {
+ # needed since the Makefile doesn't do 'mkdir -p $(BINDIR)'
+ dodir /usr/bin
+
+ emake INSTPREFIX="${D}" install || die "emake install failed"
+
+ exeinto /etc/acpi
+ doexe examples/default.sh
+ insinto /etc/acpi/events
+ doins examples/default
+
+ dodoc README Changelog TODO
+
+ newinitd ${FILESDIR}/${P}-init.d acpid
+
+ docinto examples
+ dodoc samples/{acpi_handler.sh,sample.conf}
+ dodoc examples/ac{,.sh}
+
+ docinto examples/battery
+ dodoc samples/battery/*
+
+ docinto examples/panasonic
+ dodoc samples/panasonic/*
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins debian/acpid.logrotate acpid
+ fi
+}
+
+pkg_postinst() {
+ echo
+ einfo "You may wish to read the Gentoo Linux Power Management Guide,"
+ einfo "which can be found online at:"
+ einfo " http://www.gentoo.org/doc/en/power-management-guide.xml"
+ echo
+}
diff --git a/sys-power/acpid/files/digest-acpid-1.0.4-r5 b/sys-power/acpid/files/digest-acpid-1.0.4-r5
new file mode 100644
index 000000000000..d2770602fc44
--- /dev/null
+++ b/sys-power/acpid/files/digest-acpid-1.0.4-r5
@@ -0,0 +1,6 @@
+MD5 3aff94e92186e99ed5fd6dcee2db7c74 acpid-1.0.4.tar.gz 23416
+RMD160 ddf3cb4e2df7126c71130f89086473b1aa8656b1 acpid-1.0.4.tar.gz 23416
+SHA256 032a95967f8dd8a227ee1771de4a2646becc4d0f1123568faeca931006ec8f5f acpid-1.0.4.tar.gz 23416
+MD5 de7e2e01ffb8e8bb36d040ace01e0052 acpid_1.0.4-7.1.diff.gz 10356
+RMD160 92ec19825915a354b167a33a093c2d7231d5b848 acpid_1.0.4-7.1.diff.gz 10356
+SHA256 a268a9c3adbe79cee3d0a1ed4eb2fa849039d1d7e9d0aba0e81f55078d42e7f4 acpid_1.0.4-7.1.diff.gz 10356
diff --git a/sys-power/acpid/metadata.xml b/sys-power/acpid/metadata.xml
index b51edd611c30..b27ff8eb4ed6 100644
--- a/sys-power/acpid/metadata.xml
+++ b/sys-power/acpid/metadata.xml
@@ -2,8 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>mobile</herd>
-<maintainer>
- <email>chutzpah@gentoo.org</email>
- <name>Patrick McLean</name>
-</maintainer>
</pkgmetadata>