summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-10-04 22:53:59 +0000
committerMichael Weber <xmw@gentoo.org>2010-10-04 22:53:59 +0000
commit677bc2e735658db052f69a3adcc08847f5c5fb37 (patch)
tree5358aa8e5017efdba8bd5b8d3c4326e49f78d364 /sys-power/suspend
parentVersion bump, now is splitted into pieces which have been added to cvs (diff)
downloadgentoo-2-677bc2e735658db052f69a3adcc08847f5c5fb37.tar.gz
gentoo-2-677bc2e735658db052f69a3adcc08847f5c5fb37.tar.bz2
gentoo-2-677bc2e735658db052f69a3adcc08847f5c5fb37.zip
Add errno.patch
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/suspend')
-rw-r--r--sys-power/suspend/ChangeLog7
-rw-r--r--sys-power/suspend/files/suspend-0.9_pre0-errno.patch10
-rw-r--r--sys-power/suspend/suspend-0.9_pre0.ebuild3
3 files changed, 18 insertions, 2 deletions
diff --git a/sys-power/suspend/ChangeLog b/sys-power/suspend/ChangeLog
index cad155f783a1..24c5e45e8869 100644
--- a/sys-power/suspend/ChangeLog
+++ b/sys-power/suspend/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-power/suspend
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/ChangeLog,v 1.15 2010/10/03 20:29:33 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/ChangeLog,v 1.16 2010/10/04 22:53:59 xmw Exp $
+
+ 04 Oct 2010; Michael Weber <xmw@gentoo.org> suspend-0.9_pre0.ebuild,
+ +files/suspend-0.9_pre0-errno.patch:
+ Add errno.patch by Ole Craig <olc@macmillan-craig.net> on bug #339759,
+ thank you.
*suspend-0.9_pre0 (03 Oct 2010)
diff --git a/sys-power/suspend/files/suspend-0.9_pre0-errno.patch b/sys-power/suspend/files/suspend-0.9_pre0-errno.patch
new file mode 100644
index 000000000000..ea8a378a5abe
--- /dev/null
+++ b/sys-power/suspend/files/suspend-0.9_pre0-errno.patch
@@ -0,0 +1,10 @@
+--- swsusp.h.orig 2010-10-03 13:40:47.000000000 -0600
++++ swsusp.h 2010-10-04 14:38:38.000000000 -0600
+@@ -11,6 +11,7 @@
+
+ #include <stdint.h>
+ #include <linux/fs.h>
++#include <errno.h>
+
+ #include "suspend_ioctls.h"
+ #include "encrypt.h"
diff --git a/sys-power/suspend/suspend-0.9_pre0.ebuild b/sys-power/suspend/suspend-0.9_pre0.ebuild
index fe16bae6ced9..b3d9af97dc2b 100644
--- a/sys-power/suspend/suspend-0.9_pre0.ebuild
+++ b/sys-power/suspend/suspend-0.9_pre0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/suspend-0.9_pre0.ebuild,v 1.1 2010/10/03 20:29:33 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/suspend/suspend-0.9_pre0.ebuild,v 1.2 2010/10/04 22:53:59 xmw Exp $
EAPI=2
@@ -35,6 +35,7 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ epatch "${FILESDIR}"/${PF}-errno.patch
sed -i -e "/AC_INIT/s/0\.8/0.9-${MY_GIT_SHORT_COMMIT}/" configure.ac || die
eautoreconf
}