summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-09-20 03:26:51 +0000
committerRick Farina <zerochaos@gentoo.org>2012-09-20 03:26:51 +0000
commitf15787d194842171053b40096179c9b5fbd5ae08 (patch)
tree8ee2ba8c953d02c2786aeeadaccc5350e9eb96aa /sys-power/powertop
parentstable arm, bug #420727 (diff)
downloadgentoo-2-f15787d194842171053b40096179c9b5fbd5ae08.tar.gz
gentoo-2-f15787d194842171053b40096179c9b5fbd5ae08.tar.bz2
gentoo-2-f15787d194842171053b40096179c9b5fbd5ae08.zip
match linux_config_exists format from other ebuilds to quiet reported warnings
(Portage version: 2.1.11.18/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/powertop')
-rw-r--r--sys-power/powertop/ChangeLog6
-rw-r--r--sys-power/powertop/powertop-2.1-r1.ebuild87
-rw-r--r--sys-power/powertop/powertop-9999.ebuild81
3 files changed, 95 insertions, 79 deletions
diff --git a/sys-power/powertop/ChangeLog b/sys-power/powertop/ChangeLog
index e1996277e87c..73fba5c07946 100644
--- a/sys-power/powertop/ChangeLog
+++ b/sys-power/powertop/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-power/powertop
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.67 2012/09/18 23:36:31 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/ChangeLog,v 1.68 2012/09/20 03:26:51 zerochaos Exp $
+
+ 20 Sep 2012; Rick Farina <zerochaos@gentoo.org> powertop-2.1-r1.ebuild,
+ powertop-9999.ebuild:
+ match linux_config_exists format from other ebuilds to quiet reported warnings
18 Sep 2012; Rick Farina <zerochaos@gentoo.org> powertop-2.1-r1.ebuild,
powertop-9999.ebuild:
diff --git a/sys-power/powertop/powertop-2.1-r1.ebuild b/sys-power/powertop/powertop-2.1-r1.ebuild
index 09941db161d7..eef7d68a79cf 100644
--- a/sys-power/powertop/powertop-2.1-r1.ebuild
+++ b/sys-power/powertop/powertop-2.1-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.7 2012/09/18 23:36:31 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-2.1-r1.ebuild,v 1.8 2012/09/20 03:26:51 zerochaos Exp $
EAPI="4"
inherit eutils linux-info
-if [[ ${PV} == "9999" ]] ; then
+if [ ${PV} == "9999" ] ; then
EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
- inherit git-2
+ inherit git-2 autotools
SRC_URI=""
else
SRC_URI="https://01.org/powertop/sites/default/files/downloads/${P}.tar.gz"
@@ -39,42 +39,51 @@ RDEPEND="
DOCS=( TODO README )
pkg_setup() {
- linux_config_exists
- CONFIG_CHECK="
- ~X86_MSR
- ~DEBUG_FS
- ~PERF_EVENTS
- ~TRACEPOINTS
- ~NO_HZ
- ~HIGH_RES_TIMERS
- ~HPET_TIMER
- ~CPU_FREQ_STAT
- ~CPU_FREQ_GOV_ONDEMAND
- ~USB_SUSPEND
- ~FTRACE
- ~BLK_DEV_IO_TRACE
- ~TIMER_STATS
- ~EVENT_POWER_TRACING_DEPRECATED
- ~TRACING
- "
- linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
- ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_USB_SUSPEND="USB_SUSPEND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
- ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
- ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
- linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK="
+ ~X86_MSR
+ ~DEBUG_FS
+ ~PERF_EVENTS
+ ~TRACEPOINTS
+ ~NO_HZ
+ ~HIGH_RES_TIMERS
+ ~HPET_TIMER
+ ~CPU_FREQ_STAT
+ ~CPU_FREQ_GOV_ONDEMAND
+ ~USB_SUSPEND
+ ~FTRACE
+ ~BLK_DEV_IO_TRACE
+ ~TIMER_STATS
+ ~EVENT_POWER_TRACING_DEPRECATED
+ ~TRACING
+ "
+ linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
+ ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
+ linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_USB_SUSPEND="USB_SUSPEND should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
+ ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
+ linux-info_pkg_setup
+ else
+ ewarn "unable to find kernel config, all checks disabled"
+ fi
+}
+
+src_prepare() {
+ if [ ${PV} == "9999" ] ; then
+ eautoreconf
+ fi
}
src_configure() {
diff --git a/sys-power/powertop/powertop-9999.ebuild b/sys-power/powertop/powertop-9999.ebuild
index 833e60fdb179..97e2a60b83e2 100644
--- a/sys-power/powertop/powertop-9999.ebuild
+++ b/sys-power/powertop/powertop-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.14 2012/09/19 16:22:37 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/powertop/powertop-9999.ebuild,v 1.15 2012/09/20 03:26:51 zerochaos Exp $
EAPI="4"
inherit eutils linux-info
-if [[ ${PV} == "9999" ]] ; then
+if [ ${PV} == "9999" ] ; then
EGIT_REPO_URI="git://github.com/fenrus75/powertop.git"
inherit git-2 autotools
SRC_URI=""
@@ -39,46 +39,49 @@ RDEPEND="
DOCS=( TODO README )
pkg_setup() {
- linux_config_exists
- CONFIG_CHECK="
- ~X86_MSR
- ~DEBUG_FS
- ~PERF_EVENTS
- ~TRACEPOINTS
- ~NO_HZ
- ~HIGH_RES_TIMERS
- ~HPET_TIMER
- ~CPU_FREQ_STAT
- ~CPU_FREQ_GOV_ONDEMAND
- ~USB_SUSPEND
- ~FTRACE
- ~BLK_DEV_IO_TRACE
- ~TIMER_STATS
- ~EVENT_POWER_TRACING_DEPRECATED
- ~TRACING
- "
- linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
- ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
- ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
- linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_USB_SUSPEND="USB_SUSPEND should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
- ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
- ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
- ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
- linux-info_pkg_setup
+ if linux_config_exists; then
+ CONFIG_CHECK="
+ ~X86_MSR
+ ~DEBUG_FS
+ ~PERF_EVENTS
+ ~TRACEPOINTS
+ ~NO_HZ
+ ~HIGH_RES_TIMERS
+ ~HPET_TIMER
+ ~CPU_FREQ_STAT
+ ~CPU_FREQ_GOV_ONDEMAND
+ ~USB_SUSPEND
+ ~FTRACE
+ ~BLK_DEV_IO_TRACE
+ ~TIMER_STATS
+ ~EVENT_POWER_TRACING_DEPRECATED
+ ~TRACING
+ "
+ linux_chkconfig_present SND_HDA_INTEL && CONFIG_CHECK+="~SND_HDA_POWER_SAVE"
+ ERROR_KERNEL_X86_MSR="X86_MSR is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_DEBUG_FS="DEBUG_FS is not enabled in the kernel, you almost certainly need it"
+ ERROR_KERNEL_PERF_EVENTS="PERF_EVENTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACEPOINTS="TRACEPOINTS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_NO_HZ="NO_HZ should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HIGH_RES_TIMERS="HIGH_RES_TIMERS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_HPET_TIMER="HPET_TIMER should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_STAT="CPU_FREQ_STAT should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_CPU_FREQ_GOV_ONDEMAND="CPU_FREQ_GOV_ONDEMAND should be enabled in the kernel for full powertop function"
+ linux_chkconfig_present SND_HDA_INTEL && ERROR_KERNEL_SND_HDA_POWER_SAVE="SND_HDA_POWER_SAVE should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_USB_SUSPEND="USB_SUSPEND should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_FTRACE="FTRACE needs to be turned on to enable BLK_DEV_IO_TRACE"
+ ERROR_KERNEL_BLK_DEV_IO_TRACE="BLK_DEV_IO_TRACE needs to be turned on to enable TIMER_STATS, TRACING and EVENT_POWER_TRACING_DEPRECATED"
+ ERROR_KERNEL_TIMER_STATS="TIMER_STATS should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_EVENT_POWER_TRACING_DEPRECATED="EVENT_POWER_TRACING_DEPRECATED should be enabled in the kernel for full powertop function"
+ ERROR_KERNEL_TRACING="TRACING should be enabled in the kernel for full powertop function"
+ linux-info_pkg_setup
+ else
+ ewarn "unable to find kernel config, all checks disabled"
+ fi
}
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
+ if [ ${PV} == "9999" ] ; then
eautoreconf
fi
}