summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-30 16:56:57 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-30 16:56:57 +0000
commita6f97332c4ff52df91e4b30b38b8f665a2452042 (patch)
tree82e46d837e0a09ca936cabfcf8e6dee68b93a107 /sys-power/iasl
parentDrop die with edos2unix since it does it for us now. (diff)
downloadgentoo-2-a6f97332c4ff52df91e4b30b38b8f665a2452042.tar.gz
gentoo-2-a6f97332c4ff52df91e4b30b38b8f665a2452042.tar.bz2
gentoo-2-a6f97332c4ff52df91e4b30b38b8f665a2452042.zip
Drop die with edos2unix since it does it for us now.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'sys-power/iasl')
-rw-r--r--sys-power/iasl/ChangeLog10
-rw-r--r--sys-power/iasl/iasl-20060912.ebuild8
-rw-r--r--sys-power/iasl/iasl-20080514.ebuild11
-rw-r--r--sys-power/iasl/iasl-20080701.ebuild11
-rw-r--r--sys-power/iasl/iasl-20090123.ebuild11
-rw-r--r--sys-power/iasl/iasl-20090521.ebuild11
-rw-r--r--sys-power/iasl/iasl-20090903.ebuild13
-rw-r--r--sys-power/iasl/iasl-20091013.ebuild13
-rw-r--r--sys-power/iasl/iasl-20100428.ebuild13
-rw-r--r--sys-power/iasl/iasl-20100528.ebuild13
10 files changed, 56 insertions, 58 deletions
diff --git a/sys-power/iasl/ChangeLog b/sys-power/iasl/ChangeLog
index 372deed805e4..92f5d8f13ffb 100644
--- a/sys-power/iasl/ChangeLog
+++ b/sys-power/iasl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-power/iasl
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.32 2010/06/18 06:31:38 robbat2 Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/ChangeLog,v 1.33 2011/09/30 16:56:57 vapier Exp $
+
+ 30 Sep 2011; Mike Frysinger <vapier@gentoo.org> iasl-20060912.ebuild,
+ iasl-20080514.ebuild, iasl-20080701.ebuild, iasl-20090123.ebuild,
+ iasl-20090521.ebuild, iasl-20090903.ebuild, iasl-20091013.ebuild,
+ iasl-20100428.ebuild, iasl-20100528.ebuild:
+ Drop die with edos2unix since it does it for us now.
*iasl-20100528 (18 Jun 2010)
diff --git a/sys-power/iasl/iasl-20060912.ebuild b/sys-power/iasl/iasl-20060912.ebuild
index 814c50862758..cffa6862a0c0 100644
--- a/sys-power/iasl/iasl-20060912.ebuild
+++ b/sys-power/iasl/iasl-20060912.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060912.ebuild,v 1.7 2008/05/26 21:51:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20060912.ebuild,v 1.8 2011/09/30 16:56:57 vapier Exp $
inherit toolchain-funcs eutils
@@ -15,10 +15,10 @@ SRC_URI="http://www.intel.com/technology/iapc/acpi/downloads/${MY_P}.tar.gz"
LICENSE="iASL"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-
IUSE=""
+
DEPEND="sys-devel/bison
- sys-devel/flex"
+ sys-devel/flex"
RDEPEND=""
src_unpack() {
diff --git a/sys-power/iasl/iasl-20080514.ebuild b/sys-power/iasl/iasl-20080514.ebuild
index af0ae2745768..837799d6c07d 100644
--- a/sys-power/iasl/iasl-20080514.ebuild
+++ b/sys-power/iasl/iasl-20080514.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.4 2009/07/31 06:47:10 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080514.ebuild,v 1.5 2011/09/30 16:56:57 vapier Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -15,11 +15,10 @@ SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
LICENSE="iASL"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
IUSE="test"
+
DEPEND="sys-devel/bison
sys-devel/flex"
-
RDEPEND=""
S=${WORKDIR}/${MY_P}
@@ -94,7 +93,7 @@ aslts_test() {
export PATH="${PATH}:${ASLTSDIR}/bin"
echo "$ASLTSDIR" >"${T}"/asltdir
cd "${ASLTSDIR}"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ edos2unix $(find . -type 'f')
make install || die "make install aslts test failed"
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
@@ -107,7 +106,7 @@ aslts_test() {
aapits_test() {
mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ edos2unix $(find . -type 'f')
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
make || die "make in aapits failed"
cd asl || die "cd asl failed"
diff --git a/sys-power/iasl/iasl-20080701.ebuild b/sys-power/iasl/iasl-20080701.ebuild
index 554e938ab651..3c9e71adaab5 100644
--- a/sys-power/iasl/iasl-20080701.ebuild
+++ b/sys-power/iasl/iasl-20080701.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080701.ebuild,v 1.3 2009/07/31 06:47:10 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20080701.ebuild,v 1.4 2011/09/30 16:56:57 vapier Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -15,11 +15,10 @@ SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
LICENSE="iASL"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
IUSE="test"
+
DEPEND="sys-devel/bison
sys-devel/flex"
-
RDEPEND=""
S=${WORKDIR}/${MY_P}
@@ -100,7 +99,7 @@ aslts_test() {
export PATH="${PATH}:${ASLTSDIR}/bin"
echo "$ASLTSDIR" >"${T}"/asltdir
cd "${ASLTSDIR}"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ edos2unix $(find . -type 'f')
make install || die "make install aslts test failed"
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
@@ -113,7 +112,7 @@ aslts_test() {
aapits_test() {
mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ edos2unix $(find . -type 'f')
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
make || die "make in aapits failed"
cd asl || die "cd asl failed"
diff --git a/sys-power/iasl/iasl-20090123.ebuild b/sys-power/iasl/iasl-20090123.ebuild
index 7e3e7e516aec..55dea828a50c 100644
--- a/sys-power/iasl/iasl-20090123.ebuild
+++ b/sys-power/iasl/iasl-20090123.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090123.ebuild,v 1.6 2009/10/07 16:15:23 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090123.ebuild,v 1.7 2011/09/30 16:56:57 vapier Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -15,11 +15,10 @@ SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
LICENSE="iASL"
SLOT="0"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
-
IUSE="test"
+
DEPEND="sys-devel/bison
sys-devel/flex"
-
RDEPEND=""
S=${WORKDIR}/${MY_P}
@@ -103,7 +102,7 @@ aslts_test() {
export PATH="${PATH}:${ASLTSDIR}/bin"
echo "$ASLTSDIR" >"${T}"/asltdir
cd "${ASLTSDIR}"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ edos2unix $(find . -type 'f')
make install || die "make install aslts test failed"
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
@@ -116,7 +115,7 @@ aslts_test() {
aapits_test() {
mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ edos2unix $(find . -type 'f')
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
make || die "make in aapits failed"
cd asl || die "cd asl failed"
diff --git a/sys-power/iasl/iasl-20090521.ebuild b/sys-power/iasl/iasl-20090521.ebuild
index bd875ff4e0ae..a09c4b7faeed 100644
--- a/sys-power/iasl/iasl-20090521.ebuild
+++ b/sys-power/iasl/iasl-20090521.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090521.ebuild,v 1.2 2009/07/31 06:47:10 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090521.ebuild,v 1.3 2011/09/30 16:56:57 vapier Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -15,11 +15,10 @@ SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
LICENSE="iASL"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
IUSE="test"
+
DEPEND="sys-devel/bison
sys-devel/flex"
-
RDEPEND=""
S=${WORKDIR}/${MY_P}
@@ -103,7 +102,7 @@ aslts_test() {
export PATH="${PATH}:${ASLTSDIR}/bin"
echo "$ASLTSDIR" >"${T}"/asltdir
cd "${ASLTSDIR}"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ edos2unix $(find . -type 'f')
make install || die "make install aslts test failed"
chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
@@ -116,7 +115,7 @@ aslts_test() {
aapits_test() {
mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ edos2unix $(find . -type 'f')
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
make || die "make in aapits failed"
cd asl || die "cd asl failed"
diff --git a/sys-power/iasl/iasl-20090903.ebuild b/sys-power/iasl/iasl-20090903.ebuild
index a3512f2b5081..bd0d5fe4a7a3 100644
--- a/sys-power/iasl/iasl-20090903.ebuild
+++ b/sys-power/iasl/iasl-20090903.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090903.ebuild,v 1.1 2009/09/30 01:17:18 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20090903.ebuild,v 1.2 2011/09/30 16:56:57 vapier Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -15,11 +15,10 @@ SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
LICENSE="iASL"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
IUSE="test"
-DEPEND="sys-devel/bison
- sys-devel/flex"
+DEPEND="sys-devel/bison
+ sys-devel/flex"
RDEPEND=""
S=${WORKDIR}/${MY_P}
@@ -104,7 +103,7 @@ aslts_test() {
export PATH="${PATH}:${ASLTSDIR}/bin"
echo "$ASLTSDIR" >"${T}"/asltdir
cd "${ASLTSDIR}"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ edos2unix $(find . -type 'f')
make install || die "make install aslts test failed"
chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
@@ -117,7 +116,7 @@ aslts_test() {
aapits_test() {
mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ edos2unix $(find . -type 'f')
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
make || die "make in aapits failed"
cd asl || die "cd asl failed"
diff --git a/sys-power/iasl/iasl-20091013.ebuild b/sys-power/iasl/iasl-20091013.ebuild
index f81b1fa87d3c..a2282425dc22 100644
--- a/sys-power/iasl/iasl-20091013.ebuild
+++ b/sys-power/iasl/iasl-20091013.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20091013.ebuild,v 1.1 2009/10/23 07:48:13 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20091013.ebuild,v 1.2 2011/09/30 16:56:57 vapier Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -15,11 +15,10 @@ SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
LICENSE="iASL"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
IUSE="test"
-DEPEND="sys-devel/bison
- sys-devel/flex"
+DEPEND="sys-devel/bison
+ sys-devel/flex"
RDEPEND=""
S=${WORKDIR}/${MY_P}
@@ -104,7 +103,7 @@ aslts_test() {
export PATH="${PATH}:${ASLTSDIR}/bin"
echo "$ASLTSDIR" >"${T}"/asltdir
cd "${ASLTSDIR}"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ edos2unix $(find . -type 'f')
make install || die "make install aslts test failed"
chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
@@ -117,7 +116,7 @@ aslts_test() {
aapits_test() {
mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ edos2unix $(find . -type 'f')
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
make || die "make in aapits failed"
cd asl || die "cd asl failed"
diff --git a/sys-power/iasl/iasl-20100428.ebuild b/sys-power/iasl/iasl-20100428.ebuild
index 9f564a28059c..26ad691aab5a 100644
--- a/sys-power/iasl/iasl-20100428.ebuild
+++ b/sys-power/iasl/iasl-20100428.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20100428.ebuild,v 1.1 2010/05/04 17:32:17 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20100428.ebuild,v 1.2 2011/09/30 16:56:57 vapier Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -15,11 +15,10 @@ SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
LICENSE="iASL"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
IUSE="test"
-DEPEND="sys-devel/bison
- sys-devel/flex"
+DEPEND="sys-devel/bison
+ sys-devel/flex"
RDEPEND=""
S=${WORKDIR}/${MY_P}
@@ -104,7 +103,7 @@ aslts_test() {
export PATH="${PATH}:${ASLTSDIR}/bin"
echo "$ASLTSDIR" >"${T}"/asltdir
cd "${ASLTSDIR}"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ edos2unix $(find . -type 'f')
make install || die "make install aslts test failed"
chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
@@ -117,7 +116,7 @@ aslts_test() {
aapits_test() {
mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ edos2unix $(find . -type 'f')
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
make || die "make in aapits failed"
cd asl || die "cd asl failed"
diff --git a/sys-power/iasl/iasl-20100528.ebuild b/sys-power/iasl/iasl-20100528.ebuild
index 3a79ab7fd050..d319afd0a27f 100644
--- a/sys-power/iasl/iasl-20100528.ebuild
+++ b/sys-power/iasl/iasl-20100528.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20100528.ebuild,v 1.1 2010/06/18 06:31:38 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/iasl/iasl-20100528.ebuild,v 1.2 2011/09/30 16:56:57 vapier Exp $
inherit toolchain-funcs flag-o-matic eutils
@@ -15,11 +15,10 @@ SRC_URI="http://www.acpica.org/download/${MY_P}.tar.gz
LICENSE="iASL"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
IUSE="test"
-DEPEND="sys-devel/bison
- sys-devel/flex"
+DEPEND="sys-devel/bison
+ sys-devel/flex"
RDEPEND=""
S=${WORKDIR}/${MY_P}
@@ -104,7 +103,7 @@ aslts_test() {
export PATH="${PATH}:${ASLTSDIR}/bin"
echo "$ASLTSDIR" >"${T}"/asltdir
cd "${ASLTSDIR}"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aslts"
+ edos2unix $(find . -type 'f')
make install || die "make install aslts test failed"
chmod +x $(find bin/ ! -regex 'ERROR_OPCODES|HOW_TO_USE|README' ) || die "chmod bin +x failed"
@@ -117,7 +116,7 @@ aslts_test() {
aapits_test() {
mv "${WORKDIR}/${MY_TESTS_P}/tests/aapits" "${S}/tools/" || die "mv failed"
cd "${S}/tools/aapits" || die "cannot find ${S}/tools/aapits"
- edos2unix $(find . -type 'f') || die "edos2unix failed in aapits"
+ edos2unix $(find . -type 'f')
chmod +x $(find bin/ | sed -r -e '/\/[A-Z_]+$/d') || die "chmod bin +x failed"
make || die "make in aapits failed"
cd asl || die "cd asl failed"