summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-09-17 05:44:10 +0000
committerChristian Heim <phreak@gentoo.org>2006-09-17 05:44:10 +0000
commit8edc3fa9bc34e7dbcb918e0ac33e85ce8349a8cb (patch)
tree82e54fa4b0731b895dd43238b7a2cc35386911ef /sys-power/hibernate-script
parentrevert changes that werent supposed to be committed to the older version #147866 (diff)
downloadgentoo-2-8edc3fa9bc34e7dbcb918e0ac33e85ce8349a8cb.tar.gz
gentoo-2-8edc3fa9bc34e7dbcb918e0ac33e85ce8349a8cb.tar.bz2
gentoo-2-8edc3fa9bc34e7dbcb918e0ac33e85ce8349a8cb.zip
Revision bump, fixing #147832. Moving the scriptlets.d/swsusp2_15 out of the gentoo.patch as it is causing rejects too often (just rm'ing it now within the ebuild). Removing old revisions.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'sys-power/hibernate-script')
-rw-r--r--sys-power/hibernate-script/ChangeLog11
-rw-r--r--sys-power/hibernate-script/files/digest-hibernate-script-1.93-r66
-rw-r--r--sys-power/hibernate-script/hibernate-script-1.93-r6.ebuild73
3 files changed, 89 insertions, 1 deletions
diff --git a/sys-power/hibernate-script/ChangeLog b/sys-power/hibernate-script/ChangeLog
index 29fc98f7008e..8712246efe3f 100644
--- a/sys-power/hibernate-script/ChangeLog
+++ b/sys-power/hibernate-script/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-power/hibernate-script
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.32 2006/09/16 13:55:26 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.33 2006/09/17 05:44:10 phreak Exp $
+
+*hibernate-script-1.93-r6 (17 Sep 2006)
+
+ 17 Sep 2006; Christian Heim <phreak@gentoo.org>
+ -hibernate-script-1.93-r4.ebuild, -hibernate-script-1.93-r5.ebuild,
+ +hibernate-script-1.93-r6.ebuild:
+ Revision bump, fixing #147832. Moving the scriptlets.d/swsusp2_15 out of the
+ gentoo.patch as it is causing rejects too often (just rm'ing it now within
+ the ebuild). Removing old revisions.
*hibernate-script-1.93-r5 (16 Sep 2006)
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r6 b/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r6
new file mode 100644
index 000000000000..e906e5d7492d
--- /dev/null
+++ b/sys-power/hibernate-script/files/digest-hibernate-script-1.93-r6
@@ -0,0 +1,6 @@
+MD5 56ba08798b7404a3a35ffe7c89f4ba21 hibernate-script-1.93-patches-0.4.tar.bz2 2763
+RMD160 020e18249722507947b2fa37ff8350cfad4f6b14 hibernate-script-1.93-patches-0.4.tar.bz2 2763
+SHA256 fe021036d479500818a4e5586df50fc0af05489165b43d38625d76bbbab7533e hibernate-script-1.93-patches-0.4.tar.bz2 2763
+MD5 903e30d67bcdf728f245a71b9ec412e2 hibernate-script-1.93.tar.gz 68644
+RMD160 bbb59d7ac5c7a26667cb00c5dd32224ad3eb8f01 hibernate-script-1.93.tar.gz 68644
+SHA256 8020d653cc09d1724f700e2b28cf5ce83eef3ffd287304141357eef2c22db366 hibernate-script-1.93.tar.gz 68644
diff --git a/sys-power/hibernate-script/hibernate-script-1.93-r6.ebuild b/sys-power/hibernate-script/hibernate-script-1.93-r6.ebuild
new file mode 100644
index 000000000000..4f26b2bc1547
--- /dev/null
+++ b/sys-power/hibernate-script/hibernate-script-1.93-r6.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.93-r6.ebuild,v 1.1 2006/09/17 05:44:10 phreak Exp $
+
+inherit eutils
+
+PATCH_VERSION="0.4"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+ http://dev.gentoo.org/~phreak/distfiles/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ rm -f "${S}"/scriptlets.d/swsusp2_15
+ epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+ BASE_DIR="${D}" PREFIX=/usr MAN_DIR="${D}"/usr/share/man \
+ "${S}"/install.sh
+
+ # hibernate-ram will default to using ram.conf
+ dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+ newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+ # other ebuilds can install scriplets to this dir
+ keepdir /etc/hibernate/scriptlets.d/
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles
+ doins hibernate.vim
+ fi
+
+ dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+ if use logrotate; then
+ insinto /etc/logrotate.d
+ newins "${S}"/logrotate.d-hibernate-script hibernate-script
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You should run the following command to invalidate"
+ einfo "suspend images on a clean boot."
+ einfo
+ einfo " # rc-update add hibernate-cleanup boot"
+ einfo
+ einfo "See /usr/share/doc/${PF}/README.gz for further details."
+ einfo
+ einfo "Please note that you will need to manually emerge any utilities"
+ einfo "(radeontool, vbetool, ...) enabled in the configuration files,"
+ einfo "should you wish to use them."
+ einfo
+ einfo "Starting with hibernate-script-1.90 the configuration files have"
+ einfo "been reordered and split into method specific files. Make sure you"
+ einfo "update your /etc/hibernate/ configuration files accordingly."
+ einfo
+}