summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-04-05 16:55:23 +0000
committerHanno Böck <hanno@gentoo.org>2009-04-05 16:55:23 +0000
commitb7717b3d0a2e145b8ff46f2a7b0e2a5432b62b6b (patch)
treebd02bb6a3e6ebf005583ed6fa80667c11e0b0b5a /sys-libs
parentamd64/x86 stable, bug #264392 (diff)
downloadgentoo-2-b7717b3d0a2e145b8ff46f2a7b0e2a5432b62b6b.tar.gz
gentoo-2-b7717b3d0a2e145b8ff46f2a7b0e2a5432b62b6b.tar.bz2
gentoo-2-b7717b3d0a2e145b8ff46f2a7b0e2a5432b62b6b.zip
gwenhywfar bump
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-3.8.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 0b40528574fc..487b13d68b50 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.63 2009/03/02 17:50:17 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.64 2009/04/05 16:55:23 hanno Exp $
+
+*gwenhywfar-3.8.0 (05 Apr 2009)
+
+ 05 Apr 2009; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-3.8.0.ebuild:
+ Version bump.
*gwenhywfar-3.7.2 (02 Mar 2009)
diff --git a/sys-libs/gwenhywfar/gwenhywfar-3.8.0.ebuild b/sys-libs/gwenhywfar/gwenhywfar-3.8.0.ebuild
new file mode 100644
index 000000000000..fad97d7ed66b
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-3.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-3.8.0.ebuild,v 1.1 2009/04/05 16:55:23 hanno Exp $
+
+inherit flag-o-matic
+
+append-ldflags -Wl,--no-as-needed
+RESTRICT="test"
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+RDEPEND="ssl? ( net-libs/gnutls )
+ sys-libs/ncurses
+ ncurses? ( sys-libs/ncurses )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ econf \
+ $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable doc full-doc) \
+ $(use_enable ncurses gwenui) \
+ --with-docpath="/usr/share/doc/${PF}/apidoc" || die "configure failed"
+ emake || die "emake failed"
+ if use doc ; then
+ emake srcdoc || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README* AUTHORS ChangeLog TODO || die "dodoc failed"
+ if use doc ; then
+ make DESTDIR="${D}" install-srcdoc || die "install doc failed"
+ fi
+ find "${D}" -name '*.la' -delete
+}