summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-12-05 06:45:55 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-12-05 06:45:55 +0000
commita4c2dcc2e7275ffa3ce8ec4384f85c215fe10fd8 (patch)
treea1d91a8fc40e22affa20cc6a7538d6b356b12655 /sys-libs
parentBump (diff)
downloadgentoo-2-a4c2dcc2e7275ffa3ce8ec4384f85c215fe10fd8.tar.gz
gentoo-2-a4c2dcc2e7275ffa3ce8ec4384f85c215fe10fd8.tar.bz2
gentoo-2-a4c2dcc2e7275ffa3ce8ec4384f85c215fe10fd8.zip
Bump
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/tdb/ChangeLog7
-rw-r--r--sys-libs/tdb/tdb-1.2.11.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/tdb/ChangeLog b/sys-libs/tdb/ChangeLog
index 4cecba223afa..cd632ccd5879 100644
--- a/sys-libs/tdb/ChangeLog
+++ b/sys-libs/tdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/tdb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.49 2012/11/29 15:03:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/ChangeLog,v 1.50 2012/12/05 06:45:55 patrick Exp $
+
+*tdb-1.2.11 (05 Dec 2012)
+
+ 05 Dec 2012; Patrick Lauer <patrick@gentoo.org> +tdb-1.2.11.ebuild:
+ Bump
29 Nov 2012; Jeroen Roovers <jer@gentoo.org> tdb-1.2.10.ebuild:
Stable for HPPA (bug #444686).
diff --git a/sys-libs/tdb/tdb-1.2.11.ebuild b/sys-libs/tdb/tdb-1.2.11.ebuild
new file mode 100644
index 000000000000..26e47021d556
--- /dev/null
+++ b/sys-libs/tdb/tdb-1.2.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/tdb/tdb-1.2.11.ebuild,v 1.1 2012/12/05 06:45:55 patrick Exp $
+
+EAPI=3
+PYTHON_DEPEND="python? 2"
+RESTRICT_PYTHON_ABIS="3.* *-jython 2.7-pypy-*"
+
+inherit waf-utils python
+
+DESCRIPTION="A simple database API"
+HOMEPAGE="http://tdb.samba.org/"
+SRC_URI="http://samba.org/ftp/tdb/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux"
+IUSE="python"
+
+RDEPEND=""
+DEPEND="|| ( dev-lang/python:2.7 dev-lang/python:2.6 )
+ app-text/docbook-xml-dtd:4.2"
+
+WAF_BINARY="${S}/buildtools/bin/waf"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local extra_opts=""
+ use python || extra_opts+=" --disable-python"
+ waf-utils_src_configure \
+ ${extra_opts}
+}
+
+src_test() {
+ # the default src_test runs 'make test' and 'make check', letting
+ # the tests fail occasionally (reason: unknown)
+ emake check || die "emake check failed"
+}