summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2007-03-25 20:58:24 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2007-03-25 20:58:24 +0000
commit7e5f6ff5a496ae2c7ebf425957b6d004bf955ca8 (patch)
treee08c5f3b004688ec97c913fb8455be47c9ee1a54 /sys-libs
parentpatch added; ready for VDR 1.5.x (diff)
downloadgentoo-2-7e5f6ff5a496ae2c7ebf425957b6d004bf955ca8.tar.gz
gentoo-2-7e5f6ff5a496ae2c7ebf425957b6d004bf955ca8.tar.bz2
gentoo-2-7e5f6ff5a496ae2c7ebf425957b6d004bf955ca8.zip
Fix the not stripping of utilities
(Portage version: 2.1.2.2)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/db/ChangeLog6
-rw-r--r--sys-libs/db/db-4.5.20_p2.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index b1b4bb57b601..601e0495a3bb 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/db
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.200 2007/03/02 17:33:26 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.201 2007/03/25 20:58:24 pauldv Exp $
+
+ 25 Mar 2007; Paul de Vrieze <pauldv@gentoo.org> db-4.5.20_p2.ebuild:
+ Have a different fix for not stripping as the old fix no longer works for this
+ db version.
02 Mar 2007; Caleb Tennis <caleb@gentoo.org> -files/db-4.1.25-java.patch,
-files/db-4.1.25-uclibc.patch, -files/db-4.1.25_p1-jarlocation.patch,
diff --git a/sys-libs/db/db-4.5.20_p2.ebuild b/sys-libs/db/db-4.5.20_p2.ebuild
index 6637ddac49da..0e004b24f04d 100644
--- a/sys-libs/db/db-4.5.20_p2.ebuild
+++ b/sys-libs/db/db-4.5.20_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2.ebuild,v 1.4 2007/02/28 13:22:15 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-4.5.20_p2.ebuild,v 1.5 2007/03/25 20:58:24 pauldv Exp $
inherit eutils db flag-o-matic java-pkg-opt-2
@@ -103,11 +103,14 @@ src_compile() {
--host="${CHOST}" \
${myconf} "${javaconf}" || die "configure failed"
+ sed -e "s,\(^STRIP *=\).*,\1\"none\"," Makefile > Makefile.cpy \
+ && mv Makefile.cpy Makefile
+
emake -j1 || die "make failed"
}
src_install() {
- einstall libdir="${D}/usr/$(get_libdir)" strip="${D}/bin/strip" || die
+ einstall libdir="${D}/usr/$(get_libdir)" STRIP="none" || die
db_src_install_usrbinslot