summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-15 03:10:56 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-15 03:10:56 +0000
commit4d6db7f8cc31588b817d1121c5fdc1eb9c0bb75c (patch)
tree4f5ed35cb75bd418b01bc6c593432b095a793070 /sys-libs
parentVersion bump. (diff)
downloadgentoo-2-4d6db7f8cc31588b817d1121c5fdc1eb9c0bb75c.tar.gz
gentoo-2-4d6db7f8cc31588b817d1121c5fdc1eb9c0bb75c.tar.bz2
gentoo-2-4d6db7f8cc31588b817d1121c5fdc1eb9c0bb75c.zip
get rid of $ARCH ... use $(tc-arch) since it is cross-compile friendly atm
(Portage version: 2.0.51-r12)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.2-r12.ebuild39
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild63
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20041102.ebuild59
3 files changed, 86 insertions, 75 deletions
diff --git a/sys-libs/glibc/glibc-2.3.2-r12.ebuild b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
index 8aaa67fb13c9..16e54478acbc 100644
--- a/sys-libs/glibc/glibc-2.3.2-r12.ebuild
+++ b/sys-libs/glibc/glibc-2.3.2-r12.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.6 2005/01/14 02:51:58 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.2-r12.ebuild,v 1.7 2005/01/15 03:10:55 vapier Exp $
-inherit eutils flag-o-matic gcc
+inherit eutils flag-o-matic toolchain-funcs
# Branch update support. Following will disable:
# BRANCH_UPDATE=
@@ -120,7 +120,7 @@ use_nptl() {
# - Or we have 'amd64' in USE
# - Or we have 'mips' in USE
# - Or we have 'ppc' in USE
- case ${ARCH} in
+ case $(tc-arch ${CTARGET}) in
"x86")
if [ "${CHOST/-*}" = "i486" -o \
"${CHOST/-*}" = "i586" -o \
@@ -292,18 +292,15 @@ src_unpack() {
cd ${S}
# Extract our threads package ...
- if (! use_nptl) && [ -z "${BRANCH_UPDATE}" ]
- then
+ if (! use_nptl) && [[ -z ${BRANCH_UPDATE} ]] ; then
unpack glibc-linuxthreads-${MY_PV}.tar.bz2
fi
- if [ -n "${BRANCH_UPDATE}" ]
- then
+ if [[ -n ${BRANCH_UPDATE} ]] ; then
epatch ${DISTDIR}/${P}-branch-update-${BRANCH_UPDATE}.patch.bz2
fi
- if use_nptl
- then
+ if use_nptl ; then
epatch ${FILESDIR}/2.3.2/${P}-redhat-nptl-fixes.patch
else
epatch ${FILESDIR}/2.3.2/${P}-redhat-linuxthreads-fixes.patch
@@ -313,8 +310,7 @@ src_unpack() {
# __guard_setup__stack_smash_handler
#
# http://www.gentoo.org/proj/en/hardened/etdyn-ssp.xml
- if [ "${ARCH}" != "hppa" -a "${ARCH}" != "hppa64" ]
- then
+ if [[ $(tc-arch ${CTARGET}) != "hppa" ]] ; then
cd ${S}; epatch ${FILESDIR}/${PV}/${P}-propolice-guard-functions-v2.patch
fi
@@ -382,8 +378,7 @@ src_unpack() {
# do can be found in the patch headers.
# <tuxus@gentoo.org> thx <dragon@gentoo.org> (11 Jan 2003)
# <kumba@gentoo.org> remove tst-rndseek-mips & ulps-mips patches
- if [ "${ARCH}" = "mips" ]
- then
+ if [[ $(tc-arch ${CTARGET}) == "mips" ]] ; then
cd ${S}
epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-fpu-cw-mips.patch
epatch ${FILESDIR}/2.3.1/${PN}-2.3.1-libgcc-compat-mips.patch
@@ -394,8 +389,7 @@ src_unpack() {
epatch ${FILESDIR}/2.3.2/${P}-mips-fix-nested-entend-pairs.patch
fi
- if [ "${ARCH}" = "alpha" ]
- then
+ if [[ $(tc-arch ${CTARGET}) == "alpha" ]] ; then
cd ${S}
# Fix compatability with compaq compilers by ifdef'ing out some
# 2.3.2 additions.
@@ -410,13 +404,11 @@ src_unpack() {
epatch ${FILESDIR}/2.3.2/${P}-alpha-sysdeps.patch
fi
- if [ "${ARCH}" = "amd64" ]
- then
+ if [[ $(tc-arch ${CTARGET}) == "amd64" ]] ; then
cd ${S}; epatch ${FILESDIR}/2.3.2/${P}-amd64-nomultilib.patch
fi
- if [ "${ARCH}" = "ia64" ]
- then
+ if [[ $(tc-arch ${CTARGET}) == "ia64" ]] ; then
# The basically problem is glibc doesn't store information about
# what the kernel interface is so that it can't efficiently set up
# parameters for system calls. This patch from H.J. Lu fixes it:
@@ -426,8 +418,7 @@ src_unpack() {
cd ${S}; epatch ${FILESDIR}/2.3.2/${P}-ia64-LOAD_ARGS-fixup.patch
fi
- if [ "${ARCH}" = "hppa" ]
- then
+ if [[ $(tc-arch ${CTARGET}) == "hppa" ]] ; then
cd ${WORKDIR}
unpack ${P}-hppa-patches-p1.tar.bz2
cd ${S}
@@ -445,8 +436,7 @@ src_unpack() {
patch -p 1 < ${FILESDIR}/2.3.1/glibc23-07-hppa-atomicity.dpatch
fi
- if [ "${ARCH}" = "s390" ]
- then
+ if [[ $(tc-arch ${CTARGET}) == "s390" ]] ; then
# The deprecated ustat.h causes problems on s390
#
# http://sources.redhat.com/ml/bug-glibc/2003-08/msg00020.html
@@ -455,8 +445,7 @@ src_unpack() {
cd ${S}/sysdeps/unix/sysv/linux; epatch ${FILESDIR}/2.3.2/${P}-s390-deprecated-ustat-fixup.patch
fi
- if [ "${ARCH}" == "arm" ]
- then
+ if [[ $(tc-arch ${CTARGET}) == "arm" ]] ; then
cd ${S}
# sjlj exceptions causes undefined frame variables (ported from cvs)
epatch ${FILESDIR}/2.3.2/${P}-framestate-USING_SJLJ_EXCEPTIONS.patch
diff --git a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
index baed6425c56d..205ff474861a 100644
--- a/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.34 2005/01/14 13:35:23 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20040808-r1.ebuild,v 1.35 2005/01/15 03:10:55 vapier Exp $
-inherit eutils multilib flag-o-matic gcc versionator
+inherit eutils multilib flag-o-matic toolchain-funcs versionator
# Branch update support. Following will disable:
# BRANCH_UPDATE=
@@ -349,7 +349,22 @@ pkg_setup() {
}
+do_arch_alpha_patches() {
+ [[ $(tc-arch ${CTARGET}) != "alpha" ]] && return 0
+ cd ${S}
+
+ # Fix compatability with compaq compilers by ifdef'ing out some
+ # 2.3.2 additions.
+ # <taviso@gentoo.org> (14 Jun 2003).
+ epatch ${FILESDIR}/2.3.2/${PN}-2.3.2-decc-compaq.patch
+
+ # Fix compilation with >=gcc-3.2.3 (01 Nov 2003 agriffis)
+# epatch ${FILESDIR}/2.3.2/${LOCAL_P}-alpha-pwrite.patch
+}
+
+
do_arch_amd64_patches() {
+ [[ $(tc-arch ${CTARGET}) != "amd64" ]] && return 0
cd ${S};
if [ -z "${MULTILIB_ABIS}" ]; then
@@ -365,20 +380,8 @@ do_arch_amd64_patches() {
}
-do_arch_alpha_patches() {
- cd ${S}
-
- # Fix compatability with compaq compilers by ifdef'ing out some
- # 2.3.2 additions.
- # <taviso@gentoo.org> (14 Jun 2003).
- epatch ${FILESDIR}/2.3.2/${PN}-2.3.2-decc-compaq.patch
-
- # Fix compilation with >=gcc-3.2.3 (01 Nov 2003 agriffis)
-# epatch ${FILESDIR}/2.3.2/${LOCAL_P}-alpha-pwrite.patch
-}
-
-
do_arch_arm_patches() {
+ [[ $(tc-arch ${CTARGET}) != "arm" ]] && return 0
cd ${S};
# Any needed patches for arm go here
@@ -387,6 +390,7 @@ do_arch_arm_patches() {
do_arch_hppa_patches() {
+ [[ $(tc-arch ${CTARGET}) != "hppa" ]] && return 0
einfo "Applying hppa specific path of ${HPPA_PATCHES} ..."
cd ${T}
unpack glibc-hppa-patches-${HPPA_PATCHES}.tar.gz
@@ -405,6 +409,7 @@ do_arch_hppa_patches() {
do_arch_ia64_patches() {
+ [[ $(tc-arch ${CTARGET}) != "ia64" ]] && return 0
cd ${S};
# The basically problem is glibc doesn't store information about
@@ -424,6 +429,7 @@ do_arch_ia64_patches() {
do_arch_mips_patches() {
+ [[ $(tc-arch ${CTARGET}) != "mips" ]] && return 0
cd ${S}
# A few patches only for the MIPS platform. Descriptions of what they
@@ -447,6 +453,7 @@ do_arch_mips_patches() {
do_arch_ppc_patches() {
+ [[ $(tc-arch ${CTARGET}) != "ppc" ]] && return 0
cd ${S};
epatch ${FILESDIR}/2.3.4/glibc-2.3.4-getcontext.patch
# Any needed patches for ppc go here
@@ -454,6 +461,7 @@ do_arch_ppc_patches() {
do_arch_ppc64_patches() {
+ [[ $(tc-arch ${CTARGET}) != "ppc64" ]] && return 0
cd ${S};
epatch ${FILESDIR}/2.3.4/glibc-2.3.4-getcontext.patch
# Any needed patches for ppc64 go here
@@ -461,6 +469,7 @@ do_arch_ppc64_patches() {
do_arch_s390_patches() {
+ [[ $(tc-arch ${CTARGET}) != "s390" ]] && return 0
cd ${S};
# Any needed patches for s390 go here
@@ -468,6 +477,7 @@ do_arch_s390_patches() {
do_arch_sparc_patches() {
+ [[ $(tc-arch ${CTARGET}) != "sparc" ]] && return 0
cd ${S};
# Any needed patches for sparc go here
@@ -475,6 +485,7 @@ do_arch_sparc_patches() {
do_arch_x86_patches() {
+ [[ $(tc-arch ${CTARGET}) != "x86" ]] && return 0
cd ${S};
# CONF_LIBDIR support
epatch ${FILESDIR}/2.3.4/glibc-gentoo-libdir.patch
@@ -581,17 +592,17 @@ src_unpack() {
do_hardened_fixes
# Arch specific patching
- use amd64 && do_arch_amd64_patches
- use alpha && do_arch_alpha_patches
- use arm && do_arch_arm_patches
- use hppa && do_arch_hppa_patches
- use ia64 && do_arch_ia64_patches
- use mips && do_arch_mips_patches
- use ppc && do_arch_ppc_patches
- use ppc64 && do_arch_ppc64_patches
- use s390 && do_arch_s390_patches
- use sparc && do_arch_sparc_patches
- use x86 && do_arch_x86_patches
+ do_arch_alpha_patches
+ do_arch_amd64_patches
+ do_arch_arm_patches
+ do_arch_hppa_patches
+ do_arch_ia64_patches
+ do_arch_mips_patches
+ do_arch_ppc_patches
+ do_arch_ppc64_patches
+ do_arch_s390_patches
+ do_arch_sparc_patches
+ do_arch_x86_patches
# Remaining patches
cd ${S}
diff --git a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
index afaa9b1bf865..7c7b848d1a9d 100644
--- a/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20041102.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.30 2005/01/14 21:44:00 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20041102.ebuild,v 1.31 2005/01/15 03:10:56 vapier Exp $
-inherit eutils multilib flag-o-matic gcc versionator
+inherit eutils multilib flag-o-matic toolchain-funcs versionator
# Branch update support. Following will disable:
# BRANCH_UPDATE=
@@ -358,18 +358,8 @@ pkg_setup() {
}
-do_arch_amd64_patches() {
- cd ${S}
-
- if [ -z "${MULTILIB_ABIS}" ]; then
- # CONF_LIBDIR support
- epatch ${FILESDIR}/2.3.4/glibc-gentoo-libdir.patch
- sed -i -e "s:@GENTOO_LIBDIR@:$(get_libdir):g" ${S}/sysdeps/unix/sysv/linux/configure
- fi
-}
-
-
do_arch_alpha_patches() {
+ [[ $(tc-arch ${CTARGET}) != "alpha" ]] && return 0
cd ${S}
# Fix compatability with compaq compilers by ifdef'ing out some
@@ -382,7 +372,20 @@ do_arch_alpha_patches() {
}
+do_arch_amd64_patches() {
+ [[ $(tc-arch ${CTARGET}) != "amd64" ]] && return 0
+ cd ${S}
+
+ if [ -z "${MULTILIB_ABIS}" ]; then
+ # CONF_LIBDIR support
+ epatch ${FILESDIR}/2.3.4/glibc-gentoo-libdir.patch
+ sed -i -e "s:@GENTOO_LIBDIR@:$(get_libdir):g" ${S}/sysdeps/unix/sysv/linux/configure
+ fi
+}
+
+
do_arch_arm_patches() {
+ [[ $(tc-arch ${CTARGET}) != "arm" ]] && return 0
cd ${S};
# Any needed patches for arm go here
@@ -391,6 +394,7 @@ do_arch_arm_patches() {
do_arch_hppa_patches() {
+ [[ $(tc-arch ${CTARGET}) != "hppa" ]] && return 0
einfo "Applying hppa specific path of ${HPPA_PATCHES} ..."
cd ${T}
unpack glibc-hppa-patches-${HPPA_PATCHES}.tar.gz
@@ -409,6 +413,7 @@ do_arch_hppa_patches() {
do_arch_ia64_patches() {
+ [[ $(tc-arch ${CTARGET}) != "ia64" ]] && return 0
cd ${S};
# The basically problem is glibc doesn't store information about
@@ -422,6 +427,7 @@ do_arch_ia64_patches() {
do_arch_mips_patches() {
+ [[ $(tc-arch ${CTARGET}) != "mips" ]] && return 0
cd ${S}
# A few patches only for the MIPS platform. Descriptions of what they
@@ -444,12 +450,14 @@ do_arch_mips_patches() {
do_arch_ppc_patches() {
+ [[ $(tc-arch ${CTARGET}) != "ppc" ]] && return 0
cd ${S};
# Any needed patches for ppc go here
}
do_arch_ppc64_patches() {
+ [[ $(tc-arch ${CTARGET}) != "ppc64" ]] && return 0
cd ${S};
# Any needed patches for ppc64 go here
@@ -459,6 +467,7 @@ do_arch_ppc64_patches() {
do_arch_s390_patches() {
+ [[ $(tc-arch ${CTARGET}) != "s390" ]] && return 0
cd ${S};
# Any needed patches for s390 go here
@@ -466,6 +475,7 @@ do_arch_s390_patches() {
do_arch_sparc_patches() {
+ [[ $(tc-arch ${CTARGET}) != "sparc" ]] && return 0
cd ${S};
# Any needed patches for sparc go here
@@ -473,6 +483,7 @@ do_arch_sparc_patches() {
do_arch_x86_patches() {
+ [[ $(tc-arch ${CTARGET}) != "x86" ]] && return 0
cd ${S};
# CONF_LIBDIR support
epatch ${FILESDIR}/2.3.4/glibc-gentoo-libdir.patch
@@ -606,17 +617,17 @@ src_unpack() {
# Arch specific patching
- use amd64 && do_arch_amd64_patches
- use alpha && do_arch_alpha_patches
- use arm && do_arch_arm_patches
- use hppa && do_arch_hppa_patches
- use ia64 && do_arch_ia64_patches
- use mips && do_arch_mips_patches
- use ppc && do_arch_ppc_patches
- use ppc64 && do_arch_ppc64_patches
- use s390 && do_arch_s390_patches
- use sparc && do_arch_sparc_patches
- use x86 && do_arch_x86_patches
+ do_arch_alpha_patches
+ do_arch_amd64_patches
+ do_arch_arm_patches
+ do_arch_hppa_patches
+ do_arch_ia64_patches
+ do_arch_mips_patches
+ do_arch_ppc_patches
+ do_arch_ppc64_patches
+ do_arch_s390_patches
+ do_arch_sparc_patches
+ do_arch_x86_patches
# Remaining patches