summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2005-03-31 12:57:23 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2005-03-31 12:57:23 +0000
commit07fd33e029d962ba9aa96cbd5b791dcc4f6c838c (patch)
treeaae3da816a6988261056fd92d45bdc6ae2eb741e /sys-libs
parentVersion bump, bug #86708 (diff)
downloadgentoo-2-07fd33e029d962ba9aa96cbd5b791dcc4f6c838c.tar.gz
gentoo-2-07fd33e029d962ba9aa96cbd5b791dcc4f6c838c.tar.bz2
gentoo-2-07fd33e029d962ba9aa96cbd5b791dcc4f6c838c.zip
Fixing gconvdir on multilib archs, BUG #86861
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/ChangeLog6
-rw-r--r--sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild9
2 files changed, 11 insertions, 4 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 16eb30ace017..c2e0f065d6d1 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/glibc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.330 2005/03/23 21:18:24 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.331 2005/03/31 12:57:23 kugelfang Exp $
+
+ 31 Mar 2005; Danny van Dyk <kugelfang@gentoo.org>
+ glibc-2.3.4.20050125-r1.ebuild:
+ Fixed gconvdir on multilib arches, BUG #86861.
23 Mar 2005; Martin Schlemmer <azarah@gentoo.org>
glibc-2.3.4.20041102-r1.ebuild, glibc-2.3.4.20050125-r1.ebuild:
diff --git a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
index 7157e8e27947..502fe476844d 100644
--- a/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
+++ b/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.32 2005/03/25 06:17:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.4.20050125-r1.ebuild,v 1.33 2005/03/31 12:57:23 kugelfang Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -228,17 +228,20 @@ toolchain-glibc_src_unpack() {
}
toolchain-glibc_src_compile() {
+ # Set gconvdir to /usr/$(get_libdir)/gconv on archs with multiple ABIs
+ has_multilib_profile && MAKEFLAGS="gconvdir=$(alt_usrlibdir)/gconv"
+
if want_linuxthreads ; then
glibc_do_configure linuxthreads
einfo "Building GLIBC with linuxthreads..."
- make PARALLELMFLAGS="${MAKEOPTS}" || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
fi
if want_nptl ; then
# ... and then do the optional nptl build
unset LD_ASSUME_KERNEL || :
glibc_do_configure nptl
einfo "Building GLIBC with NPTL..."
- make PARALLELMFLAGS="${MAKEOPTS}" || die
+ make PARALLELMFLAGS="${MAKEOPTS}" ${MAKEFLAGS} || die
fi
}