summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2007-02-14 17:01:11 +0000
committerLuca Barbato <lu_zero@gentoo.org>2007-02-14 17:01:11 +0000
commitac46634a56e26a491241ea92b27c48c563a997c1 (patch)
tree39b55a4c793b7e3a8e48e4d4d908f8e3ab0a1dba /sys-libs/newlib
parentAdded xalan to dependencies as it was missing there. (diff)
downloadgentoo-2-ac46634a56e26a491241ea92b27c48c563a997c1.tar.gz
gentoo-2-ac46634a56e26a491241ea92b27c48c563a997c1.tar.bz2
gentoo-2-ac46634a56e26a491241ea92b27c48c563a997c1.zip
Cleanup, bug #166707
(Portage version: 2.1.2-r9)
Diffstat (limited to 'sys-libs/newlib')
-rw-r--r--sys-libs/newlib/ChangeLog9
-rw-r--r--sys-libs/newlib/files/digest-newlib-200612033
-rw-r--r--sys-libs/newlib/newlib-20061203.ebuild76
3 files changed, 8 insertions, 80 deletions
diff --git a/sys-libs/newlib/ChangeLog b/sys-libs/newlib/ChangeLog
index fbab7562c623..f054b30907ea 100644
--- a/sys-libs/newlib/ChangeLog
+++ b/sys-libs/newlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/newlib
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.6 2007/02/05 14:51:50 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.7 2007/02/14 17:01:11 lu_zero Exp $
+
+ 14 Feb 2007; Luca Barbato <lu_zero@gentoo.org> -newlib-20061203.ebuild:
+ Cleanup, thanks to rx Kaffee <rxKaffee@unixtriad.com> for pointing out in
+ bug #166707
+
+ 14 Feb 2007; Luca Barbato <lu_zero@gentoo.org> -newlib-20061203.ebuild:
+ Cleanup, thanks to rx Kaffee <rxKaffee@unixtriad.com>
05 Feb 2007; Luca Barbato <lu_zero@gentoo.org> newlib-1.15.0.ebuild:
Make it in line with uclibc, as asked by Flameeyes
diff --git a/sys-libs/newlib/files/digest-newlib-20061203 b/sys-libs/newlib/files/digest-newlib-20061203
deleted file mode 100644
index 0ccab2649ca2..000000000000
--- a/sys-libs/newlib/files/digest-newlib-20061203
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 3410a58ad88025a837c1d4abead01123 newlib-20061203.tar.bz2 6664575
-RMD160 ad4b1495e4fd7e94060a63b27719fb18d3b3082d newlib-20061203.tar.bz2 6664575
-SHA256 900fd7d076367f36594c87f422513dbf7b46045a27f20c25954807af3705d320 newlib-20061203.tar.bz2 6664575
diff --git a/sys-libs/newlib/newlib-20061203.ebuild b/sys-libs/newlib/newlib-20061203.ebuild
deleted file mode 100644
index 46725a20e428..000000000000
--- a/sys-libs/newlib/newlib-20061203.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-20061203.ebuild,v 1.3 2007/02/12 05:05:23 vapier Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-# Handle the case where we want newlib on glibc ...
-if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
- export CTARGET=${CHOST%%-*}-pc-linux-newlib
-fi
-
-DESCRIPTION="Newlib is a C library intended for use on embedded systems"
-HOMEPAGE="http://sourceware.org/newlib/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-
-LICENSE="NEWLIB LIBGLOSS GPL-2"
-[[ ${CTARGET} != ${CHOST} ]] \
- && SLOT="${CTARGET}" \
- || SLOT="0"
-KEYWORDS="-* ~ppc64 ~ppc"
-IUSE="nls threads unicode multilib"
-RESTRICT="strip"
-
-DEPEND=""
-RDEPEND=""
-
-NEWLIBBUILD="${WORKDIR}/build"
-S="${WORKDIR}/newlib"
-
-src_unpack() {
- unpack ${A}
- mkdir -p "${NEWLIBBUILD}"
-}
-
-src_compile() {
- # we should fix this ...
- unset LDFLAGS
- CHOST=${CTARGET} strip-unsupported-flags
-
- local myconf=""
- # hardwired to avoid breakages
- [[ $(tc-is-softfloat) == "no" ]] \
- && myconf="--disable-newlib-hw-fp" \
- || myconf="--enable-newlib-hw-fp"
- [[ ${CTARGET} == "spu" ]] \
- && myconf="${myconf} --disable-threads" \
- || myconf="${myconf} $(use_enable threads)"
-
- cd "${NEWLIBBUILD}"
-
- ECONF_SOURCE=${S} \
- econf \
- $(use_enable unicode newlib-mb) \
- $(use_enable nls) \
- $(use_enable multilib) \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- cd "${NEWLIBBUILD}"
- emake -j1 DESTDIR="${D}" install
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- # minor hack to keep things clean
- rm -fR "${D}"/usr/share/info
- rm -fR "${D}"/usr/info
-}