summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-01 14:15:35 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-01 14:15:35 +0000
commit0431f08ac9be3de17a1af5434d1b8ed4986f6ff0 (patch)
tree85553d681140997385debc59e84768dd42e2fe34 /sys-libs/libcxxrt
parentEAPI bump wrt bug 460572 (diff)
downloadgentoo-2-0431f08ac9be3de17a1af5434d1b8ed4986f6ff0.tar.gz
gentoo-2-0431f08ac9be3de17a1af5434d1b8ed4986f6ff0.tar.bz2
gentoo-2-0431f08ac9be3de17a1af5434d1b8ed4986f6ff0.zip
Make libunwind optional in the current snapshot too
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxxrt')
-rw-r--r--sys-libs/libcxxrt/ChangeLog6
-rw-r--r--sys-libs/libcxxrt/libcxxrt-0.0_p20130531.ebuild13
2 files changed, 11 insertions, 8 deletions
diff --git a/sys-libs/libcxxrt/ChangeLog b/sys-libs/libcxxrt/ChangeLog
index 8d17a0d5215a..fd81a1faf4f7 100644
--- a/sys-libs/libcxxrt/ChangeLog
+++ b/sys-libs/libcxxrt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcxxrt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.12 2013/06/01 12:58:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/ChangeLog,v 1.13 2013/06/01 14:15:35 aballier Exp $
+
+ 01 Jun 2013; Alexis Ballier <aballier@gentoo.org>
+ libcxxrt-0.0_p20130531.ebuild:
+ Make libunwind optional in the current snapshot too
01 Jun 2013; Alexis Ballier <aballier@gentoo.org> libcxxrt-9999.ebuild,
metadata.xml:
diff --git a/sys-libs/libcxxrt/libcxxrt-0.0_p20130531.ebuild b/sys-libs/libcxxrt/libcxxrt-0.0_p20130531.ebuild
index 2ecb1fa9e35b..5616c8c0be76 100644
--- a/sys-libs/libcxxrt/libcxxrt-0.0_p20130531.ebuild
+++ b/sys-libs/libcxxrt/libcxxrt-0.0_p20130531.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-0.0_p20130531.ebuild,v 1.1 2013/05/31 15:54:41 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxxrt/libcxxrt-0.0_p20130531.ebuild,v 1.2 2013/06/01 14:15:35 aballier Exp $
-EAPI=4
+EAPI=5
EGIT_REPO_URI="git://github.com/pathscale/libcxxrt.git"
@@ -26,9 +26,9 @@ if [ "${PV%9999}" = "${PV}" ] ; then
else
KEYWORDS=""
fi
-IUSE="static-libs"
+IUSE="libunwind static-libs"
-RDEPEND=">=sys-libs/libunwind-1.0.1-r1[static-libs?]"
+RDEPEND="libunwind? ( >=sys-libs/libunwind-1.0.1-r1[static-libs?] )"
DEPEND="${RDEPEND}
${DEPEND}"
@@ -40,12 +40,11 @@ src_prepare() {
src_compile() {
# Notes: we build -nodefaultlibs to avoid linking to gcc libs.
- # libcxxrt needs: dladdr (dlopen_lib), libunwind (or libgcc_s but we build
- # over libunwind) and the libc.
+ # libcxxrt needs: dladdr (dlopen_lib), libunwind or libgcc_s and the libc.
tc-export CC CXX AR
append-ldflags "-Wl,-z,defs" # make sure we are not underlinked
cd "${S}/src"
- LIBS="$(dlopen_lib) -lunwind -lc" emake shared
+ LIBS="$(dlopen_lib) -l$(usex libunwind unwind gcc_s) -lc" emake shared
use static-libs && emake static
}