summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-08 02:40:54 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-08 02:40:54 +0000
commit35ff75a444656b389b18af6a513cce684d84bece (patch)
tree855cec801e966ab14644bbac2d1564dad1fc7d1b /sys-libs/db
parentadd detection for tar files (diff)
downloadgentoo-2-35ff75a444656b389b18af6a513cce684d84bece.tar.gz
gentoo-2-35ff75a444656b389b18af6a513cce684d84bece.tar.bz2
gentoo-2-35ff75a444656b389b18af6a513cce684d84bece.zip
Further cleanup the patch from Redhat, add a SONAME fix for alpha #48616, and tweak how we build/install.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/ChangeLog11
-rw-r--r--sys-libs/db/db-1.85-r3.ebuild47
-rw-r--r--sys-libs/db/files/db-1.85-gentoo-paths.patch29
-rw-r--r--sys-libs/db/files/digest-db-1.85-r32
4 files changed, 87 insertions, 2 deletions
diff --git a/sys-libs/db/ChangeLog b/sys-libs/db/ChangeLog
index 4d8760e5a6f4..169151a006ef 100644
--- a/sys-libs/db/ChangeLog
+++ b/sys-libs/db/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/db
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.135 2005/08/23 20:46:39 agriffis Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/ChangeLog,v 1.136 2005/11/08 02:40:54 vapier Exp $
+
+*db-1.85-r3 (08 Nov 2005)
+
+ 08 Nov 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/db-1.85-gentoo-paths.patch, +db-1.85-r3.ebuild:
+ Further cleanup the patch from Redhat, add a SONAME fix for alpha #48616,
+ and tweak how we build/install.
23 Aug 2005; Aron Griffis <agriffis@gentoo.org> db-4.2.52_p2.ebuild:
stable on ia64
diff --git a/sys-libs/db/db-1.85-r3.ebuild b/sys-libs/db/db-1.85-r3.ebuild
new file mode 100644
index 000000000000..c523954b9f24
--- /dev/null
+++ b/sys-libs/db/db-1.85-r3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85-r3.ebuild,v 1.1 2005/11/08 02:40:54 vapier Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="old berk db kept around for really old packages"
+HOMEPAGE="http://www.sleepycat.com/"
+SRC_URI="ftp://ftp.sleepycat.com/releases/db.${PV}.tar.gz
+ mirror://gentoo/${PF}.patch.bz2"
+
+LICENSE="DB"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/db.${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${PF}.patch
+ epatch "${FILESDIR}"/${P}-gentoo-paths.patch
+ sed -i -e "s:@GENTOO_LIBDIR@:$(get_libdir):" PORT/linux/Makefile || die
+}
+
+src_compile() {
+ tc-export CC AR RANLIB
+ emake -C PORT/linux OORG="${CFLAGS}" || die
+}
+
+src_install() {
+ make -C PORT/linux install DESTDIR="${D}" || die
+
+ # binary compat symlink
+ dosym libdb1.so.2 /usr/$(get_libdir)/libdb.so.2 || die
+
+ dosed "s:<db.h>:<db1/db.h>:" /usr/include/db1/ndbm.h
+ dosym db1/ndbm.h /usr/include/ndbm.h
+
+ dodoc changelog README
+ newdoc hash/README README.hash
+ docinto ps
+ dodoc docs/*.ps
+}
diff --git a/sys-libs/db/files/db-1.85-gentoo-paths.patch b/sys-libs/db/files/db-1.85-gentoo-paths.patch
new file mode 100644
index 000000000000..4a65106bdc70
--- /dev/null
+++ b/sys-libs/db/files/db-1.85-gentoo-paths.patch
@@ -0,0 +1,29 @@
+--- PORT/linux/Makefile
++++ PORT/linux/Makefile
+@@ -1,12 +1,12 @@
+ # @(#)Makefile 8.9 (Berkeley) 7/14/94
+
+-LIBDB= libdb.a
+-LIBDBSO=libdb.so
++LIBDB= libdb1.a
++LIBDBSO=libdb1.so
+ SOVER=2
+ SONAME=$(LIBDBSO).$(SOVER)
+ LIBNDBM=libndbm.a
+ LIBNDBMSO=libndbm.so
+-PROG= db_dump185
++PROG= db1_dump185
+ OBJ1= hash.o hash_bigkey.o hash_buf.o hash_func.o hash_log2.o hash_page.o \
+ ndbm.o
+ OBJ2= bt_close.o bt_conv.o bt_debug.o bt_delete.o bt_get.o bt_open.o \
+@@ -27,8 +27,8 @@
+ DESTDIR =
+ prefix = /usr
+ bindir = $(prefix)/bin
+-libdir = $(prefix)/lib
+-includedir = $(prefix)/include
++libdir = $(prefix)/@GENTOO_LIBDIR@
++includedir = $(prefix)/include/db1
+
+ all: $(LIBDB) $(LIBDBSO) $(PROG)
+
diff --git a/sys-libs/db/files/digest-db-1.85-r3 b/sys-libs/db/files/digest-db-1.85-r3
new file mode 100644
index 000000000000..9991746913e0
--- /dev/null
+++ b/sys-libs/db/files/digest-db-1.85-r3
@@ -0,0 +1,2 @@
+MD5 befeaaece9f5e8214194fdf4129537fa db-1.85-r3.patch.bz2 14629
+MD5 42cc6c1e1e25818bd3e3f91328edb0f1 db.1.85.tar.gz 270953