summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStratos Psomadakis <psomas@gentoo.org>2013-03-26 14:01:09 +0000
committerStratos Psomadakis <psomas@gentoo.org>2013-03-26 14:01:09 +0000
commit874d1f1379779933e5eb7e9e9e9377fd65ab0256 (patch)
tree1d41157b6315b0a593ff8101c59cd53ce23a3bfa /sys-kernel
parentStable for HPPA (bug #458984). (diff)
downloadgentoo-2-874d1f1379779933e5eb7e9e9e9377fd65ab0256.tar.gz
gentoo-2-874d1f1379779933e5eb7e9e9e9377fd65ab0256.tar.bz2
gentoo-2-874d1f1379779933e5eb7e9e9e9377fd65ab0256.zip
Version bump
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key BC35D737)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/rt-sources/ChangeLog9
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.6.11_p31.ebuild45
-rw-r--r--sys-kernel/rt-sources/rt-sources-3.8.4_p1.ebuild45
3 files changed, 98 insertions, 1 deletions
diff --git a/sys-kernel/rt-sources/ChangeLog b/sys-kernel/rt-sources/ChangeLog
index 9ba793e467ee..805a5d75ece8 100644
--- a/sys-kernel/rt-sources/ChangeLog
+++ b/sys-kernel/rt-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/rt-sources
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.19 2013/03/17 15:35:20 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/ChangeLog,v 1.20 2013/03/26 14:01:09 psomas Exp $
+
+*rt-sources-3.8.4_p1 (26 Mar 2013)
+*rt-sources-3.6.11_p31 (26 Mar 2013)
+
+ 26 Mar 2013; <psomas@gentoo.org> +rt-sources-3.6.11_p31.ebuild,
+ +rt-sources-3.8.4_p1.ebuild:
+ Version bump
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/sys-kernel/rt-sources/rt-sources-3.6.11_p31.ebuild b/sys-kernel/rt-sources/rt-sources-3.6.11_p31.ebuild
new file mode 100644
index 000000000000..337941a0ff28
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.6.11_p31.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.6.11_p31.ebuild,v 1.1 2013/03/26 14:01:09 psomas Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst(){
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."
diff --git a/sys-kernel/rt-sources/rt-sources-3.8.4_p1.ebuild b/sys-kernel/rt-sources/rt-sources-3.8.4_p1.ebuild
new file mode 100644
index 000000000000..dd473757e3a9
--- /dev/null
+++ b/sys-kernel/rt-sources/rt-sources-3.8.4_p1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/rt-sources/rt-sources-3.8.4_p1.ebuild,v 1.1 2013/03/26 14:01:09 psomas Exp $
+
+EAPI="5"
+ETYPE="sources"
+KEYWORDS="~amd64"
+
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/projects/rt/"
+
+inherit versionator
+
+CKV="$(get_version_component_range 1-3)"
+K_SECURITY_UNSUPPORTED="yes"
+K_DEBLOB_AVAILABLE="1"
+RT_PATCHSET="${PV/*_p}"
+
+inherit kernel-2
+detect_version
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+RT_FILE="patch-${K_BRANCH_ID}.${KV_PATCH}-rt${RT_PATCHSET}.patch.xz"
+RT_URI="mirror://kernel/linux/kernel/projects/rt/${K_BRANCH_ID}/${RT_FILE}"
+
+DESCRIPTION="Full Linux ${K_BRANCH_ID} kernel sources with the CONFIG_PREEMPT_RT patch"
+SRC_URI="${KERNEL_URI} ${RT_URI}"
+
+KV_FULL="${PVR/_p/-rt}"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+UNIPATCH_LIST="${DISTDIR}/${RT_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_postinst(){
+
+ ewarn
+ ewarn "${PN} are *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the RT project developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds."
+ ewarn
+}
+
+K_EXTRAEINFO="For more info on rt-sources and details on how to report problems, see: \
+${HOMEPAGE}."