summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-10-08 21:41:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-10-08 21:41:31 +0000
commit08e26e06f50baaff8963a5ca219349d11ebf7f9d (patch)
tree0fb11ae1d2492727d5168a56b0d7abf5bcfac1df /sys-kernel
parentamd64 stable wrt #385807 (diff)
downloadgentoo-2-08e26e06f50baaff8963a5ca219349d11ebf7f9d.tar.gz
gentoo-2-08e26e06f50baaff8963a5ca219349d11ebf7f9d.tar.bz2
gentoo-2-08e26e06f50baaff8963a5ca219349d11ebf7f9d.zip
Based on 2.6.32.46 + genpatches-2.6.32-43 + grsecurity-2.2.2-2.6.32.46-201110080819
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r70.ebuild48
2 files changed, 56 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 86da1a848117..1fa8a25269f1 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.478 2011/10/08 21:33:21 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.479 2011/10/08 21:41:31 blueness Exp $
+
+*hardened-sources-2.6.32-r70 (08 Oct 2011)
+
+ 08 Oct 2011; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r70.ebuild:
+ Based on 2.6.32.46 + genpatches-2.6.32-43 +
+ grsecurity-2.2.2-2.6.32.46-201110080819
08 Oct 2011; Anthony G. Basile <blueness@gentoo.org>
hardened-sources-3.0.4-r1.ebuild:
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r70.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r70.ebuild
new file mode 100644
index 000000000000..eaedabf4cab8
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r70.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r70.ebuild,v 1.1 2011/10/08 21:41:31 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="43"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-73"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="2000_fix-broken-backport-for-ipv6-tunnels.patch 4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.2.2*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}