summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-23 20:40:29 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-23 20:40:29 +0000
commit0776567bc70521e85e07b75af3ec16877424478d (patch)
tree31ec34c7f183da569d20feb390232a7d0c3c9090 /sys-kernel
parentstable x86, bug 324735 (diff)
downloadgentoo-2-0776567bc70521e85e07b75af3ec16877424478d.tar.gz
gentoo-2-0776567bc70521e85e07b75af3ec16877424478d.tar.bz2
gentoo-2-0776567bc70521e85e07b75af3ec16877424478d.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/zen-sources/ChangeLog8
-rw-r--r--sys-kernel/zen-sources/zen-sources-2.6.34_p1.ebuild52
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-kernel/zen-sources/ChangeLog b/sys-kernel/zen-sources/ChangeLog
index 4f74d0eeafcd..5397acc52325 100644
--- a/sys-kernel/zen-sources/ChangeLog
+++ b/sys-kernel/zen-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/zen-sources
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.36 2010/06/17 16:00:52 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/ChangeLog,v 1.37 2010/06/23 20:40:29 hwoarang Exp $
+
+*zen-sources-2.6.34_p1 (23 Jun 2010)
+
+ 23 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +zen-sources-2.6.34_p1.ebuild:
+ Version bump
*zen-sources-2.6.33_p3 (17 Jun 2010)
diff --git a/sys-kernel/zen-sources/zen-sources-2.6.34_p1.ebuild b/sys-kernel/zen-sources/zen-sources-2.6.34_p1.ebuild
new file mode 100644
index 000000000000..10e0796ac97d
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-2.6.34_p1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/zen-sources/zen-sources-2.6.34_p1.ebuild,v 1.1 2010/06/23 20:40:29 hwoarang Exp $
+
+COMPRESSTYPE=".lzma"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="${PV/_p[0-9]*}"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="The Zen Kernel Sources v2.6"
+HOMEPAGE="http://zen-kernel.org"
+
+ZEN_PATCHSET="${PV/*_p}"
+ZEN_KERNEL="${PV/_p[0-9]*}"
+ZEN_KERNEL="${ZEN_KERNEL/_/-}"
+ZEN_FILE="${ZEN_KERNEL}-zen${ZEN_PATCHSET}.patch${COMPRESSTYPE}"
+ZEN_URI="http://downloads.zen-kernel.org/$(get_version_component_range 1-3)/${ZEN_FILE}"
+SRC_URI="${KERNEL_URI} ${ZEN_URI}"
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="|| ( app-arch/xz-utils app-arch/lzma-utils )"
+
+KV_FULL="${PVR/_p/-zen}"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the Zen developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ ebeep 8
+ kernel-2_pkg_setup
+}
+
+src_unpack(){
+ kernel-2_src_unpack
+ cd "${S}"
+ epatch "${DISTDIR}"/"${ZEN_FILE}"
+}
+
+K_EXTRAEINFO="For more info on zen-sources and details on how to report problems, see: \
+${HOMEPAGE}. You may also visit #zen-sources on irc.rizon.net"