summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2004-02-21 19:13:29 +0000
committerChristian Birchinger <joker@gentoo.org>2004-02-21 19:13:29 +0000
commit02b7af6d12e3342edad6880bcae42e1784188cda (patch)
tree5404d9ffcd92872992e163363c203a69f8445dc9 /sys-kernel
parentInitial import. (Manifest recommit) (diff)
downloadgentoo-2-02b7af6d12e3342edad6880bcae42e1784188cda.tar.gz
gentoo-2-02b7af6d12e3342edad6880bcae42e1784188cda.tar.bz2
gentoo-2-02b7af6d12e3342edad6880bcae42e1784188cda.zip
Version bump
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog8
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.252
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild61
3 files changed, 70 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 0651acfecebc..92d0f9fe070b 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.49 2004/02/19 00:56:35 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.50 2004/02/21 19:13:28 joker Exp $
+
+*sparc-sources-2.4.25 (21 Feb 2004)
+
+ 21 Feb 2004; Christian Birchinger <joker@gentoo.org>
+ sparc-sources-2.4.25.ebuild:
+ Version bump
19 Feb 2004; Christian Birchinger <joker@gentoo.org>
sparc-sources-2.4.24-r2.ebuild:
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.25 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.25
new file mode 100644
index 000000000000..aeda787d6a0d
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.25
@@ -0,0 +1,2 @@
+MD5 5fc8e9f43fa44ac29ddf9a9980af57d8 linux-2.4.25.tar.bz2 30626548
+MD5 ebf1bf200cdc568b8bf9c07fc88327df patches-2.4.25-sparc.tar.bz2 141155
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild
new file mode 100644
index 000000000000..105083729acb
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.25.ebuild,v 1.1 2004/02/21 19:13:28 joker Exp $
+
+IUSE="ultra1"
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="grsecurity" would not patch any patches whose names match
+# *grsecurity*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+ETYPE="sources"
+inherit kernel
+
+# OKV=original kernel version, KV=patched kernel version. They can be the same.
+[ "$OKV" == "" ] && OKV="${PV}"
+
+EXTRAVERSION="-${PN/-*/}"
+[ ! "${PR}" == "r0" ] && EXTRAVERSION="${EXTRAVERSION}-${PR}"
+KV="${OKV}${EXTRAVERSION}"
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Sparc Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${KV}.tar.bz2"
+
+S=${WORKDIR}/linux-${KV}
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die "Error moving kernel source tree to linux-${KV}"
+ cd ${KV} || die "Unable to cd into ${KV}"
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}