summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2012-12-27 09:13:02 +0000
committerJoshua Kinard <kumba@gentoo.org>2012-12-27 09:13:02 +0000
commitc8e57a3f19fb5df433aa4f80a54fcead6faae4a8 (patch)
tree4024ec5b3c7426c713e3b4c152d2a4018b5dad21 /sys-kernel/mips-sources
parentalpha/s390/sh/sparc stable wrt #441256 (diff)
downloadgentoo-2-c8e57a3f19fb5df433aa4f80a54fcead6faae4a8.tar.gz
gentoo-2-c8e57a3f19fb5df433aa4f80a54fcead6faae4a8.tar.bz2
gentoo-2-c8e57a3f19fb5df433aa4f80a54fcead6faae4a8.zip
Update to 3.4.24/3.6.11 and add 3.7.1. All use git pull from linus-mips 20121226.
(Portage version: 2.1.11.38/cvs/Linux x86_64, signed Manifest commit with key D25D95E3)
Diffstat (limited to 'sys-kernel/mips-sources')
-rw-r--r--sys-kernel/mips-sources/ChangeLog12
-rw-r--r--sys-kernel/mips-sources/mips-sources-3.4.24.ebuild (renamed from sys-kernel/mips-sources/mips-sources-3.4.19.ebuild)6
-rw-r--r--sys-kernel/mips-sources/mips-sources-3.6.11.ebuild177
-rw-r--r--sys-kernel/mips-sources/mips-sources-3.7.1.ebuild (renamed from sys-kernel/mips-sources/mips-sources-3.6.7.ebuild)4
4 files changed, 193 insertions, 6 deletions
diff --git a/sys-kernel/mips-sources/ChangeLog b/sys-kernel/mips-sources/ChangeLog
index e6ae4dcfcc69..d57fbd05a465 100644
--- a/sys-kernel/mips-sources/ChangeLog
+++ b/sys-kernel/mips-sources/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-kernel/mips-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/ChangeLog,v 1.146 2012/11/23 23:39:02 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/ChangeLog,v 1.147 2012/12/27 09:13:02 kumba Exp $
+
+*mips-sources-3.7.1 (27 Dec 2012)
+*mips-sources-3.6.11 (27 Dec 2012)
+*mips-sources-3.4.24 (27 Dec 2012)
+
+ 27 Dec 2012; Joshua Kinard <kumba@gentoo.org> -mips-sources-3.4.19.ebuild,
+ +mips-sources-3.4.24.ebuild, -mips-sources-3.6.7.ebuild,
+ +mips-sources-3.6.11.ebuild, +mips-sources-3.7.1.ebuild:
+ Update to 3.4.24/3.6.11 and add 3.7.1. All use git pull from linus-mips
+ 20121226.
*mips-sources-3.6.7 (23 Nov 2012)
*mips-sources-3.4.19 (23 Nov 2012)
diff --git a/sys-kernel/mips-sources/mips-sources-3.4.19.ebuild b/sys-kernel/mips-sources/mips-sources-3.4.24.ebuild
index 6d7ee98dfd7e..ecf4737e0e9f 100644
--- a/sys-kernel/mips-sources/mips-sources-3.4.19.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-3.4.24.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-3.4.19.ebuild,v 1.1 2012/11/23 23:39:02 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-3.4.24.ebuild,v 1.1 2012/12/27 09:13:02 kumba Exp $
# EAPI Version
EAPI=4
@@ -18,8 +18,8 @@ EAPI=4
# Version Data
OKV=${PV/_/-}
-GITDATE="20120623" # Date of diff between kernel.org and lmo GIT
-GENPATCHREV="1" # Tarball revision for patches
+GITDATE="20121226" # Date of diff between kernel.org and lmo GIT
+GENPATCHREV="2" # Tarball revision for patches
# Directories
S="${WORKDIR}/linux-${OKV}-${GITDATE}"
diff --git a/sys-kernel/mips-sources/mips-sources-3.6.11.ebuild b/sys-kernel/mips-sources/mips-sources-3.6.11.ebuild
new file mode 100644
index 000000000000..efd85fd478d9
--- /dev/null
+++ b/sys-kernel/mips-sources/mips-sources-3.6.11.ebuild
@@ -0,0 +1,177 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-3.6.11.ebuild,v 1.1 2012/12/27 09:13:02 kumba Exp $
+
+# EAPI Version
+EAPI=4
+
+# INCLUDED:
+# 1) linux sources from kernel.org
+# 2) linux-mips.org GIT snapshot diff
+# 3) Generic Fixes
+# 4) Patch for the IOC3 Metadriver (IP27, IP30)
+# 5) Patch for IP30 Support
+# 6) Patch for IP28 Graphics Support (SolidImpact)
+# 7) Experimental patches (if needed)
+
+#//------------------------------------------------------------------------------
+
+# Version Data
+OKV=${PV/_/-}
+GITDATE="20121226" # Date of diff between kernel.org and lmo GIT
+GENPATCHREV="2" # Tarball revision for patches
+
+# Directories
+S="${WORKDIR}/linux-${OKV}-${GITDATE}"
+MIPS_PATCHES="${WORKDIR}/mips-patches"
+
+# Kernel-2 Vars
+K_SECURITY_UNSUPPORTED="1"
+K_NOUSENAME="0"
+K_NOUSEPR="0"
+K_USEPV="0"
+ETYPE="sources"
+
+# Inherit Eclasses
+inherit kernel-2 eutils
+detect_version
+
+# Version Data
+F_KV="${PVR}"
+BASE_KV="$(get_version_component_range 1-2).0"
+[[ "${EXTRAVERSION}" = -rc* ]] && KVE="${EXTRAVERSION}"
+
+# Portage Vars
+HOMEPAGE="http://www.linux-mips.org/ http://www.gentoo.org/"
+SLOT="${OKV}"
+KEYWORDS="-* ~mips"
+IUSE="cobalt ip27 ip28 ip30 ip32r10k impactdebug odysseydebug"
+DEPEND=">=sys-devel/gcc-4.1.1"
+RDEPEND=""
+
+# Machine Support Control Variables
+DO_IP22="yes" # If "yes", enable IP22 support (SGI Indy, Indigo2 R4x00)
+DO_IP27="test" # IP27 support (SGI Origin)
+DO_IP28="yes" # IP28 support (SGI Indigo2 Impact R10000)
+DO_IP30="test" # IP30 support (SGI Octane)
+DO_IP32="yes" # IP32 support (SGI O2, R5000/RM5200 Only)
+DO_CBLT="yes" # Cobalt Support (Cobalt Microsystems)
+
+# Machine Stable Version Variables
+SV_IP22="" # If set && DO_IP22 == "no", indicates last "good" IP22 version
+SV_IP27="" # DO_IP27 == "no", IP27
+SV_IP28="" # DO_IP28 == "no", IP28
+SV_IP30="" # DO_IP30 == "no", IP30
+SV_IP32="" # DO_IP32 == "no", IP32
+SV_CBLT="" # DO_CBLT == "no", Cobalt
+
+DESCRIPTION="Linux-Mips GIT sources for MIPS-based machines, dated ${GITDATE}"
+SRC_URI="${KERNEL_URI}
+ mirror://gentoo/mipsgit-${BASE_KV}${KVE}-${GITDATE}.diff.xz
+ mirror://gentoo/${PN}-${BASE_KV}-patches-v${GENPATCHREV}.tar.xz"
+
+UNIPATCH_STRICTORDER="1"
+UNIPATCH_LIST="${DISTDIR}/mipsgit-${BASE_KV}${KVE}-${GITDATE}.diff.xz"
+
+#//------------------------------------------------------------------------------
+
+# Eblit Handling Functions
+#
+# They'll likely be superseded someday by better ideas, possibly elibs.
+
+# eblit-core
+# Usage: <function> [version]
+# Main eblit engine
+eblit-core() {
+ local e v func=$1 ver=$2
+ for v in ${ver:+-}${ver} -${PVR} -${PV} "" ; do
+ e="${FILESDIR}/eblits/${func}${v}.eblit"
+ if [[ -e ${e} ]] ; then
+ . "${e}"
+ [[ ${func} == pkg_* ]] && eval "${func}() { eblit-run ${func} ${ver} ; }"
+ return 0
+ fi
+ done
+ return 1
+}
+
+# eblit-include
+# Usage: [--skip] <function> [version]
+# Includes an "eblit" -- a chunk of common code among ebuilds in a given
+# package so that its functions can be sourced and utilized within the
+# ebuild.
+eblit-include() {
+ local skipable=false r=0
+ [[ $1 == "--skip" ]] && skipable=true && shift
+ [[ $1 == pkg_* ]] && skipable=true
+
+ [[ -z $1 ]] && die "Usage: eblit-include <function> [version]"
+ eblit-core $1 $2
+ r="$?"
+ ${skipable} && return 0
+ [[ "$r" -gt "0" ]] && die "Could not locate requested eblit '$1' in ${FILESDIR}/eblits/"
+}
+
+# eblit-run-maybe
+# Usage: <function>
+# Runs a function if it is defined in an eblit
+eblit-run-maybe() {
+ [[ $(type -t "$@") == "function" ]] && "$@"
+}
+
+# eblit-run
+# Usage: <function> [version]
+# Runs a function defined in an eblit
+eblit-run() {
+ eblit-include --skip common "${*:2}"
+ eblit-include "$@"
+ eblit-run-maybe eblit-$1-pre
+ eblit-${PN}-$1
+ eblit-run-maybe eblit-$1-post
+}
+
+# eblit-pkg
+# Usage: <phase> [version]
+# Runs the pkg_* functions AND evals them so they're included in the binpkgs
+eblit-pkg() {
+ [[ -z $1 ]] && die "Usage: eblit-pkg <phase> [version]"
+ eblit-core pkg_$1 $2
+}
+
+#//------------------------------------------------------------------------------
+
+load_eblit_funcs() {
+ # This is a sanity check to avoid QA issues. It prevents
+ # eblits from being referenced during metadata operations.
+ [ -n "${MIPS_SOURCES_EBLITS_LOADED}" ] && return
+
+ # All are in ${FILESDIR}/eblits
+ # If a message for a given machine needs to change,
+ # then we create a new eblit and increment the
+ # version and reference it here.
+ eblit-include err_disabled_mach v1
+ eblit-include err_only_one_mach_allowed v1
+ eblit-include show_ip22_info v3
+ eblit-include show_ip27_info v1
+ eblit-include show_ip28_info v1
+ eblit-include show_ip30_info v2
+ eblit-include show_ip32_info v3
+ eblit-include show_cobalt_info v1
+
+ # This makes sure pkg_setup & pkg_postinst gets into any binpkg.
+ # Neccessary because we can't guarantee FILESDIR is around for binpkgs.
+ eblit-pkg setup v1
+ eblit-pkg postinst v1
+
+ # Eblit load complete
+ MIPS_SOURCES_EBLITS_LOADED=1
+}
+
+pkg_setup() {
+ load_eblit_funcs
+ pkg_setup
+}
+
+src_unpack() { eblit-run src_unpack v3 ; }
+
+#//------------------------------------------------------------------------------
diff --git a/sys-kernel/mips-sources/mips-sources-3.6.7.ebuild b/sys-kernel/mips-sources/mips-sources-3.7.1.ebuild
index 12fda657bcd3..8360302624ed 100644
--- a/sys-kernel/mips-sources/mips-sources-3.6.7.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-3.7.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-3.6.7.ebuild,v 1.1 2012/11/23 23:39:02 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-3.7.1.ebuild,v 1.1 2012/12/27 09:13:02 kumba Exp $
# EAPI Version
EAPI=4
@@ -18,7 +18,7 @@ EAPI=4
# Version Data
OKV=${PV/_/-}
-GITDATE="20121123" # Date of diff between kernel.org and lmo GIT
+GITDATE="20121226" # Date of diff between kernel.org and lmo GIT
GENPATCHREV="1" # Tarball revision for patches
# Directories