summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-06-04 09:32:17 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-06-04 09:32:17 +0000
commit924e60f14eb4b95cd948c99b24d006690f661133 (patch)
tree975912f6816b20510ac06b8034c355c7613a9e9f /sys-kernel/mips-sources/mips-sources-2.4.26-r2.ebuild
parentAdded to "ppc (Manifest recommit) (diff)
downloadgentoo-2-924e60f14eb4b95cd948c99b24d006690f661133.tar.gz
gentoo-2-924e60f14eb4b95cd948c99b24d006690f661133.tar.bz2
gentoo-2-924e60f14eb4b95cd948c99b24d006690f661133.zip
Batch of security updates that apparently got missed. Finally removed 2.4.{21,22,23} and 2.6.3 from repository. Added newer 2.6.6 snapshot (20040406), and marked 2.4.26 stable.
Diffstat (limited to 'sys-kernel/mips-sources/mips-sources-2.4.26-r2.ebuild')
-rw-r--r--sys-kernel/mips-sources/mips-sources-2.4.26-r2.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-kernel/mips-sources/mips-sources-2.4.26-r2.ebuild b/sys-kernel/mips-sources/mips-sources-2.4.26-r2.ebuild
new file mode 100644
index 000000000000..46fc089390d8
--- /dev/null
+++ b/sys-kernel/mips-sources/mips-sources-2.4.26-r2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/mips-sources/mips-sources-2.4.26-r2.ebuild,v 1.1 2004/06/04 09:32:17 kumba Exp $
+
+
+# Version Data
+OKV=${PV/_/-}
+CVSDATE="20040415"
+EXTRAVERSION="-mipscvs-${CVSDATE}"
+KV="${OKV}${EXTRAVERSION}"
+COBALTPATCHVER="1.4"
+
+# Miscellaneous stuff
+S=${WORKDIR}/linux-${OKV}-${CVSDATE}
+IUSE=""
+
+# Eclass stuff
+ETYPE="sources"
+inherit kernel eutils
+
+
+# INCLUDED:
+# 1) linux sources from kernel.org
+# 2) linux-mips.org CVS snapshot diff from 28 Nov 2003
+# 3) patch to fix arch/mips[64]/Makefile to pass appropriate CFLAGS
+# 4) patch to fix the mips64 Makefile to allow building of mips64 kernels
+# 5) iso9660 fix
+# 6) Patches for Cobalt support
+
+
+DESCRIPTION="Linux-Mips CVS sources for MIPS-based machines, dated ${CVSDATE}"
+SRC_URI="mirror://kernel/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/mipscvs-${OKV}-${CVSDATE}.diff.bz2
+ mirror://gentoo/cobalt-patches-24xx-${COBALTPATCHVER}.tar.bz2"
+HOMEPAGE="http://www.linux-mips.org/"
+SLOT="${OKV}"
+PROVIDE="virtual/linux-sources"
+KEYWORDS="-* mips"
+
+
+src_unpack() {
+ unpack ${A}
+ mv ${WORKDIR}/linux-${OKV} ${WORKDIR}/linux-${OKV}-${CVSDATE}
+ cd ${S}
+
+ # Update the vanilla sources with linux-mips CVS changes
+ epatch ${WORKDIR}/mipscvs-${OKV}-${CVSDATE}.diff
+
+ # Patch arch/mips/Makefile for gcc (Pass -mips3/-mips4 for r4k/r5k cpus)
+ epatch ${FILESDIR}/mipscvs-${OKV}-makefile-fix.patch
+
+ # Security Fixes
+ echo -e ""
+ ebegin "Applying Security Fixes"
+ epatch ${FILESDIR}/CAN-2004-0394-panic.patch
+ eend
+
+ # Cobalt Patches
+ if [ "${PROFILE_ARCH}" = "cobalt" ]; then
+ echo -e ""
+ einfo ">>> Patching kernel for Cobalt support ..."
+ for x in ${WORKDIR}/cobalt-patches-24xx-${COBALTPATCHVER}/*.patch; do
+ epatch ${x}
+ done
+ cp ${WORKDIR}/cobalt-patches-24xx-${COBALTPATCHVER}/cobalt-patches.txt ${S}
+ cd ${WORKDIR}
+ mv ${WORKDIR}/linux-${OKV}-${CVSDATE} ${WORKDIR}/linux-${OKV}-${CVSDATE}.cobalt
+ S="${S}.cobalt"
+ fi
+
+ kernel_universal_unpack
+}