summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-03-15 19:41:02 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-03-15 19:41:02 +0000
commitd1b4322a11d197200effe8e78a37f6e5beecd653 (patch)
treef18f05180e7dd13a23b01cba8e61cb5a2bcad9b4 /sys-kernel/linux-headers
parentlibtoolize (diff)
downloadgentoo-2-d1b4322a11d197200effe8e78a37f6e5beecd653.tar.gz
gentoo-2-d1b4322a11d197200effe8e78a37f6e5beecd653.tar.bz2
gentoo-2-d1b4322a11d197200effe8e78a37f6e5beecd653.zip
Bump to 2.6.11; fix #85106.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-kernel/linux-headers')
-rw-r--r--sys-kernel/linux-headers/ChangeLog9
-rw-r--r--sys-kernel/linux-headers/files/digest-linux-headers-2.6.11 (renamed from sys-kernel/linux-headers/files/digest-linux-headers-2.6.10)2
-rw-r--r--sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch (renamed from sys-kernel/linux-headers/files/linux-headers-2.6.10-appCompat.patch)77
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.6.11.ebuild (renamed from sys-kernel/linux-headers/linux-headers-2.6.10.ebuild)9
4 files changed, 58 insertions, 39 deletions
diff --git a/sys-kernel/linux-headers/ChangeLog b/sys-kernel/linux-headers/ChangeLog
index c5b62c8fc89c..c3e6320e7b15 100644
--- a/sys-kernel/linux-headers/ChangeLog
+++ b/sys-kernel/linux-headers/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/linux-headers
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.107 2005/03/06 18:32:44 plasmaroo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.108 2005/03/15 19:41:02 plasmaroo Exp $
+
+*linux-headers-2.6.11 (15 Mar 2005)
+
+ 15 Mar 2005; <plasmaroo@gentoo.org> -linux-headers-2.6.10.ebuild,
+ +linux-headers-2.6.11.ebuild, -files/linux-headers-2.6.10-appCompat.patch,
+ +files/linux-headers-2.6.11-appCompat.patch:
+ Bump to 2.6.11; fix #85106.
06 Mar 2005; <plasmaroo@gentoo.org>
files/linux-headers-2.6.10-appCompat.patch:
diff --git a/sys-kernel/linux-headers/files/digest-linux-headers-2.6.10 b/sys-kernel/linux-headers/files/digest-linux-headers-2.6.11
index 8372638227d6..7e21ce282b32 100644
--- a/sys-kernel/linux-headers/files/digest-linux-headers-2.6.10
+++ b/sys-kernel/linux-headers/files/digest-linux-headers-2.6.11
@@ -1,2 +1,2 @@
-MD5 cffcd2919d9c8ef793ce1ac07a440eda linux-2.6.10.tar.bz2 36533484
+MD5 f00fd1b5a80f52baf9d1d83acddfa325 linux-2.6.11.tar.bz2 37075679
MD5 27787cb0712944ae182c1faffc33f5e4 linux-2.6.10-m68k-headers.patch.bz2 12399
diff --git a/sys-kernel/linux-headers/files/linux-headers-2.6.10-appCompat.patch b/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch
index 910f252d8e09..d0acdc64e549 100644
--- a/sys-kernel/linux-headers/files/linux-headers-2.6.10-appCompat.patch
+++ b/sys-kernel/linux-headers/files/linux-headers-2.6.11-appCompat.patch
@@ -443,34 +443,33 @@ diff -ur linux-2.6.8.1/include/asm-generic/siginfo.h linux-2.6.8.1-gentoo/includ
#endif
/*
-@@ -238,7 +240,7 @@
+@@ -242,6 +244,7 @@
+ #define SIGEV_PAD_SIZE ((SIGEV_MAX_SIZE/sizeof(int)) - 3)
#endif
- #ifndef HAVE_ARCH_SIGEVENT_T
--
+#ifndef _SIGNAL_H
typedef struct sigevent {
sigval_t sigev_value;
int sigev_signo;
-@@ -253,7 +255,7 @@
+@@ -256,7 +259,7 @@
} _sigev_thread;
} _sigev_un;
} sigevent_t;
-
+#endif
- #endif
-
#define sigev_notify_function _sigev_un._sigev_thread._function
-diff -ur linux-2.6.0/include/linux/jiffies.h linux-2.6.0/include/linux.gentoo/jiffies.h
---- linux-2.6.0/include/linux/jiffies.h 2004-01-19 20:18:36.000000000 +0000
-+++ linux-2.6.0/include/linux.gentoo/jiffies.h 2004-01-19 20:01:11.000000000 +0000
+ #define sigev_notify_attributes _sigev_un._sigev_thread._attribute
+ #define sigev_notify_thread_id _sigev_un._tid
+diff -ur linux-2.6.11/include/linux/jiffies.h linux-2.6.11/include/linux.gentoo/jiffies.h
+--- linux-2.6.11/include/linux/jiffies.h 2004-01-19 20:18:36.000000000 +0000
++++ linux-2.6.11/include/linux.gentoo/jiffies.h 2004-01-19 20:01:11.000000000 +0000
@@ -13,15 +13,15 @@
* without holding read_lock_irq(&xtime_lock).
* get_jiffies_64() will do this for you as appropriate.
*/
--extern u64 jiffies_64;
-+extern __u64 jiffies_64;
- extern unsigned long volatile jiffies;
+-extern u64 __jiffy_data jiffies_64;
++extern __u64 __jiffy_data jiffies_64;
+ extern unsigned long volatile __jiffy_data jiffies;
#if (BITS_PER_LONG < 64)
-u64 get_jiffies_64(void);
@@ -1914,26 +1913,6 @@ diff -urp linux-2.6.10/include/asm-i386/semaphore.h linux-2.6.10-gentoo/include/
#include <linux/linkage.h>
/*
-diff -urp linux-2.6.10/include/linux/mmzone.h linux-2.6.10-gentoo/include/linux/mmzone.h
---- linux-2.6.10/include/linux/mmzone.h 2005-02-08 21:01:47.000000000 +0000
-+++ linux-2.6.10-gentoo/include/linux/mmzone.h 2005-02-08 20:45:13.000000000 +0000
-@@ -1,6 +1,8 @@
- #ifndef _LINUX_MMZONE_H
- #define _LINUX_MMZONE_H
-
-+extern int numnodes;
-+
- #ifdef __KERNEL__
- #ifndef __ASSEMBLY__
-
-@@ -270,7 +272,6 @@ typedef struct pglist_data {
- #define node_present_pages(nid) (NODE_DATA(nid)->node_present_pages)
- #define node_spanned_pages(nid) (NODE_DATA(nid)->node_spanned_pages)
-
--extern int numnodes;
- extern struct pglist_data *pgdat_list;
-
- void __get_zone_counts(unsigned long *active, unsigned long *inactive,
diff -urp linux-2.6.10/include/linux/prio_tree.h linux-2.6.10-gentoo/include/linux/prio_tree.h
--- linux-2.6.10/include/linux/prio_tree.h 2005-02-08 21:01:47.000000000 +0000
+++ linux-2.6.10-gentoo/include/linux/prio_tree.h 2005-02-08 20:15:28.000000000 +0000
@@ -2329,3 +2308,37 @@ diff -urp linux-2.6.10/include/linux/if_ppp.h linux-2.6.10-gentoo/include/linux/
/* Constants used for fbio SunOS compatibility */
/* (C) 1996 Miguel de Icaza */
+--- linux-2.6.10/include/linux/byteorder/little_endian.h.orig 2005-03-07 01:19:49.000000000 +0100
++++ linux-2.6.10/include/linux/byteorder/little_endian.h 2005-03-07 01:20:22.000000000 +0100
+@@ -40,6 +40,7 @@
+ #define __cpu_to_be16(x) ((__force __be16)__swab16((x)))
+ #define __be16_to_cpu(x) __swab16((__force __u16)(__be16)(x))
+
++#ifndef __STRICT_ANSI__
+ static inline __le64 __cpu_to_le64p(const __u64 *p)
+ {
+ return (__force __le64)*p;
+@@ -48,6 +49,7 @@
+ {
+ return (__force __u64)*p;
+ }
++#endif /* !__STRICT_ANSI__ */
+ static inline __le32 __cpu_to_le32p(const __u32 *p)
+ {
+ return (__force __le32)*p;
+@@ -64,6 +66,7 @@
+ {
+ return (__force __u16)*p;
+ }
++#ifndef __STRICT_ANSI__
+ static inline __be64 __cpu_to_be64p(const __u64 *p)
+ {
+ return (__force __be64)__swab64p(p);
+@@ -72,6 +75,7 @@
+ {
+ return __swab64p((__u64 *)p);
+ }
++#endif /* !__STRICT_ANSI__ */
+ static inline __be32 __cpu_to_be32p(const __u32 *p)
+ {
+ return (__force __be32)__swab32p(p);
diff --git a/sys-kernel/linux-headers/linux-headers-2.6.10.ebuild b/sys-kernel/linux-headers/linux-headers-2.6.11.ebuild
index 8907653ed6ee..9446ea935c71 100644
--- a/sys-kernel/linux-headers/linux-headers-2.6.10.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.6.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.10.ebuild,v 1.5 2005/03/10 23:01:41 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.6.11.ebuild,v 1.1 2005/03/15 19:41:02 plasmaroo Exp $
ETYPE="headers"
H_SUPPORTEDARCH="alpha amd64 arm hppa m68k ia64 ppc ppc64 s390 sh sparc x86"
@@ -8,16 +8,15 @@ inherit kernel-2 eutils
detect_version
SRC_URI="${KERNEL_URI} mirror://gentoo/linux-2.6.10-m68k-headers.patch.bz2"
-KEYWORDS="-* ~amd64 ~arm ~hppa ~ia64 ~m68k ~sparc ~s390 ~sh ~x86" # Untested, by using this you are agreeing to file bugs to plasmaroo, aren't you? :-)
+KEYWORDS="-*" # Not tested to be fully stable, if things break file bugs to plasmaroo please...
UNIPATCH_LIST="
${FILESDIR}/${PN}-2.6.0-sysctl_h-compat.patch
${FILESDIR}/${PN}-2.6.0-fb.patch
${FILESDIR}/${PN}-2.6.8.1-strict-ansi-fix.patch
${FILESDIR}/${P}-appCompat.patch
- ${FILESDIR}/${P}-generic-arm-prepare.patch
- ${FILESDIR}/${PN}-soundcard-ppc64.patch
- ${FILESDIR}/${PN}-2.6.8.1-parisc-syscall.patch"
+ ${FILESDIR}/${PN}-2.6.10-generic-arm-prepare.patch
+ ${FILESDIR}/${PN}-soundcard-ppc64.patch"
src_unpack() {
tc-arch-kernel