summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-22 20:12:27 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-22 20:12:27 +0000
commit2a6bfce2b66c591c96c1275d736fc13d5a898fef (patch)
tree40133d4c4a2100e93a5786f98d1875db2520bf83 /sys-kernel/linux-headers
parentFix LICENSE once again. BSD and GPL-2 should both be set unconditionally (diff)
downloadgentoo-2-2a6bfce2b66c591c96c1275d736fc13d5a898fef.tar.gz
gentoo-2-2a6bfce2b66c591c96c1275d736fc13d5a898fef.tar.bz2
gentoo-2-2a6bfce2b66c591c96c1275d736fc13d5a898fef.zip
Fix from upstream for missing asm/cmpxchg.h on ia64 #427622 by Tobias Ulmer.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'sys-kernel/linux-headers')
-rw-r--r--sys-kernel/linux-headers/ChangeLog7
-rw-r--r--sys-kernel/linux-headers/linux-headers-3.4-r2.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/sys-kernel/linux-headers/ChangeLog b/sys-kernel/linux-headers/ChangeLog
index 25fa50dd5c29..07971a50becf 100644
--- a/sys-kernel/linux-headers/ChangeLog
+++ b/sys-kernel/linux-headers/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/linux-headers
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.354 2012/07/15 17:32:15 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/ChangeLog,v 1.355 2012/07/22 20:12:27 vapier Exp $
+
+*linux-headers-3.4-r2 (22 Jul 2012)
+
+ 22 Jul 2012; Mike Frysinger <vapier@gentoo.org> +linux-headers-3.4-r2.ebuild:
+ Fix from upstream for missing asm/cmpxchg.h on ia64 #427622 by Tobias Ulmer.
15 Jul 2012; Raúl Porcel <armin76@gentoo.org> linux-headers-3.4-r1.ebuild:
alpha/arm/ia64/m68k/s390/sh/sparc stable wrt #423091
diff --git a/sys-kernel/linux-headers/linux-headers-3.4-r2.ebuild b/sys-kernel/linux-headers/linux-headers-3.4-r2.ebuild
new file mode 100644
index 000000000000..e3aa86f8b9bd
--- /dev/null
+++ b/sys-kernel/linux-headers/linux-headers-3.4-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-3.4-r2.ebuild,v 1.1 2012/07/22 20:12:27 vapier Exp $
+
+EAPI="3"
+
+ETYPE="headers"
+H_SUPPORTEDARCH="alpha amd64 arm bfin cris hppa m68k mips ia64 ppc ppc64 s390 sh sparc x86"
+inherit kernel-2
+detect_version
+
+PATCH_VER="3"
+SRC_URI="mirror://gentoo/gentoo-headers-base-${PV}.tar.xz
+ ${PATCH_VER:+mirror://gentoo/gentoo-headers-${PV}-${PATCH_VER}.tar.xz}"
+
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="app-arch/xz-utils
+ dev-lang/perl"
+RDEPEND=""
+
+S=${WORKDIR}/gentoo-headers-base-${PV}
+
+src_unpack() {
+ unpack ${A}
+}
+
+src_prepare() {
+ [[ -n ${PATCH_VER} ]] && EPATCH_SUFFIX="patch" epatch "${WORKDIR}"/${PV}
+}
+
+src_install() {
+ kernel-2_src_install
+ cd "${D}"
+ egrep -r \
+ -e '(^|[[:space:](])(asm|volatile|inline)[[:space:](]' \
+ -e '\<([us](8|16|32|64))\>' \
+ .
+ headers___fix $(find -type f)
+
+ egrep -l -r -e '__[us](8|16|32|64)' "${D}" | xargs grep -L linux/types.h
+
+ # hrm, build system sucks
+ find "${D}" '(' -name '.install' -o -name '*.cmd' ')' -print0 | xargs -0 rm -f
+
+ # provided by libdrm (for now?)
+ rm -rf "${D}"/$(kernel_header_destdir)/drm
+}
+
+src_test() {
+ emake ARCH=$(tc-arch-kernel) headers_check || die
+}