summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2008-11-26 23:06:25 +0000
committerMike Pagano <mpagano@gentoo.org>2008-11-26 23:06:25 +0000
commitc816b9ce76c8d5f2c18177bf733577053ef181f0 (patch)
treea90e8964b0acdfd7aef94b47619e11d5c63acb32 /sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild
parentFix quoting (diff)
downloadgentoo-2-c816b9ce76c8d5f2c18177bf733577053ef181f0.tar.gz
gentoo-2-c816b9ce76c8d5f2c18177bf733577053ef181f0.tar.bz2
gentoo-2-c816b9ce76c8d5f2c18177bf733577053ef181f0.zip
Cleanup of old versions and more parallel build fixes.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r4 i686)
Diffstat (limited to 'sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild')
-rw-r--r--sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild b/sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild
index 050e32aa5ea6..49428a89a483 100644
--- a/sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild
+++ b/sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild,v 1.1 2008/05/08 12:24:12 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-docs/linux-docs-2.6.25.2.ebuild,v 1.2 2008/11/26 23:06:25 mpagano Exp $
inherit toolchain-funcs
@@ -29,16 +29,21 @@ src_unpack() {
-e "s:db2:docbook2:g" \
-e "s:/usr/local/man:${D}/usr/share/man:g" \
"${S}"/Documentation/DocBook/Makefile
+
+ sed -i \
+ -e "s:\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:+\$(Q)\$(MAKE) \$(build)=Documentation\/DocBook \$@:" \
+ "${S}"/Makefile
+
}
src_compile() {
local ARCH=$(tc-arch-kernel)
unset KBUILD_OUTPUT
- make mandocs || die "make mandocs failed"
+ emake mandocs || die "make mandocs failed"
if use html; then
- make htmldocs || die "make htmldocs failed"
+ emake htmldocs || die "make htmldocs failed"
fi
}