summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael J. Cohen <mjc@gentoo.org>2002-08-20 11:02:31 +0000
committerMichael J. Cohen <mjc@gentoo.org>2002-08-20 11:02:31 +0000
commitb8f1d0f0d8aa47eb5c9f30de965f53f00a2d49e9 (patch)
tree94b45c52691fb3d7109ee4c95495ad7829ac8c45 /sys-kernel/gentoo-sources
parentchangelogs for 3.0.3 (diff)
downloadgentoo-2-b8f1d0f0d8aa47eb5c9f30de965f53f00a2d49e9.tar.gz
gentoo-2-b8f1d0f0d8aa47eb5c9f30de965f53f00a2d49e9.tar.bz2
gentoo-2-b8f1d0f0d8aa47eb5c9f30de965f53f00a2d49e9.zip
New ebuild =)
Diffstat (limited to 'sys-kernel/gentoo-sources')
-rw-r--r--sys-kernel/gentoo-sources/ChangeLog7
-rw-r--r--sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r8.ebuild102
2 files changed, 108 insertions, 1 deletions
diff --git a/sys-kernel/gentoo-sources/ChangeLog b/sys-kernel/gentoo-sources/ChangeLog
index 5c7ba4c841e1..6d16b542c2d5 100644
--- a/sys-kernel/gentoo-sources/ChangeLog
+++ b/sys-kernel/gentoo-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/gentoo-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.2 2002/07/16 04:31:38 gerk Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/ChangeLog,v 1.3 2002/08/20 11:02:31 mjc Exp $
+
+*gentoo-sources-2.4.19-r8 (20 Aug 2002)
+
+ 20 Aug 2002; Michael Cohen <mjc@gentoo.org>
+ new kernel with sys-kmod/$foo. needs to have sparc* and ppc tested.
*gentoo-sources-2.4.19-r7 (09 Jul 2002)
diff --git a/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r8.ebuild b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r8.ebuild
new file mode 100644
index 000000000000..e8647381479f
--- /dev/null
+++ b/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r8.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/gentoo-sources/gentoo-sources-2.4.19-r8.ebuild,v 1.1 2002/08/20 11:02:31 mjc Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.19
+KV=2.4.19-gentoo-r8
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+#What's in this kernel?
+
+#INCLUDED:
+# 2.4.19-rmap14a from http://surriel.com/patches
+# 2.4.19-rc5-preempt-3 from http://tech9.net/rml
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/${KV}.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/"
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}