summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-08-12 22:58:10 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-08-12 22:58:10 +0000
commit5c5c72cc72b5ce4429bd384ea668986c5b1e2d05 (patch)
treecb4cb10c6f8c6cdafca927da380bbc1410d961bc /sys-fs
parentForce build with libgif, not libungif; Resolves Bug #95961. (diff)
downloadgentoo-2-5c5c72cc72b5ce4429bd384ea668986c5b1e2d05.tar.gz
gentoo-2-5c5c72cc72b5ce4429bd384ea668986c5b1e2d05.tar.bz2
gentoo-2-5c5c72cc72b5ce4429bd384ea668986c5b1e2d05.zip
2.6.0_pre3 fix thanks to Leo <sir_kalot@yahoo.it> in bug 143544
(Portage version: 2.1.1_pre5)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/captive/ChangeLog6
-rw-r--r--sys-fs/captive/captive-1.1.7-r1.ebuild10
-rw-r--r--sys-fs/captive/files/captive-fuse-2.6.0_pre3.patch11
3 files changed, 25 insertions, 2 deletions
diff --git a/sys-fs/captive/ChangeLog b/sys-fs/captive/ChangeLog
index 40da97f801d2..8488e8557215 100644
--- a/sys-fs/captive/ChangeLog
+++ b/sys-fs/captive/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/captive
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/ChangeLog,v 1.16 2006/06/01 14:50:20 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/ChangeLog,v 1.17 2006/08/12 22:58:10 genstef Exp $
+
+ 12 Aug 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/captive-fuse-2.6.0_pre3.patch, captive-1.1.7-r1.ebuild:
+ 2.6.0_pre3 fix thanks to Leo <sir_kalot@yahoo.it> in bug 143544
01 Jun 2006; Stefan Schweizer <genstef@gentoo.org>
captive-1.1.7-r1.ebuild:
diff --git a/sys-fs/captive/captive-1.1.7-r1.ebuild b/sys-fs/captive/captive-1.1.7-r1.ebuild
index 8102daa3b89d..9f171d9829b0 100644
--- a/sys-fs/captive/captive-1.1.7-r1.ebuild
+++ b/sys-fs/captive/captive-1.1.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/captive-1.1.7-r1.ebuild,v 1.5 2006/06/01 16:22:34 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/captive/captive-1.1.7-r1.ebuild,v 1.6 2006/08/12 22:58:10 genstef Exp $
inherit eutils
@@ -43,6 +43,14 @@ pkg_setup() {
enewuser captive -1 -1 /dev/null captive || die "enewuser captive failed"
}
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ if has_version '>=sys-fs/fuse-2.6.0_pre3'; then
+ epatch ${FILESDIR}/captive-fuse-2.6.0_pre3.patch
+ fi
+}
+
src_compile() {
# Addwrite to fix all sandbox problems, bug #133357 see also gnome2.eclass: bug #128289
addwrite /root/.gnome2_private /root/.gnome2 /root/.gconfd /root/.gconf
diff --git a/sys-fs/captive/files/captive-fuse-2.6.0_pre3.patch b/sys-fs/captive/files/captive-fuse-2.6.0_pre3.patch
new file mode 100644
index 000000000000..a653908caf5e
--- /dev/null
+++ b/sys-fs/captive/files/captive-fuse-2.6.0_pre3.patch
@@ -0,0 +1,11 @@
+--- captive-1.1.7/src/client/fuse/main.c.orig 2006-08-12 22:54:51.000000000 +0200
++++ captive-1.1.7/src/client/fuse/main.c 2006-08-12 23:06:58.000000000 +0200
+@@ -116,7 +116,7 @@
+ * FIXME: Why?
+ */
+ }
+- fuse_teardown(capfuse_fuse,capfuse_fd,capfuse_mountpoint);
++ fuse_teardown(capfuse_fuse,capfuse_mountpoint);
+ }
+
+ int main(int argc,char **argv)