summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-01-05 06:09:08 +0000
committerMike Frysinger <vapier@gentoo.org>2005-01-05 06:09:08 +0000
commit3fd9a9585e533b15f61971bbf01f5271c695329f (patch)
tree69b86875a80a700009450a1d29d5964469d56e1d /sys-fs
parenthppa/ia64 stable (Manifest recommit) (diff)
downloadgentoo-2-3fd9a9585e533b15f61971bbf01f5271c695329f.tar.gz
gentoo-2-3fd9a9585e533b15f61971bbf01f5271c695329f.tar.bz2
gentoo-2-3fd9a9585e533b15f61971bbf01f5271c695329f.zip
cross-compile fixes
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-2.1_p2.ebuild22
1 files changed, 11 insertions, 11 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-2.1_p2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-2.1_p2.ebuild
index 9ceb26527fba..26dfedffedcb 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-2.1_p2.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-2.1_p2.ebuild
@@ -1,23 +1,23 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-2.1_p2.ebuild,v 1.1 2004/12/15 19:40:59 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/squashfs-tools/squashfs-tools-2.1_p2.ebuild,v 1.2 2005/01/05 06:09:08 vapier Exp $
+inherit toolchain-funcs
MY_PV=${PV/_p/-r}
DESCRIPTION="Tool for creating compressed filesystem type squashfs"
HOMEPAGE="http://squashfs.sourceforge.net/"
SRC_URI="mirror://sourceforge/squashfs/squashfs${MY_PV}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 sparc ~x86"
IUSE=""
-DEPEND="virtual/libc
- sys-libs/zlib
- >=sys-apps/sed-4"
-
RDEPEND="virtual/libc
sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
S=${WORKDIR}/squashfs${PV/_p/-r}/squashfs-tools
@@ -28,14 +28,14 @@ src_unpack() {
}
src_compile() {
- emake || die
+ emake CC="$(tc-getCC)" || die
}
src_test() {
- ./mksquashfs *.c *.h ${T}/squashfs && einfo "sucessfully created filesystem" \
+ ./mksquashfs *.c *.h ${T}/squashfs \
+ && einfo "sucessfully created filesystem" \
|| die "failed to create filesystem"
- if ! fgrep -q squashfs ${ROOT}/proc/filesystems;
- then
+ if ! fgrep -q squashfs ${ROOT}/proc/filesystems ; then
modprobe squashfs || ewarn "no squashfs modules - test not completed"
touch ${T}/modprobe
fgrep -q squashfs ${ROOT}/proc/filesystems || \