summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2005-06-03 19:27:21 +0000
committerTim Yamin <plasmaroo@gentoo.org>2005-06-03 19:27:21 +0000
commit1c73a27528ec5b897f386e2a400d81ce1901822e (patch)
tree94ef031def62b2c4d8e02d35db5121744f18ad0a /sys-fs
parentstable on mips (diff)
downloadgentoo-2-1c73a27528ec5b897f386e2a400d81ce1901822e.tar.gz
gentoo-2-1c73a27528ec5b897f386e2a400d81ce1901822e.tar.bz2
gentoo-2-1c73a27528ec5b897f386e2a400d81ce1901822e.zip
Fix #94880.
(Portage version: 2.0.51.22)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ext2resize/ChangeLog8
-rw-r--r--sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild5
-rw-r--r--sys-fs/ext2resize/files/ext2resize-1.1.17-linux26.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/sys-fs/ext2resize/ChangeLog b/sys-fs/ext2resize/ChangeLog
index 09538532c876..cd632b4fd904 100644
--- a/sys-fs/ext2resize/ChangeLog
+++ b/sys-fs/ext2resize/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/ext2resize
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ChangeLog,v 1.6 2004/06/25 03:17:27 agriffis Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ChangeLog,v 1.7 2005/06/03 19:27:21 plasmaroo Exp $
+
+ 03 Jun 2005; <plasmaroo@gentoo.org> ext2resize-1.1.17-r2.ebuild,
+ +files/ext2resize-1.1.17-linux26.patch:
+ Fix #94880.
*ext2resize-1.1.17-r2 (05 Jun 2004)
diff --git a/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild b/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild
index 432e3a088dde..d9f4e3fa5bbb 100644
--- a/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild
+++ b/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild,v 1.3 2004/06/30 17:09:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/ext2resize/ext2resize-1.1.17-r2.ebuild,v 1.4 2005/06/03 19:27:21 plasmaroo Exp $
inherit flag-o-matic eutils
@@ -26,6 +26,7 @@ src_unpack() {
# Fix broken source for non-''old'' GCCs
sed -e 's/printf(__FUNCTION__ \"\\n\");/printf(\"%s\\n\", __FUNCTION__);/g' -i src/*.c
epatch ${FILESDIR}/${P}-gcc3.3.patch
+ epatch ${FILESDIR}/${P}-linux26.patch
}
src_compile() {
diff --git a/sys-fs/ext2resize/files/ext2resize-1.1.17-linux26.patch b/sys-fs/ext2resize/files/ext2resize-1.1.17-linux26.patch
new file mode 100644
index 000000000000..2e9cdde766f4
--- /dev/null
+++ b/sys-fs/ext2resize/files/ext2resize-1.1.17-linux26.patch
@@ -0,0 +1,11 @@
+--- /var/tmp/portage/ext2resize-1.1.17-r2/work/ext2resize-1.1.17/src/ext2.h 2001-03-15 20:35:09.000000000 +0000
++++ ext2.h 2005-06-03 20:17:39.000000000 +0100
+@@ -53,7 +53,7 @@
+ typedef u_int32_t blk_t;
+
+ #if defined(HAVE_LINUX_EXT2_FS_H) && defined(HAVE_EXT2_DIR_ENTRY_2)
+-#define _LINUX_TYPES_H
++/* #define _LINUX_TYPES_H */
+ #define i_version i_generation
+ #include <linux/ext2_fs.h>
+ #else