summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2005-07-11 15:11:00 +0000
committerStefan Schweizer <genstef@gentoo.org>2005-07-11 15:11:00 +0000
commit16338f6848b8f070ef11acb64d6cfc7d5caf9342 (patch)
tree7c15cf525d6da0f966f05935a18376cc6e686661 /sys-fs
parentStable on sparc (diff)
downloadgentoo-2-16338f6848b8f070ef11acb64d6cfc7d5caf9342.tar.gz
gentoo-2-16338f6848b8f070ef11acb64d6cfc7d5caf9342.tar.bz2
gentoo-2-16338f6848b8f070ef11acb64d6cfc7d5caf9342.zip
Version bump thanks to Alon Bar-Lev <alon.barlev@gmail.com> in bug 98389
(Portage version: 1.589-cvs)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/loop-aes/ChangeLog7
-rw-r--r--sys-fs/loop-aes/Manifest6
-rw-r--r--sys-fs/loop-aes/files/digest-loop-aes-3.0d1
-rw-r--r--sys-fs/loop-aes/loop-aes-3.0d.ebuild64
4 files changed, 75 insertions, 3 deletions
diff --git a/sys-fs/loop-aes/ChangeLog b/sys-fs/loop-aes/ChangeLog
index 1c11ec0a0445..48db813e65ab 100644
--- a/sys-fs/loop-aes/ChangeLog
+++ b/sys-fs/loop-aes/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-fs/loop-aes
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/loop-aes/ChangeLog,v 1.4 2005/06/21 09:49:01 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/loop-aes/ChangeLog,v 1.5 2005/07/11 15:11:00 genstef Exp $
+
+*loop-aes-3.0d (11 Jul 2005)
+
+ 11 Jul 2005; Stefan Schweizer <genstef@gentoo.org> +loop-aes-3.0d.ebuild:
+ Version bump thanks to Alon Bar-Lev <alon.barlev@gmail.com> in bug 98389
21 Jun 2005; Simon Stelling <blubb@gentoo.org> loop-aes-3.0c.ebuild:
added ~amd64 keyword
diff --git a/sys-fs/loop-aes/Manifest b/sys-fs/loop-aes/Manifest
index 8e2b674d4834..87c6bd4da2ab 100644
--- a/sys-fs/loop-aes/Manifest
+++ b/sys-fs/loop-aes/Manifest
@@ -1,6 +1,8 @@
-MD5 d3296654d64e21467b1b60f6f4f214e1 ChangeLog 1093
MD5 6cc8146043588a78178cdddf5633f164 loop-aes-3.0b.ebuild 1393
-MD5 6d924ebdbe12162835ab1c1ea584636e metadata.xml 161
+MD5 b8a0b1b1cbee81b65f5bb239fe98c5a1 loop-aes-3.0d.ebuild 1552
MD5 b8a0b1b1cbee81b65f5bb239fe98c5a1 loop-aes-3.0c.ebuild 1552
+MD5 d3296654d64e21467b1b60f6f4f214e1 ChangeLog 1093
+MD5 6d924ebdbe12162835ab1c1ea584636e metadata.xml 161
MD5 31ae0c6dfb87e80f757e11b284ce19f1 files/digest-loop-aes-3.0b 67
MD5 fea513cc65c067262f379ffa404834c7 files/digest-loop-aes-3.0c 67
+MD5 083cae12c968ae38da2a2a89c57c3a7e files/digest-loop-aes-3.0d 67
diff --git a/sys-fs/loop-aes/files/digest-loop-aes-3.0d b/sys-fs/loop-aes/files/digest-loop-aes-3.0d
new file mode 100644
index 000000000000..840602ed95d0
--- /dev/null
+++ b/sys-fs/loop-aes/files/digest-loop-aes-3.0d
@@ -0,0 +1 @@
+MD5 650186003f301362247a7d16f138eb43 loop-AES-v3.0d.tar.bz2 165472
diff --git a/sys-fs/loop-aes/loop-aes-3.0d.ebuild b/sys-fs/loop-aes/loop-aes-3.0d.ebuild
new file mode 100644
index 000000000000..47b8200efcbe
--- /dev/null
+++ b/sys-fs/loop-aes/loop-aes-3.0d.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/loop-aes/loop-aes-3.0d.ebuild,v 1.1 2005/07/11 15:11:00 genstef Exp $
+
+inherit linux-mod eutils
+
+MY_P="${PN/aes/AES}-v${PV}"
+DESCRIPTION="Linux kernel module to encrypt local file systems and disk partitions with AES cipher."
+HOMEPAGE="http://loop-aes.sourceforge.net/loop-AES.README"
+SRC_URI="mirror://sourceforge/loop-aes/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="keyscrub"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${MY_P}
+
+CONFIG_CHECK="!BLK_DEV_LOOP"
+MODULE_NAMES="loop(block:)"
+BUILD_TARGETS="all"
+
+RDEPEND=">=sys-apps/util-linux-2.12q-r1"
+
+pkg_setup() {
+ if ! built_with_use util-linux crypt; then
+ eerror "loop-aes needs >=util-linux-2.12q-r1 compiled with crypt use-flag enabled!"
+ die "util-linux without crypt detected"
+ fi
+
+ linux-mod_pkg_setup
+
+ if ! linux_chkconfig_present KMOD && \
+ ! linux_chkconfig_present KERNELD
+ then
+ ewarn ""
+ ewarn "It is recommended to have Automatic kernel module loading"
+ ewarn "(CONFIG_KERNELD in kernels 2.0 or CONFIG_KMOD in newer)"
+ ewarn ""
+ fi
+
+ BUILD_PARAMS="LINUX_SOURCE=${KV_DIR} MODINST=n RUNDM=n"
+ use keyscrub && BUILD_PARAMS="${BUILD_PARAMS} KEYSCRUB=y"
+}
+
+src_unpack () {
+ unpack ${A}
+ convert_to_m ${S}/Makefile
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+
+ einfo ""
+ einfo "For more instructions take a look at examples in"
+ einfo "/usr/share/doc/${PF}/README.gz"
+ einfo ""
+}