summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2011-07-26 00:09:54 +0000
committerZac Medico <zmedico@gentoo.org>2011-07-26 00:09:54 +0000
commit00d3fac32776f9bcc961d4d2631d6a8eebecf1bb (patch)
tree198ff0307a89911a40a376e31c1ba8f790493f47 /sys-fs
parentExtend puppet rights and clean ups (diff)
downloadgentoo-2-00d3fac32776f9bcc961d4d2631d6a8eebecf1bb.tar.gz
gentoo-2-00d3fac32776f9bcc961d4d2631d6a8eebecf1bb.tar.bz2
gentoo-2-00d3fac32776f9bcc961d4d2631d6a8eebecf1bb.zip
Bump to EAPI 3 and fix for prefix.
(Portage version: 2.2.0_alpha47/cvs/Linux i686)
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/ChangeLog5
-rw-r--r--sys-fs/fuse/fuse-2.8.5.ebuild10
2 files changed, 10 insertions, 5 deletions
diff --git a/sys-fs/fuse/ChangeLog b/sys-fs/fuse/ChangeLog
index 2b4cca68f65e..3cddd2734bee 100644
--- a/sys-fs/fuse/ChangeLog
+++ b/sys-fs/fuse/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-fs/fuse
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.143 2011/03/30 20:42:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/ChangeLog,v 1.144 2011/07/26 00:09:54 zmedico Exp $
+
+ 26 Jul 2011; Zac Medico <zmedico@gentoo.org> fuse-2.8.5.ebuild:
+ Bump to EAPI 3 and fix for prefix.
30 Mar 2011; Samuli Suominen <ssuominen@gentoo.org> fuse-2.8.5.ebuild:
Install 99-fuse.rules to /lib/udev instead of /etc/udev.
diff --git a/sys-fs/fuse/fuse-2.8.5.ebuild b/sys-fs/fuse/fuse-2.8.5.ebuild
index 45e2c6ccad89..0a5c05e22679 100644
--- a/sys-fs/fuse/fuse-2.8.5.ebuild
+++ b/sys-fs/fuse/fuse-2.8.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.8.5.ebuild,v 1.10 2011/03/30 20:42:33 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse/fuse-2.8.5.ebuild,v 1.11 2011/07/26 00:09:54 zmedico Exp $
-EAPI=2
+EAPI=3
inherit eutils libtool linux-info
MY_P=${P/_/-}
@@ -35,7 +35,9 @@ src_prepare() {
src_configure() {
econf \
- UDEV_RULES_PATH=/lib/udev/rules.d \
+ INIT_D_PATH="${EPREFIX}/etc/init.d" \
+ MOUNT_FUSE_PATH="${EPREFIX}/sbin" \
+ UDEV_RULES_PATH="${EPREFIX}/lib/udev/rules.d" \
--disable-example
}
@@ -61,7 +63,7 @@ src_install() {
rm -rf "${D}/dev"
dodir /etc
- cat >"${D}"/etc/fuse.conf <<-EOF
+ cat >"${ED}"/etc/fuse.conf <<-EOF
# Set the maximum number of FUSE mounts allowed to non-root users.
# The default is 1000.
#