summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-05 11:20:58 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-05 11:20:58 +0000
commit8047fd04e3668e2937edf5c9360baabde9a29bda (patch)
tree648209d71dbafa7660483e0a9ee3164cbd5a911a /sys-fs/fuse-zip/fuse-zip-0.2.12.ebuild
parentVersion bump. Our rubyforge patch is no longer needed. (diff)
downloadgentoo-2-8047fd04e3668e2937edf5c9360baabde9a29bda.tar.gz
gentoo-2-8047fd04e3668e2937edf5c9360baabde9a29bda.tar.bz2
gentoo-2-8047fd04e3668e2937edf5c9360baabde9a29bda.zip
Moved from sunrise overlay. Fixes bug #241202
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/fuse-zip/fuse-zip-0.2.12.ebuild')
-rw-r--r--sys-fs/fuse-zip/fuse-zip-0.2.12.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sys-fs/fuse-zip/fuse-zip-0.2.12.ebuild b/sys-fs/fuse-zip/fuse-zip-0.2.12.ebuild
new file mode 100644
index 000000000000..80bdff84b53f
--- /dev/null
+++ b/sys-fs/fuse-zip/fuse-zip-0.2.12.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/fuse-zip/fuse-zip-0.2.12.ebuild,v 1.1 2010/06/05 11:20:58 hwoarang Exp $
+
+EAPI=2
+
+DESCRIPTION="FUSE file system to navigate, extract, create and modify ZIP archives based on libzip"
+HOMEPAGE="http://code.google.com/p/fuse-zip/"
+SRC_URI="http://fuse-zip.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libzip
+ sys-fs/fuse"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Fix strip than installing fuse-zip
+ sed -i -e 's/install -m 755 -s/install -m 755/' Makefile || die "sed failed"
+}
+
+src_install() {
+ emake INSTALLPREFIX="${D}"/usr install || die "Failed to install"
+ prepalldocs
+}