summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-15 10:03:06 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-15 10:03:06 +0000
commit9c4d3a85256ff33f7cfa6fb6f3eb4cdcbd800a5e (patch)
tree667b5523d40b8444ffdcf5be6c975d14ca105ce2 /sys-fs/dosfstools
parentVersion bump. (diff)
downloadgentoo-2-9c4d3a85256ff33f7cfa6fb6f3eb4cdcbd800a5e.tar.gz
gentoo-2-9c4d3a85256ff33f7cfa6fb6f3eb4cdcbd800a5e.tar.bz2
gentoo-2-9c4d3a85256ff33f7cfa6fb6f3eb4cdcbd800a5e.zip
Version bump.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'sys-fs/dosfstools')
-rw-r--r--sys-fs/dosfstools/ChangeLog8
-rw-r--r--sys-fs/dosfstools/dosfstools-3.0.20.ebuild28
-rw-r--r--sys-fs/dosfstools/files/dosfstools-3.0.20-name-ext.patch29
3 files changed, 64 insertions, 1 deletions
diff --git a/sys-fs/dosfstools/ChangeLog b/sys-fs/dosfstools/ChangeLog
index e7f29289700f..e57b14ee973e 100644
--- a/sys-fs/dosfstools/ChangeLog
+++ b/sys-fs/dosfstools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-fs/dosfstools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/ChangeLog,v 1.125 2013/06/02 08:44:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/ChangeLog,v 1.126 2013/06/15 10:03:06 radhermit Exp $
+
+*dosfstools-3.0.20 (15 Jun 2013)
+
+ 15 Jun 2013; Tim Harder <radhermit@gentoo.org> +dosfstools-3.0.20.ebuild,
+ +files/dosfstools-3.0.20-name-ext.patch:
+ Version bump.
02 Jun 2013; Agostino Sarubbo <ago@gentoo.org> dosfstools-3.0.16.ebuild:
Stable for sh, wrt bug #469358
diff --git a/sys-fs/dosfstools/dosfstools-3.0.20.ebuild b/sys-fs/dosfstools/dosfstools-3.0.20.ebuild
new file mode 100644
index 000000000000..e8f2ce6bc8bd
--- /dev/null
+++ b/sys-fs/dosfstools/dosfstools-3.0.20.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dosfstools/dosfstools-3.0.20.ebuild,v 1.1 2013/06/15 10:03:06 radhermit Exp $
+
+EAPI="5"
+
+inherit toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="DOS filesystem tools - provides mkdosfs, mkfs.msdos, mkfs.vfat"
+HOMEPAGE="http://www.daniel-baumann.ch/software/dosfstools/"
+SRC_URI="http://www.daniel-baumann.ch/files/software/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+RESTRICT="test" # there is no test target #239071
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.20-name-ext.patch
+ sed -i \
+ -e "/^PREFIX/s:=.*:= ${EPREFIX}/usr:" \
+ -e '/^OPTFLAGS/d' \
+ -e '/^DEBUGFLAGS/d' \
+ -e "/\$(DOCDIR)/s:${PN}:${PF}:" \
+ Makefile || die
+ append-lfs-flags
+ tc-export CC
+}
diff --git a/sys-fs/dosfstools/files/dosfstools-3.0.20-name-ext.patch b/sys-fs/dosfstools/files/dosfstools-3.0.20-name-ext.patch
new file mode 100644
index 000000000000..71149bd4d803
--- /dev/null
+++ b/sys-fs/dosfstools/files/dosfstools-3.0.20-name-ext.patch
@@ -0,0 +1,29 @@
+avoid fortify warnings about going beyond array bounds as the strcmp
+assumes name[8] and ext[3] are together
+
+--- dosfstools-3.0.20/src/check.c
++++ dosfstools-3.0.20/src/check.c
+@@ -264,7 +264,7 @@
+ {
+ int i, spc, suspicious = 0;
+ const char *bad_chars = atari_format ? "*?\\/:" : "*?<>|\"\\/:";
+- const unsigned char *name = file->dir_ent.name;
++ const unsigned char *name = file->dir_ent.name_ext;
+ const unsigned char *ext = file->dir_ent.ext;
+
+ /* Do not complain about (and auto-correct) the extended attribute files
+--- dosfstools-3.0.20/src/fsck.fat.h
++++ dosfstools-3.0.20/src/fsck.fat.h
+@@ -126,7 +126,12 @@
+ };
+
+ typedef struct {
++ union {
++ struct {
+ __u8 name[8], ext[3]; /* name and extension */
++ };
++ __u8 name_ext[11];
++ };
+ __u8 attr; /* attribute bits */
+ __u8 lcase; /* Case for base and extension */
+ __u8 ctime_ms; /* Creation time, milliseconds */