summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-14 13:37:29 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-14 13:37:29 +0000
commit3ecfa6ff31b2f059141adcdac681b9218da3cfe8 (patch)
tree779013fa5134119d5585b26115ed346ef33126fb /sys-fs/avfs
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-3ecfa6ff31b2f059141adcdac681b9218da3cfe8.tar.gz
gentoo-2-3ecfa6ff31b2f059141adcdac681b9218da3cfe8.tar.bz2
gentoo-2-3ecfa6ff31b2f059141adcdac681b9218da3cfe8.zip
Some QA on ebuild style and die
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'sys-fs/avfs')
-rw-r--r--sys-fs/avfs/ChangeLog6
-rw-r--r--sys-fs/avfs/avfs-0.9.7-r1.ebuild26
-rw-r--r--sys-fs/avfs/avfs-0.9.8-r1.ebuild24
-rw-r--r--sys-fs/avfs/avfs-0.9.8.ebuild22
4 files changed, 40 insertions, 38 deletions
diff --git a/sys-fs/avfs/ChangeLog b/sys-fs/avfs/ChangeLog
index 0efd8eb6d68f..5c8649ca0a7e 100644
--- a/sys-fs/avfs/ChangeLog
+++ b/sys-fs/avfs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-fs/avfs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.26 2010/11/14 13:32:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/ChangeLog,v 1.27 2010/11/14 13:37:29 jlec Exp $
+
+ 14 Nov 2010; Justin Lecher <jlec@gentoo.org> avfs-0.9.7-r1.ebuild,
+ avfs-0.9.8.ebuild, avfs-0.9.8-r1.ebuild:
+ Some QA on ebuild style and die
14 Nov 2010; Justin Lecher <jlec@gentoo.org> avfs-0.9.9.ebuild,
metadata.xml:
diff --git a/sys-fs/avfs/avfs-0.9.7-r1.ebuild b/sys-fs/avfs/avfs-0.9.7-r1.ebuild
index 5055e672a18d..48238253142f 100644
--- a/sys-fs/avfs/avfs-0.9.7-r1.ebuild
+++ b/sys-fs/avfs/avfs-0.9.7-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.7-r1.ebuild,v 1.4 2007/07/21 13:57:10 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.7-r1.ebuild,v 1.5 2010/11/14 13:37:29 jlec Exp $
inherit linux-info
@@ -11,6 +11,7 @@ SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc sparc ~x86"
+IUSE=""
DEPEND=">=sys-fs/fuse-2.4"
RDEPEND="${DEPEND}"
@@ -20,25 +21,24 @@ pkg_setup() {
}
src_compile() {
- econf --enable-fuse --enable-library || die "Sorry, can't configure :("
+ econf --enable-fuse --enable-library
emake || die "Sorry make failed :("
}
src_install() {
einstall || die "Sorry, make install failed :("
# remove cruft
- dobin scripts/avfs-config
- cd ${D}/usr
- rm -f bin/davpass bin/ftppass
- rm -fr sbin ../etc
- cd ${S}
- cd doc
- dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse
+ dobin scripts/avfs-config || die
+ cd "${D}"/usr
+ rm -f bin/davpass bin/ftppass || die
+ rm -fr sbin ../etc || die
+ cd "${S}"/doc
+ dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse || die
cd ..
- dodoc AUTHORS ChangeLog COPYING* INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || die
docinto scripts
- dodoc scripts/avfs* scripts/*pass scripts/*mountavfs
- dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+ dodoc scripts/avfs* scripts/*pass scripts/*mountavfs || die
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs || die
}
pkg_postinst() {
diff --git a/sys-fs/avfs/avfs-0.9.8-r1.ebuild b/sys-fs/avfs/avfs-0.9.8-r1.ebuild
index 0f099bc1ef35..787eb40a24e5 100644
--- a/sys-fs/avfs/avfs-0.9.8-r1.ebuild
+++ b/sys-fs/avfs/avfs-0.9.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.8-r1.ebuild,v 1.5 2010/10/24 17:31:34 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.8-r1.ebuild,v 1.6 2010/11/14 13:37:29 jlec Exp $
inherit eutils linux-info
@@ -11,12 +11,11 @@ SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~hppa ia64 ~ppc sparc x86"
+IUSE=""
DEPEND=">=sys-fs/fuse-2.4"
RDEPEND="${DEPEND}"
-IUSE=""
-
pkg_setup() {
kernel_is lt 2 6 && die "Must have a version 2.6 kernel. Cannot continue. :("
}
@@ -24,25 +23,24 @@ pkg_setup() {
src_compile() {
# Fixs bug #258295
epatch "${FILESDIR}/${P}-gcc43_fix_open_missing_mode.patch"
- econf --enable-fuse --enable-library || die "Sorry, can't configure :("
+ econf --enable-fuse --enable-library
emake || die "Sorry make failed :("
}
src_install() {
einstall || die "Sorry, make install failed :("
# remove cruft
- dobin scripts/avfs-config
+ dobin scripts/avfs-config || die
cd "${D}"/usr
- rm -f bin/davpass bin/ftppass
- rm -fr sbin ../etc
- cd "${S}"
- cd doc
- dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse
+ rm -f bin/davpass bin/ftppass || die
+ rm -fr sbin ../etc || die
+ cd "${S}"/doc
+ dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse || die
cd ..
- dodoc AUTHORS ChangeLog COPYING* INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || die
docinto scripts
- dodoc scripts/avfs* scripts/*pass scripts/*mountavfs
- dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+ dodoc scripts/avfs* scripts/*pass scripts/*mountavfs || die
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs || die
}
pkg_postinst() {
diff --git a/sys-fs/avfs/avfs-0.9.8.ebuild b/sys-fs/avfs/avfs-0.9.8.ebuild
index f445002a6270..acc20193db5a 100644
--- a/sys-fs/avfs/avfs-0.9.8.ebuild
+++ b/sys-fs/avfs/avfs-0.9.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.8.ebuild,v 1.4 2008/07/05 09:36:48 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/avfs/avfs-0.9.8.ebuild,v 1.5 2010/11/14 13:37:29 jlec Exp $
inherit linux-info
@@ -11,6 +11,7 @@ SRC_URI="mirror://sourceforge/avf/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~hppa ia64 ppc sparc x86"
+IUSE=""
DEPEND=">=sys-fs/fuse-2.4"
RDEPEND="${DEPEND}"
@@ -27,18 +28,17 @@ src_compile() {
src_install() {
einstall || die "Sorry, make install failed :("
# remove cruft
- dobin scripts/avfs-config
+ dobin scripts/avfs-config || die
cd "${D}"/usr
- rm -f bin/davpass bin/ftppass
- rm -fr sbin ../etc
- cd "${S}"
- cd doc
- dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse
+ rm -f bin/davpass bin/ftppass || die
+ rm -fr sbin ../etc || die
+ cd "${S}"/doc
+ dodoc api-overview background FORMAT INSTALL.* README.avfs-fuse || die
cd ..
- dodoc AUTHORS ChangeLog COPYING* INSTALL NEWS README TODO
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO || die
docinto scripts
- dodoc scripts/avfs* scripts/*pass scripts/*mountavfs
- dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs
+ dodoc scripts/avfs* scripts/*pass scripts/*mountavfs || die
+ dosym /usr/lib/avfs/extfs/README /usr/share/doc/${PF}/README.extfs || die
}
pkg_postinst() {