summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-05-27 13:06:03 +0000
committerRichard Yao <ryao@gentoo.org>2012-05-27 13:06:03 +0000
commit2fbef537e8c083a64baa9e2a67e5e86bd1bfdf0e (patch)
tree241d5a049791a21812dfd09c813732c28225a5a2 /sys-freebsd/freebsd-sources
parentarm stable, bug #415859 (diff)
downloadgentoo-2-2fbef537e8c083a64baa9e2a67e5e86bd1bfdf0e.tar.gz
gentoo-2-2fbef537e8c083a64baa9e2a67e5e86bd1bfdf0e.tar.bz2
gentoo-2-2fbef537e8c083a64baa9e2a67e5e86bd1bfdf0e.zip
Fix regression in -r2
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd/freebsd-sources')
-rw-r--r--sys-freebsd/freebsd-sources/ChangeLog11
-rw-r--r--sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-disable-optimization.patch (renamed from sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-gcc-disable-optimization.patch)6
-rw-r--r--sys-freebsd/freebsd-sources/freebsd-sources-9.0-r3.ebuild (renamed from sys-freebsd/freebsd-sources/freebsd-sources-9.0-r2.ebuild)4
3 files changed, 15 insertions, 6 deletions
diff --git a/sys-freebsd/freebsd-sources/ChangeLog b/sys-freebsd/freebsd-sources/ChangeLog
index 5e096f39ad58..f1641910e4c3 100644
--- a/sys-freebsd/freebsd-sources/ChangeLog
+++ b/sys-freebsd/freebsd-sources/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-freebsd/freebsd-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.71 2012/05/27 08:42:25 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.72 2012/05/27 13:06:03 ryao Exp $
+
+*freebsd-sources-9.0-r3 (27 May 2012)
+
+ 27 May 2012; Richard Yao <ryao@gentoo.org>
+ +files/freebsd-sources-9.0-disable-optimization.patch,
+ +freebsd-sources-9.0-r3.ebuild,
+ -files/freebsd-sources-9.0-gcc-disable-optimization.patch,
+ -freebsd-sources-9.0-r2.ebuild:
+ Fix regression in -r2
*freebsd-sources-9.0-r2 (27 May 2012)
diff --git a/sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-gcc-disable-optimization.patch b/sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-disable-optimization.patch
index a72d5beee9e1..4824ff6e1a09 100644
--- a/sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-gcc-disable-optimization.patch
+++ b/sys-freebsd/freebsd-sources/files/freebsd-sources-9.0-disable-optimization.patch
@@ -4,7 +4,7 @@ Regretably, with GCC 4.4 or later this is the only flag combination
I could find that doesn't cause kernel panics CPU triple-faults or
other kind of severe breakage. This is Gentoo Bug #410945.
-We restrict this to GCC so that Clang can use -O2.
+Clang can use -O2, so we do not force -O1 on it
--- a/sys/conf/kern.pre.mk
+++ b/sys/conf/kern.pre.mk
@@ -12,7 +12,7 @@ We restrict this to GCC so that Clang can use -O2.
.if !empty(COPTFLAGS:M-O[23s]) && empty(COPTFLAGS:M-fno-strict-aliasing)
COPTFLAGS+= -fno-strict-aliasing
.endif
-+.if ${CC:T:Mgcc} == "gcc" && !empty(COPTFLAGS:M-O[23s])
++.if ${CC:T:Mclang} != "clang" && !empty(COPTFLAGS:M-O[23s])
+COPTFLAGS+= -O1
+.endif
.if !defined(NO_CPU_COPTFLAGS)
@@ -24,7 +24,7 @@ We restrict this to GCC so that Clang can use -O2.
.if !empty(CFLAGS:M-O[23s]) && empty(CFLAGS:M-fno-strict-aliasing)
CFLAGS+= -fno-strict-aliasing
.endif
-+.if ${CC:T:Mgcc} == "gcc" && !empty(CFLAGS:M-O[23s])
++.if ${CC:T:Mclang} != "clang" && !empty(CFLAGS:M-O[23s])
+CFLAGS+= -O1
+.endif
WERROR?= -Werror
diff --git a/sys-freebsd/freebsd-sources/freebsd-sources-9.0-r2.ebuild b/sys-freebsd/freebsd-sources/freebsd-sources-9.0-r3.ebuild
index 078df82b6d62..2274bfb771c5 100644
--- a/sys-freebsd/freebsd-sources/freebsd-sources-9.0-r2.ebuild
+++ b/sys-freebsd/freebsd-sources/freebsd-sources-9.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-9.0-r2.ebuild,v 1.1 2012/05/27 08:42:25 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-9.0-r3.ebuild,v 1.1 2012/05/27 13:06:03 ryao Exp $
inherit bsdmk freebsd flag-o-matic
@@ -34,7 +34,7 @@ src_unpack() {
"${S}/conf/newvers.sh"
# workaround a kernel panic for amd64-fbsd, bug #408019
- epatch "${FILESDIR}/${PN}-9.0-gcc-disable-optimization.patch"
+ epatch "${FILESDIR}/${PN}-9.0-disable-optimization.patch"
# __FreeBSD_cc_version comes from FreeBSD's gcc.
# on 9.0-RELEASE it's 900001.