summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-24 14:14:11 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-24 14:14:11 +0000
commit185df05b6e6c6b20a6a6b62c46531b78588a3b3d (patch)
treece389d2865502f9d91cb6904f0c7f782d02737c4 /sys-freebsd/freebsd-sources
parentChange patch for compiling with newer PowerPC kernels, allow building on 2.6.... (diff)
downloadgentoo-2-185df05b6e6c6b20a6a6b62c46531b78588a3b3d.tar.gz
gentoo-2-185df05b6e6c6b20a6a6b62c46531b78588a3b3d.tar.bz2
gentoo-2-185df05b6e6c6b20a6a6b62c46531b78588a3b3d.zip
Add binchecks restrict for newer portage, and fix quoting.
(Portage version: 2.1_rc2-r2)
Diffstat (limited to 'sys-freebsd/freebsd-sources')
-rw-r--r--sys-freebsd/freebsd-sources/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-sources/freebsd-sources-6.1.ebuild26
2 files changed, 18 insertions, 14 deletions
diff --git a/sys-freebsd/freebsd-sources/ChangeLog b/sys-freebsd/freebsd-sources/ChangeLog
index 393c5a0cd525..1da1ace9efd6 100644
--- a/sys-freebsd/freebsd-sources/ChangeLog
+++ b/sys-freebsd/freebsd-sources/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-sources
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.11 2006/05/09 07:43:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/ChangeLog,v 1.12 2006/05/24 14:14:11 flameeyes Exp $
+
+ 24 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ freebsd-sources-6.1.ebuild:
+ Add binchecks restrict for newer portage, and fix quoting.
*freebsd-sources-6.1 (09 May 2006)
diff --git a/sys-freebsd/freebsd-sources/freebsd-sources-6.1.ebuild b/sys-freebsd/freebsd-sources/freebsd-sources-6.1.ebuild
index 116ba6749211..98b7307f81ce 100644
--- a/sys-freebsd/freebsd-sources/freebsd-sources-6.1.ebuild
+++ b/sys-freebsd/freebsd-sources/freebsd-sources-6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-6.1.ebuild,v 1.1 2006/05/09 07:43:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-sources/freebsd-sources-6.1.ebuild,v 1.2 2006/05/24 14:14:11 flameeyes Exp $
inherit bsdmk freebsd
@@ -15,9 +15,9 @@ SRC_URI="mirror://gentoo/${SYS}.tar.bz2"
RDEPEND=">=sys-freebsd/freebsd-mk-defs-6.0-r1"
DEPEND=""
-RESTRICT="nostrip"
+RESTRICT="strip binchecks"
-S=${WORKDIR}/sys
+S="${WORKDIR}/sys"
MY_PVR="${PVR}"
@@ -25,13 +25,13 @@ MY_PVR="${PVR}"
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# This replaces the gentoover patch, it doesn't need reapply every time.
sed -i -e 's:^REVISION=.*:REVISION="'${PVR}'":' \
-e 's:^BRANCH=.*:BRANCH="Gentoo":' \
-e 's:^VERSION=.*:VERSION="${TYPE} ${BRANCH} ${REVISION}":' \
- ${S}/conf/newvers.sh
+ "${S}/conf/newvers.sh"
epatch "${FILESDIR}/${PN}-gentoo.patch"
epatch "${FILESDIR}/${PN}-6.0-flex-2.5.31.patch"
@@ -48,23 +48,23 @@ src_compile() {
}
src_install() {
- insinto /usr/src/sys-${MY_PVR}
- doins -r ${S}/*
+ insinto "/usr/src/sys-${MY_PVR}"
+ doins -r "${S}/"*
}
pkg_postinst() {
- if [[ ! -L ${ROOT}/usr/src/sys ]]; then
+ if [[ ! -L $"{ROOT}/usr/src/sys" ]]; then
einfo "/usr/src/sys symlink doesn't exist; creating..."
- ln -sf sys-${MY_PVR} ${ROOT}/usr/src/sys || \
+ ln -sf "sys-${MY_PVR}" "${ROOT}/usr/src/sys" || \
eerror "Couldn't create ${ROOT}/usr/src/sys symlink."
- ln -sf sys-${MY_PVR} ${ROOT}/usr/src/sys-${RV} || \
+ ln -sf "sys-${MY_PVR}" "${ROOT}/usr/src/sys-${RV}" || \
eerror "Couldn't create ${ROOT}/usr/src/sys-${RV} symlink."
elif use symlink; then
einfo "Updating /usr/src/sys symlink..."
- rm ${ROOT}/usr/src/sys ${ROOT}/usr/src/sys-${RV}
- ln -sf sys-${MY_PVR} ${ROOT}/usr/src/sys || \
+ rm "${ROOT}/usr/src/sys" "${ROOT}/usr/src/sys-${RV}"
+ ln -sf "sys-${MY_PVR}" "${ROOT}/usr/src/sys" || \
eerror "Couldn't create ${ROOT}/usr/src/sys symlink."
- ln -sf sys-${MY_PVR} ${ROOT}/usr/src/sys-${RV} || \
+ ln -sf "sys-${MY_PVR}" "${ROOT}/usr/src/sys-${RV}" || \
eerror "Couldn't create ${ROOT}/usr/src/sys-${RV} symlink."
fi
}