summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-12 15:03:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-12 15:03:30 +0000
commit82b9ea88f8457c4e6303b9da731998276287977f (patch)
tree202b3290314b606d31dfcd3bbf9f94abd5a8576f /sys-freebsd/freebsd-lib
parentMask and de-keyword glibc-2.17 on alpha due to bug 480740 (diff)
downloadgentoo-2-82b9ea88f8457c4e6303b9da731998276287977f.tar.gz
gentoo-2-82b9ea88f8457c4e6303b9da731998276287977f.tar.bz2
gentoo-2-82b9ea88f8457c4e6303b9da731998276287977f.zip
Update the liblink patch for libcam, bug #480730 by Yuta SATOH
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/freebsd-lib')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog6
-rw-r--r--sys-freebsd/freebsd-lib/files/freebsd-lib-9.2-liblink.patch12
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.2_rc1.ebuild3
3 files changed, 18 insertions, 3 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index 26ec8adc9a9c..69e0eb7bca77 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.200 2013/08/12 14:53:54 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.201 2013/08/12 15:03:30 aballier Exp $
+
+ 12 Aug 2013; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.2_rc1.ebuild,
+ files/freebsd-lib-9.2-liblink.patch:
+ Update the liblink patch for libcam, bug #480730 by Yuta SATOH
12 Aug 2013; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.2_rc1.ebuild:
unpack the secure tarball too
diff --git a/sys-freebsd/freebsd-lib/files/freebsd-lib-9.2-liblink.patch b/sys-freebsd/freebsd-lib/files/freebsd-lib-9.2-liblink.patch
index cfc7181e3409..3759c91f0a89 100644
--- a/sys-freebsd/freebsd-lib/files/freebsd-lib-9.2-liblink.patch
+++ b/sys-freebsd/freebsd-lib/files/freebsd-lib-9.2-liblink.patch
@@ -53,3 +53,15 @@ diff -uNr lib.old/libprocstat/Makefile lib/libprocstat/Makefile
CFLAGS+= -I. -I${.CURDIR} -D_KVM_VNODE
SHLIB_MAJOR= 1
+diff --git a/lib/libcam/Makefile b/lib/libcam/Makefile
+index fcb16de..6d0312b 100644
+--- a/lib/libcam/Makefile
++++ b/lib/libcam/Makefile
+@@ -8,6 +8,7 @@ INCS= camlib.h
+
+ DPADD= ${LIBSBUF}
+ LDADD= -lsbuf
++LDFLAGS+= -L${.OBJDIR}/../libsbuf
+
+ MAN= cam.3 cam_cdbparse.3
+
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.2_rc1.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.2_rc1.ebuild
index 3eb9c9aa4a9e..c75a6f5307d4 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.2_rc1.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.2_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.2_rc1.ebuild,v 1.6 2013/08/12 14:53:54 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.2_rc1.ebuild,v 1.7 2013/08/12 15:03:30 aballier Exp $
EAPI=5
@@ -308,7 +308,6 @@ do_bootstrap() {
is_crosscompile && bootstrap_lib "lib/libc"
is_crosscompile || is_native_abi || bootstrap_libgcc
is_native_abi || bootstrap_libthr
- is_native_abi || bootstrap_lib "lib/libsbuf"
}
# Compile it. Assume we have the toolchain setup correctly.