summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-16 21:17:16 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-16 21:17:16 +0000
commit673b8150152c0b1f70db0c04974d0b3df146e62c (patch)
tree030d35e14fa55401230b24a640baef9335227ef4 /sys-firmware
parentUse new toolchain helpers for selecting the bfd linker #539388 by nzqr. (diff)
downloadgentoo-2-673b8150152c0b1f70db0c04974d0b3df146e62c.tar.gz
gentoo-2-673b8150152c0b1f70db0c04974d0b3df146e62c.tar.bz2
gentoo-2-673b8150152c0b1f70db0c04974d0b3df146e62c.zip
Use new toolchain helpers for selecting the bfd linker.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/sgabios/ChangeLog7
-rw-r--r--sys-firmware/sgabios/sgabios-0.1_pre8.ebuild22
2 files changed, 13 insertions, 16 deletions
diff --git a/sys-firmware/sgabios/ChangeLog b/sys-firmware/sgabios/ChangeLog
index 0e6496ed6cb4..d56779a5f7a7 100644
--- a/sys-firmware/sgabios/ChangeLog
+++ b/sys-firmware/sgabios/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-firmware/sgabios
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/sgabios/ChangeLog,v 1.5 2014/04/30 21:07:36 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/sgabios/ChangeLog,v 1.6 2015/03/16 21:17:16 vapier Exp $
+
+ 16 Mar 2015; Mike Frysinger <vapier@gentoo.org> sgabios-0.1_pre8.ebuild:
+ Use new toolchain helpers for selecting the bfd linker.
30 Apr 2014; Mike Frysinger <vapier@gentoo.org> sgabios-0.1_pre8.ebuild:
Add epatch_user support #487100 by Hristo Venev.
diff --git a/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild b/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild
index 7b24612f0bf9..fa57261bf177 100644
--- a/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild
+++ b/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild,v 1.5 2014/04/30 21:07:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/sgabios/sgabios-0.1_pre8.ebuild,v 1.6 2015/03/16 21:17:16 vapier Exp $
EAPI=4
@@ -17,16 +17,6 @@ SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
IUSE=""
-DEPEND=""
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- local myld=$(tc-getLD)
-
- ${myld} -v | grep -q "GNU gold" && \
- ewarn "gold linker unable to handle 16-bit code using ld.bfd. bug #438058"
-}
-
src_prepare() {
epatch "${FILESDIR}"/${P}-makefile.patch
epatch_user
@@ -34,8 +24,12 @@ src_prepare() {
src_compile() {
if use amd64 || use x86 ; then
- emake CC=$(tc-getCC) LD="$(tc-getLD).bfd" AR=$(tc-getAR) \
- OBJCOPY=$(tc-getOBJCOPY)
+ tc-ld-disable-gold
+ emake \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getLD)" \
+ AR="$(tc-getAR)" \
+ OBJCOPY="$(tc-getOBJCOPY)"
fi
}