summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-01-25 03:39:22 +0000
committerMark Wright <gienah@gentoo.org>2014-01-25 03:39:22 +0000
commit544d8f587a775d70374f438ccb1e0681b2823a11 (patch)
treef7294c9b53bcac72d53a3ac2663c1a3bdab9a22a /sys-firmware
parentVersion bump. Bump EAPI, move patches to a tarball and respin some, redo inst... (diff)
downloadgentoo-2-544d8f587a775d70374f438ccb1e0681b2823a11.tar.gz
gentoo-2-544d8f587a775d70374f438ccb1e0681b2823a11.tar.bz2
gentoo-2-544d8f587a775d70374f438ccb1e0681b2823a11.zip
Add firmware for the Intel Wireless Bluetooth 3160 and Intel Wireless Bluetooth 7260 devices. Part of bug #489714, thanks to Thomas Kear for reporting and testing.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/iwl3160-7260-bt-ucode/ChangeLog11
-rw-r--r--sys-firmware/iwl3160-7260-bt-ucode/iwl3160-7260-bt-ucode-37.10.10.ebuild39
-rw-r--r--sys-firmware/iwl3160-7260-bt-ucode/metadata.xml10
3 files changed, 60 insertions, 0 deletions
diff --git a/sys-firmware/iwl3160-7260-bt-ucode/ChangeLog b/sys-firmware/iwl3160-7260-bt-ucode/ChangeLog
new file mode 100644
index 000000000000..f4d82f39f7fe
--- /dev/null
+++ b/sys-firmware/iwl3160-7260-bt-ucode/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sys-firmware/iwl3160-7260-bt-ucode
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl3160-7260-bt-ucode/ChangeLog,v 1.1 2014/01/25 03:39:22 gienah Exp $
+
+*iwl3160-7260-bt-ucode-37.10.10 (25 Jan 2014)
+
+ 25 Jan 2014; Mark Wright <gienah@gentoo.org>
+ +iwl3160-7260-bt-ucode-37.10.10.ebuild, +metadata.xml:
+ Add firmware for the Intel Wireless Bluetooth 3160 and Intel Wireless
+ Bluetooth 7260 devices. Part of bug #489714, thanks to Thomas Kear for
+ reporting and testing.
diff --git a/sys-firmware/iwl3160-7260-bt-ucode/iwl3160-7260-bt-ucode-37.10.10.ebuild b/sys-firmware/iwl3160-7260-bt-ucode/iwl3160-7260-bt-ucode-37.10.10.ebuild
new file mode 100644
index 000000000000..c6c575a51750
--- /dev/null
+++ b/sys-firmware/iwl3160-7260-bt-ucode/iwl3160-7260-bt-ucode-37.10.10.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/iwl3160-7260-bt-ucode/iwl3160-7260-bt-ucode-37.10.10.ebuild,v 1.1 2014/01/25 03:39:22 gienah Exp $
+
+EAPI=5
+inherit linux-info
+
+MY_PN="iwlwifi-7260-ucode"
+
+DESCRIPTION="Firmware for Intel (R) Dual Band Wireless-AC 7260"
+HOMEPAGE="http://wireless.kernel.org/en/users/Drivers/iwlwifi"
+SRC_URI="https://chromium.googlesource.com/chromiumos/third_party/linux-firmware/+archive/refs/heads/upstream/master/intel.tar.gz -> ${P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!sys-kernel/linux-firmware[-savedconfig]"
+
+S="${WORKDIR}"
+
+CONFIG_CHECK="IWLMVM"
+ERROR_IWLMVM="CONFIG_IWLMVM is required to be enabled in /usr/src/linux/.config for the kernel to be able to load the 7260 firmware"
+
+pkg_pretend() {
+ if kernel_is lt 3 10 0; then
+ ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ ewarn "This microcode image requires a kernel >= 3.10.0."
+ fi
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins "${S}/ibt-hw-37.7.10-fw-1.0.2.3.d.bseq"
+ doins "${S}/ibt-hw-37.7.10-fw-1.80.2.3.d.bseq"
+ doins "${S}/ibt-hw-37.7.bseq"
+}
diff --git a/sys-firmware/iwl3160-7260-bt-ucode/metadata.xml b/sys-firmware/iwl3160-7260-bt-ucode/metadata.xml
new file mode 100644
index 000000000000..03df02aea9ad
--- /dev/null
+++ b/sys-firmware/iwl3160-7260-bt-ucode/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>gienah@gentoo.org</email>
+ <description>Feel free to bump and add yourself to the maintainer list,
+ please consider bumping sys-firmware/iwl3160-ucode and
+ sys-firmware/iwl7260-ucode as well.</description>
+ </maintainer>
+</pkgmetadata>