summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-01-06 21:06:16 +0000
committerMichał Górny <mgorny@gentoo.org>2014-01-06 21:06:16 +0000
commitf36338d5d6d729600cc747c3dbe7d42a8635ad22 (patch)
tree11929f86c731146191b4efcbf6dcdd66e0034714 /sys-devel
parentVersion bump. (diff)
downloadgentoo-2-f36338d5d6d729600cc747c3dbe7d42a8635ad22.tar.gz
gentoo-2-f36338d5d6d729600cc747c3dbe7d42a8635ad22.tar.bz2
gentoo-2-f36338d5d6d729600cc747c3dbe7d42a8635ad22.zip
Bump metapackage along with LLVM.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/clang/ChangeLog9
-rw-r--r--sys-devel/clang/clang-3.4-r100.ebuild36
2 files changed, 43 insertions, 2 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index 2275989c42c6..427e2005e01c 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/clang
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.99 2013/10/28 00:25:12 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.100 2014/01/06 21:06:16 mgorny Exp $
+
+*clang-3.4-r100 (06 Jan 2014)
+
+ 06 Jan 2014; Michał Górny <mgorny@gentoo.org> +clang-3.4-r100.ebuild:
+ Bump metapackage along with LLVM.
28 Oct 2013; Christoph Junghans <ottxor@gentoo.org> clang-3.3-r100.ebuild,
clang-9999-r100.ebuild:
diff --git a/sys-devel/clang/clang-3.4-r100.ebuild b/sys-devel/clang/clang-3.4-r100.ebuild
new file mode 100644
index 000000000000..84b5987355a7
--- /dev/null
+++ b/sys-devel/clang/clang-3.4-r100.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-3.4-r100.ebuild,v 1.1 2014/01/06 21:06:16 mgorny Exp $
+
+EAPI=5
+
+inherit multilib-build
+
+DESCRIPTION="C language family frontend for LLVM (meta-ebuild)"
+HOMEPAGE="http://clang.llvm.org/"
+SRC_URI=""
+
+LICENSE="UoI-NCSA"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug multitarget python +static-analyzer"
+
+RDEPEND="~sys-devel/llvm-${PV}[clang(-),debug=,multitarget?,python?,static-analyzer,${MULTILIB_USEDEP}]"
+
+# Please keep this package around since it's quite likely that we'll
+# return to separate LLVM & clang ebuilds when the cmake build system
+# is complete.
+
+pkg_postinst() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" ; then
+ #add ccache links as clang might get installed after ccache
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}
+
+pkg_postrm() {
+ if has_version ">=dev-util/ccache-3.1.9-r2" && [[ -z ${REPLACED_BY_VERSION} ]]; then
+ # --remove-links would remove all links, --install-links updates them
+ "${EROOT}"/usr/bin/ccache-config --install-links
+ fi
+}