summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2004-02-26 09:09:34 +0000
committerJoshua Kinard <kumba@gentoo.org>2004-02-26 09:09:34 +0000
commita34c8e69be12e3394b33e3f77ad5616205902714 (patch)
treeff53170435d360f994b75a9d90953716a8181c4b /sys-devel
parentInitial commit (Manifest recommit) (diff)
downloadgentoo-2-a34c8e69be12e3394b33e3f77ad5616205902714.tar.gz
gentoo-2-a34c8e69be12e3394b33e3f77ad5616205902714.tar.bz2
gentoo-2-a34c8e69be12e3394b33e3f77ad5616205902714.zip
Added a patch to fix some annoying bugs, and bumped into stable for x86, sparc, and mips.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/crossdev/ChangeLog9
-rw-r--r--sys-devel/crossdev/Manifest9
-rw-r--r--sys-devel/crossdev/crossdev-0.4-r1.ebuild47
-rw-r--r--sys-devel/crossdev/crossdev-0.4.ebuild4
-rw-r--r--sys-devel/crossdev/files/crossdev-0.4-fixes-one.patch47
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.4-r11
6 files changed, 111 insertions, 6 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index 3b1238f4492d..752bfa28e214 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/crossdev
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.3 2004/01/30 09:07:56 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.4 2004/02/26 09:09:34 kumba Exp $
+
+*crossdev-0.4-r1 (26 Feb 2004)
+
+ 26 Feb 2004; Joshua Kinard <kumba@gentoo.org> crossdev-0.4-r1.ebuild,
+ crossdev-0.4.ebuild, files/crossdev-0.4-fixes-one.patch:
+ Added a patch to fix some annoying bugs, and bumped into stable for x86,
+ sparc, and mips.
*crossdev-0.4 (30 Jan 2004)
diff --git a/sys-devel/crossdev/Manifest b/sys-devel/crossdev/Manifest
index 773e846eccc6..2be7cf811948 100644
--- a/sys-devel/crossdev/Manifest
+++ b/sys-devel/crossdev/Manifest
@@ -1,8 +1,11 @@
-MD5 8c7e0f3f037d19b942260809546a52df ChangeLog 718
+MD5 437377b4c9d74596d80df646cc40d3c3 ChangeLog 976
MD5 dc5d0f19cbd1a816fd91033f9c8162e2 crossdev-0.2.ebuild 902
-MD5 77157ba85dfa387178b506a435d7d3ea metadata.xml 378
MD5 02ae71ee823e70cca3aab0a32009a522 crossdev-0.3.ebuild 922
-MD5 62b2431511cfe359bc7ea8e8e921bf2b crossdev-0.4.ebuild 1035
+MD5 eb67e590a17b6aec7679fcd0c71b1c58 crossdev-0.4.ebuild 1036
+MD5 77157ba85dfa387178b506a435d7d3ea metadata.xml 378
+MD5 84f22469bdac589f174559b445df872b crossdev-0.4-r1.ebuild 1216
MD5 41882d5c4b72122ba324821b3d8e02fa files/digest-crossdev-0.2 64
MD5 5d1859e3b3613dc49a4bb21e357c4f3b files/digest-crossdev-0.3 64
MD5 e797084ae210cc0ff10ba4185eefb5e7 files/digest-crossdev-0.4 64
+MD5 bbb032e270728ffb39276e95e5653b62 files/crossdev-0.4-fixes-one.patch 1675
+MD5 e797084ae210cc0ff10ba4185eefb5e7 files/digest-crossdev-0.4-r1 64
diff --git a/sys-devel/crossdev/crossdev-0.4-r1.ebuild b/sys-devel/crossdev/crossdev-0.4-r1.ebuild
new file mode 100644
index 000000000000..cbfe0b581457
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.4-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.4-r1.ebuild,v 1.1 2004/02/26 09:09:34 kumba Exp $
+
+inherit eutils
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ~ppc sparc mips amd64"
+
+RDEPEND="sys-apps/portage
+ app-shells/bash
+ sys-apps/coreutils"
+
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Fixes some issues with portageq returning eclass names, and the cross-gcc install
+ epatch ${FILESDIR}/${P}-fixes-one.patch
+}
+
+src_install() {
+ cd ${S}
+ dobin crossdev.sh crossdev-status.sh
+ dodoc BUGS README CHANGELOG TODO
+
+ dodir /etc/crossdev
+ cp crossdev.conf.example ${D}/etc/crossdev
+
+ dosym ${D}/usr/bin/crossdev.sh /usr/bin/crossdev
+ dosym ${D}/usr/bin/crossdev-status.sh /usr/bin/crossdev-status
+
+}
+
+pkg_postinst() {
+ einfo ""
+ einfo "To make use of the cross-compilers installed by this script, you need to add the"
+ einfo "bin directory to your \$PATH. Upon sucessful creation of a toolchain, the full"
+ einfo "path to add to \$PATH will be displayed."
+ einfo ""
+}
diff --git a/sys-devel/crossdev/crossdev-0.4.ebuild b/sys-devel/crossdev/crossdev-0.4.ebuild
index 6644cf4d495b..1942e2ff785c 100644
--- a/sys-devel/crossdev/crossdev-0.4.ebuild
+++ b/sys-devel/crossdev/crossdev-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.4.ebuild,v 1.3 2004/02/22 16:21:14 brad_mssw Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.4.ebuild,v 1.4 2004/02/26 09:09:34 kumba Exp $
DESCRIPTION="Gentoo Cross-toolchain generator"
HOMEPAGE="http://www.gentoo.org/"
@@ -10,7 +10,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~sparc ~mips amd64"
-DEPEND="sys-apps/portage
+RDEPEND="sys-apps/portage
app-shells/bash
sys-apps/coreutils"
diff --git a/sys-devel/crossdev/files/crossdev-0.4-fixes-one.patch b/sys-devel/crossdev/files/crossdev-0.4-fixes-one.patch
new file mode 100644
index 000000000000..f14b43493d15
--- /dev/null
+++ b/sys-devel/crossdev/files/crossdev-0.4-fixes-one.patch
@@ -0,0 +1,47 @@
+Index: crossdev
+===================================================================
+RCS file: /home/cvsroot/gentoo/users/kumba/crossdev/crossdev,v
+retrieving revision 1.1
+retrieving revision 1.3
+diff -u -p -r1.1 -r1.3
+--- crossdev.sh 19 Feb 2004 09:35:37 -0000 1.1
++++ crossdev.sh 26 Feb 2004 08:03:52 -0000 1.3
+@@ -281,7 +282,7 @@ CheckSandbox() {
+ ;;
+ best_visible)
+ export ACCEPT_KEYWORDS="$4"
+- eval "$1=$(${PORTAGEQ_LOC} $2 $3)"
++ eval "$1=$(${PORTAGEQ_LOC} $2 $3 | tail -n 1)"
+ unset ACCEPT_KEYWORDS
+ ;;
+ esac
+@@ -338,7 +339,7 @@ CheckSandbox() {
+ ;;
+ best_visible)
+ export ACCEPT_KEYWORDS="$4"
+- eval "$1=$(${PORTAGEQ_LOC} $2 $3)"
++ eval "$1=$(${PORTAGEQ_LOC} $2 $3 | tail -n 1)"
+ unset ACCEPT_KEYWORDS
+ ;;
+ esac
+@@ -1355,6 +1356,9 @@ InstallGccBootstrap() {
+
+ #// if .installed exists, skip, otherwise install
+ if [ ! -f ".installed" ]; then
++ #// Because we use /usr/headers for gcc, we sometimes get garbage headers we don't want.
++ #// So we remove them.
++ find gcc/include -type l -exec rm -f '{}' \;
+ showInfo "Installing ${GCC_VER} (bootstrap)..."
+ make install || showError "${func_name}: Failed to run 'make install'!"
+ touch .installed
+@@ -1585,6 +1589,10 @@ InstallGccFull() {
+
+ #// if .installed exists, skip, otherwise install
+ if [ ! -f ".installed" ]; then
++ #// Because we use /usr/headers for gcc, we sometimes get garbage headers we don't want.
++ #// So we remove them.
++ find gcc/include -type l -exec rm -f '{}' \;
++
+ showInfo "Installing ${GCC_VER} (full)..."
+ make install || showError "${func_name}: Failed to run 'make install'!"
+ touch .installed
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.4-r1 b/sys-devel/crossdev/files/digest-crossdev-0.4-r1
new file mode 100644
index 000000000000..d2af869bb1ea
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.4-r1
@@ -0,0 +1 @@
+MD5 52317caa43a1ea0fd14e060c596d02c3 crossdev-0.4.tar.bz2 19042