summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-09-08 06:25:56 +0000
committerMike Frysinger <vapier@gentoo.org>2007-09-08 06:25:56 +0000
commit76443f71062b8883121086da8aa3504efe830eac (patch)
tree3da028ea1f4e4304fc3770da5f1aae4ed5bff039 /sys-devel
parentBump for 7.3. (diff)
downloadgentoo-2-76443f71062b8883121086da8aa3504efe830eac.tar.gz
gentoo-2-76443f71062b8883121086da8aa3504efe830eac.tar.bz2
gentoo-2-76443f71062b8883121086da8aa3504efe830eac.zip
Fixup false test failures with newer gcc versions #146592.
(Portage version: 2.1.3.7)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog6
-rw-r--r--sys-devel/autoconf/autoconf-2.13.ebuild18
-rw-r--r--sys-devel/autoconf/files/autoconf-2.13-test-fixes.patch18
3 files changed, 30 insertions, 12 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 9c71a90f798e..527056f013ce 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/autoconf
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.107 2007/09/08 06:11:43 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.108 2007/09/08 06:25:56 vapier Exp $
+
+ 08 Sep 2007; Mike Frysinger <vapier@gentoo.org>
+ +files/autoconf-2.13-test-fixes.patch, autoconf-2.13.ebuild:
+ Fixup false test failures with newer gcc versions #146592.
08 Sep 2007; Joseph Jezak <josejx@gentoo.org> autoconf-2.61-r1.ebuild:
Marked ppc64 stable for bug #189029.
diff --git a/sys-devel/autoconf/autoconf-2.13.ebuild b/sys-devel/autoconf/autoconf-2.13.ebuild
index 20e2ac17d951..4517c28dd0f3 100644
--- a/sys-devel/autoconf/autoconf-2.13.ebuild
+++ b/sys-devel/autoconf/autoconf-2.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.13.ebuild,v 1.16 2006/11/03 18:40:55 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.13.ebuild,v 1.17 2007/09/08 06:25:56 vapier Exp $
inherit eutils
@@ -20,9 +20,10 @@ DEPEND=">=sys-apps/texinfo-4.3
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gentoo.patch
- epatch ${FILESDIR}/${P}-destdir.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ epatch "${FILESDIR}"/${P}-destdir.patch
+ epatch "${FILESDIR}"/${P}-test-fixes.patch #146592
touch configure # make sure configure is newer than configure.in
rm -f standards.{texi,info} # binutils installs this infopage
@@ -46,15 +47,10 @@ src_compile() {
}
src_install() {
- make install DESTDIR="${D}" || die
+ emake install DESTDIR="${D}" || die
dodoc AUTHORS NEWS README TODO \
ChangeLog ChangeLog.0 ChangeLog.1
mv "${D}"/usr/share/info/autoconf{,-${PV}}.info
}
-
-pkg_postinst() {
- einfo "Please note that the 'WANT_AUTOCONF_2_1=1' syntax is now:"
- einfo " WANT_AUTOCONF=2.1"
-}
diff --git a/sys-devel/autoconf/files/autoconf-2.13-test-fixes.patch b/sys-devel/autoconf/files/autoconf-2.13-test-fixes.patch
new file mode 100644
index 000000000000..b8a7e3b8ce99
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.13-test-fixes.patch
@@ -0,0 +1,18 @@
+newer gcc versions don't provide g77, so if it doesn't exist,
+don't bother trying to test it (and failing)
+
+http://bugs.gentoo.org/146592
+
+--- autoconf-2.13/testsuite/autoconf.s/syntax.exp
++++ autoconf-2.13/testsuite/autoconf.s/syntax.exp
+@@ -5,6 +5,10 @@
+ set macros [exec sed -n $script $srcdir/../acspecific.m4]
+
+ foreach mac $macros {
++ if { [string match "*F77*" "$mac"] && [catch {exec which g77} ignore_output] } then {
++ send_user "XFAIL: $mac\n"
++ continue
++ }
+ send_user "$mac\n"
+ autoconf_test $mac $mac
+ }