summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMagnus Granberg <zorry@gentoo.org>2014-01-10 16:02:18 +0000
committerMagnus Granberg <zorry@gentoo.org>2014-01-10 16:02:18 +0000
commit6ce6cb6f036bb9ac49a5f542790d6d119010f5b4 (patch)
tree7b9293d0f9b0c429d326592932da9faca70de551 /sys-devel
parentRemove use hardened from the ssp check #484714 (diff)
downloadgentoo-2-6ce6cb6f036bb9ac49a5f542790d6d119010f5b4.tar.gz
gentoo-2-6ce6cb6f036bb9ac49a5f542790d6d119010f5b4.tar.bz2
gentoo-2-6ce6cb6f036bb9ac49a5f542790d6d119010f5b4.zip
Reverted gcc-4.8.2 and move the ssp changes to -r1
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key FD79807F)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/gcc-4.8.2-r1.ebuild50
-rw-r--r--sys-devel/gcc/gcc-4.8.2.ebuild6
3 files changed, 60 insertions, 4 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 22a56ee5ce74..f95eecc3b996 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.991 2014/01/10 15:09:25 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.992 2014/01/10 16:02:18 zorry Exp $
+
+*gcc-4.8.2-r1 (10 Jan 2014)
+
+ 10 Jan 2014; Magnus Granberg <zorry@gentoo.org> gcc-4.8.2.ebuild,
+ +gcc-4.8.2-r1.ebuild:
+ Reverted gcc-4.8.2 and move the ssp changes to -r1
10 Jan 2014; Magnus Granberg <zorry@gentoo.org> gcc-4.8.2.ebuild:
Updated it with the default ssp patchset bug 484714
diff --git a/sys-devel/gcc/gcc-4.8.2-r1.ebuild b/sys-devel/gcc/gcc-4.8.2-r1.ebuild
new file mode 100644
index 000000000000..87b6b8c4f9c7
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.8.2-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.2-r1.ebuild,v 1.1 2014/01/10 16:02:18 zorry Exp $
+
+PATCH_VER="1.4-ssptest"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.5.9-ssptest"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
+#end Hardened stuff
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection"
+
+LICENSE="GPL-3+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.3+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~x86 ~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.20"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ toolchain_src_unpack
+
+ use vanilla && return 0
+ #Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
+}
diff --git a/sys-devel/gcc/gcc-4.8.2.ebuild b/sys-devel/gcc/gcc-4.8.2.ebuild
index fcd0a9855307..383d6fa59484 100644
--- a/sys-devel/gcc/gcc-4.8.2.ebuild
+++ b/sys-devel/gcc/gcc-4.8.2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.2.ebuild,v 1.5 2014/01/10 15:09:25 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.8.2.ebuild,v 1.6 2014/01/10 16:02:18 zorry Exp $
-PATCH_VER="1.4-ssptest"
+PATCH_VER="1.3"
UCLIBC_VER="1.0"
# Hardened gcc 4 stuff
-PIE_VER="0.5.9-ssptest"
+PIE_VER="0.5.8"
SPECS_VER="0.2.0"
SPECS_GCC_VER="4.4.3"
# arch/libc configurations known to be stable with {PIE,SSP}-by-default