summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-02-08 00:55:08 +0000
committerMike Frysinger <vapier@gentoo.org>2006-02-08 00:55:08 +0000
commit569e218418dacfddc5ac2f5e7f4603ad72f6dad7 (patch)
treee3222143a4df7ddc05ada6cf0839b0b9501d2fd7 /sys-devel
parentchange xml2 to xml (diff)
downloadgentoo-2-569e218418dacfddc5ac2f5e7f4603ad72f6dad7.tar.gz
gentoo-2-569e218418dacfddc5ac2f5e7f4603ad72f6dad7.tar.bz2
gentoo-2-569e218418dacfddc5ac2f5e7f4603ad72f6dad7.zip
Fix locale.h include bug #121920 by Chris Smith.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/flex/ChangeLog6
-rw-r--r--sys-devel/flex/files/flex-2.5.31-check-for-locale-header.patch37
-rw-r--r--sys-devel/flex/flex-2.5.31-r1.ebuild5
3 files changed, 45 insertions, 3 deletions
diff --git a/sys-devel/flex/ChangeLog b/sys-devel/flex/ChangeLog
index 15d46d7d7b72..0a7cc69a727d 100644
--- a/sys-devel/flex/ChangeLog
+++ b/sys-devel/flex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/flex
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/ChangeLog,v 1.37 2006/02/07 17:49:26 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/ChangeLog,v 1.38 2006/02/08 00:55:08 vapier Exp $
+
+ 08 Feb 2006; Mike Frysinger <vapier@gentoo.org>
+ +files/flex-2.5.31-check-for-locale-header.patch, flex-2.5.31-r1.ebuild:
+ Fix locale.h include bug #121920 by Chris Smith.
07 Feb 2006; Fabian Groffen <grobian@gentoo.org> flex-2.5.4a-r6.ebuild:
Doin' it for vapier, ppc-macos stable (bug #121487)
diff --git a/sys-devel/flex/files/flex-2.5.31-check-for-locale-header.patch b/sys-devel/flex/files/flex-2.5.31-check-for-locale-header.patch
new file mode 100644
index 000000000000..fe60828b41c1
--- /dev/null
+++ b/sys-devel/flex/files/flex-2.5.31-check-for-locale-header.patch
@@ -0,0 +1,37 @@
+the source code has an '#ifdef HAVE_LOCALE_H' but forgets to
+actually check for locale.h in configure
+
+http://bugs.gentoo.org/121920
+
+--- flex-2.5.31/configure
++++ flex-2.5.31/configure
+@@ -6964,7 +6991,7 @@
+
+
+
+-for ac_header in unistd.h stdbool.h netinet/in.h limits.h
++for ac_header in unistd.h stdbool.h netinet/in.h limits.h locale.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if eval "test \"\${$as_ac_Header+set}\" = set"; then
+--- flex-2.5.31/conf.in
++++ flex-2.5.31/conf.in
+@@ -4,6 +4,9 @@
+ language is requested. */
+ #undef ENABLE_NLS
+
++/* Define to 1 if you have the <locale.h> header file. */
++#undef HAVE_LOCALE_H
++
+ /* Define to 1 if you have the <cunistd> header file. */
+ #undef HAVE_CUNISTD
+
+configure.in changes
+ dnl checks for header files
+
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(unistd.h stdbool.h netinet/in.h limits.h)
++AC_CHECK_HEADERS(unistd.h stdbool.h netinet/in.h limits.h locale.h)
+ AC_CHECK_HEADERS( sys/wait.h sys/params.h)
+ AC_CHECK_HEADERS(cunistd)
+
diff --git a/sys-devel/flex/flex-2.5.31-r1.ebuild b/sys-devel/flex/flex-2.5.31-r1.ebuild
index 32ee71cb2bf7..149d42783f06 100644
--- a/sys-devel/flex/flex-2.5.31-r1.ebuild
+++ b/sys-devel/flex/flex-2.5.31-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.31-r1.ebuild,v 1.10 2006/02/06 23:17:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/flex/flex-2.5.31-r1.ebuild,v 1.11 2006/02/08 00:55:08 vapier Exp $
inherit eutils flag-o-matic
@@ -23,7 +23,8 @@ src_unpack() {
cd "${S}"
epatch "${WORKDIR}"/${PN}_${PV}-${DEB_VER}.diff
epatch "${FILESDIR}"/${P}-include.patch
- epatch "${FILESDIR}"/${P}-isatty.patch
+ epatch "${FILESDIR}"/${P}-isatty.patch #119598
+ epatch "${FILESDIR}"/${P}-check-for-locale-header.patch #121920
}
src_compile() {