summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2003-05-06 17:56:39 +0000
committerLuca Barbato <lu_zero@gentoo.org>2003-05-06 17:56:39 +0000
commit2092d4ac00ec79770b07f358445f45de6b2f8648 (patch)
tree7a3b0856769b5f5e94538fd8bf036a1501f28e87 /sys-devel
parentNew version (diff)
downloadgentoo-2-2092d4ac00ec79770b07f358445f45de6b2f8648.tar.gz
gentoo-2-2092d4ac00ec79770b07f358445f45de6b2f8648.tar.bz2
gentoo-2-2092d4ac00ec79770b07f358445f45de6b2f8648.zip
New version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/ChangeLog8
-rw-r--r--sys-devel/binutils/Manifest4
-rw-r--r--sys-devel/binutils/binutils-2.14.90.0.1.ebuild172
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.14.90.0.11
4 files changed, 182 insertions, 3 deletions
diff --git a/sys-devel/binutils/ChangeLog b/sys-devel/binutils/ChangeLog
index 2325d3669eea..22d515b88d1f 100644
--- a/sys-devel/binutils/ChangeLog
+++ b/sys-devel/binutils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/binutils
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.43 2003/04/09 15:27:53 dragon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/ChangeLog,v 1.44 2003/05/06 17:56:18 lu_zero Exp $
+
+*binutils-2.14.90.0.1 (06 May 2003)
+
+ 06 May 2003; Luca Barbato <lu_zero@gentoo.org>
+ binutils-2.14.90.0.1.ebuild:
+ New version, seems to solve the ppc relocation issues.
*binutils-2.13.90.0.20-r1 (09 Apr 2003)
diff --git a/sys-devel/binutils/Manifest b/sys-devel/binutils/Manifest
index 9ff61f43f959..33b8bf97dac4 100644
--- a/sys-devel/binutils/Manifest
+++ b/sys-devel/binutils/Manifest
@@ -1,4 +1,4 @@
-MD5 2bb85a54846f64b0466533990b7461e2 ChangeLog 7015
+MD5 10f771646ade43488a76fc8f33fa1978 ChangeLog 7016
MD5 d189f3ead52fedbc4494c79157c153f7 binutils-2.11.92.0.12.3-r2.ebuild 3134
MD5 a665aacd5e8087aa9c51272fa8c357c7 binutils-2.11.92.0.7.ebuild 2366
MD5 743a59e3857ba3b11beab01e6a5442b5 binutils-2.12.90.0.15.ebuild 3521
@@ -11,7 +11,7 @@ MD5 192e1fab6246a3ecbf8bf2b4ff65dd47 binutils-2.13.90.0.4.ebuild 3721
MD5 8730038a660b29c4398be9320bedb1c7 binutils-2.13.90.0.18.ebuild 4533
MD5 c98f5e3a4ce9bbb59162ee9b3bbf319e binutils-2.13.90.0.18-r1.ebuild 5329
MD5 ff717bcf4a9aebb432e43af00bd65ba6 binutils-2.13.90.0.20-r1.ebuild 4970
-MD5 510fe178771ee49d49795a1f1df1364e binutils-2.14.90.0.1.ebuild 4915
+MD5 58ae9cb837ec30cecafe368b8442ade8 binutils-2.14.90.0.1.ebuild 4912
MD5 fe5fb935b171a472f5eb1a8bca63c136 files/binutils-2.12.90.0.14-glibc21.patch 7936
MD5 f453b3f208b17cd18380bc3653936487 files/binutils-2.12.90.0.14-x86_64-libpic.patch 1184
MD5 db3f89b51f6961b0cf92bdddf8127ea7 files/digest-binutils-2.11.92.0.12.3-r2 161
diff --git a/sys-devel/binutils/binutils-2.14.90.0.1.ebuild b/sys-devel/binutils/binutils-2.14.90.0.1.ebuild
new file mode 100644
index 000000000000..1d8b1a975d1c
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.14.90.0.1.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.14.90.0.1.ebuild,v 1.1 2003/05/06 17:56:18 lu_zero Exp $
+
+IUSE="nls bootstrap build"
+
+# NOTE to Maintainer: ChangeLog states that it no longer use perl to build
+# the manpages, but seems this is incorrect ....
+
+inherit eutils libtool flag-o-matic
+
+# Generate borked binaries. Bug #6730
+filter-flags "-fomit-frame-pointer -fssa"
+
+S="${WORKDIR}/${P}"
+DESCRIPTION="Tools necessary to build programs"
+SRC_URI="ftp://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.bz2
+ ftp://ftp.kernel.org/pub/linux/devel/binutils/test/${P}.tar.bz2"
+HOMEPAGE="http://sources.redhat.com/binutils/"
+
+SLOT="0"
+LICENSE="GPL-2 | LGPL-2"
+KEYWORDS="-x86 ~ppc -alpha -sparc -mips -hppa -arm"
+
+DEPEND="virtual/glibc
+ >=sys-apps/portage-2.0.21
+ nls? ( sys-devel/gettext )
+ || ( dev-lang/perl
+ ( !build? ( dev-lang/perl ) )
+ ( !bootstrap? ( dev-lang/perl ) )
+ )"
+# This is a hairy one. Basically depend on dev-lang/perl
+# if "build" or "bootstrap" not in USE.
+
+
+# filter CFLAGS=".. -O2 .." on arm
+if [ "${ARCH}" = "arm" ]; then
+ CFLAGS="$(echo "${CFLAGS}" | sed -e 's,-O[2-9] ,-O1 ,')"
+fi
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+
+ # CVS Branch Updates
+ # This is necessary to get ppc & x86 working again. It also
+ # provides futher updates and necessary fixes for mips.
+ # <dragon@gentoo.org> (09 Apr 2003)
+ #epatch ${WORKDIR}/${P}-20030409-cvs-update.patch
+
+ # Various patches from Redhat/Mandrake...
+ #epatch ${FILESDIR}/2.13/${PN}-2.13.90.0.10-glibc21.patch
+ #epatch ${FILESDIR}/2.13/${PN}-2.13.90.0.10-x86_64-testsuite.patch
+ #epatch ${FILESDIR}/2.13/${PN}-2.13.90.0.10-x86_64-gotpcrel.patch
+ #epatch ${FILESDIR}/2.13/${PN}-2.13.90.0.18-sparc-nonpic.patch
+ #epatch ${FILESDIR}/2.13/${PN}-2.13.90.0.18-eh-frame-ro.patch
+ #epatch ${FILESDIR}/2.13/${PN}-2.13.90.0.18-ltconfig-multilib.patch
+ #epatch ${FILESDIR}/2.13/${PN}-2.13.90.0.18-testsuite-Wall-fixes.patch
+ #use x86 &> /dev/null \
+ # && epatch ${FILESDIR}/2.13/${P}-array-sects-compat.patch
+ #epatch ${FILESDIR}/2.13/${PN}-2.13.90.0.18-s390-file-loc.patch
+
+ # Add patches for mips
+ if [ "${ARCH}" = "mips" ]
+ then
+ epatch ${FILESDIR}/2.13/${P}-gas-mips-gprel.patch
+ fi
+
+}
+
+src_compile() {
+ local myconf=""
+
+ use nls && \
+ myconf="${myconf} --without-included-gettext" || \
+ myconf="${myconf} --disable-nls"
+
+ # Fix /usr/lib/libbfd.la
+ elibtoolize --portage
+
+ ./configure --enable-shared \
+ --enable-64-bit-bfd \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --host=${CHOST} \
+ ${myconf} || die
+
+ make configure-bfd || die
+ make headers -C bfd || die
+ emake tooldir="${ROOT}/usr/bin" \
+ all || die
+
+ if [ -z "`use build`" ]
+ then
+ if [ -z "`use bootstrap`" ]
+ then
+ # Nuke the manpages to recreate them (only use this if we have perl)
+ find . -name '*.1' -exec rm -f {} \; || :
+ fi
+ # Make the info pages (makeinfo included with gcc is used)
+ make info || die
+ fi
+}
+
+src_install() {
+
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ insinto /usr/include
+ doins include/libiberty.h
+
+ # c++filt is included with gcc -- what are these GNU people thinking?
+ # but not the manpage, so leave that!
+ rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
+
+ # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
+ # /usr/bin/strip we should reverse it:
+
+ rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
+ # The strip symlink gets created in the loop below
+
+ # By default ar, as, ld, nm, ranlib and strip are in two places; create
+ # symlinks. This will reduce the size of the tbz2 significantly. We also
+ # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
+ # appropriate symlinks. Things are cleaner that way.
+ cd ${D}/usr/bin
+ local x=""
+ for x in * strip
+ do
+ if [ ! -e ../${CHOST}/bin/${x} ]
+ then
+ mv ${x} ../${CHOST}/bin/${x}
+ else
+ rm -f ${x}
+ fi
+ ln -s ../${CHOST}/bin/${x} ${x}
+ done
+
+ cd ${S}
+ if [ -z "`use build`" ]
+ then
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install-info || die
+
+ dodoc COPYING* README
+ docinto bfd
+ dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
+ docinto binutils
+ dodoc binutils/ChangeLog binutils/NEWS binutils/README
+ docinto gas
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
+ docinto gprof
+ dodoc gprof/ChangeLog* gprof/TEST gprof/TODO
+ docinto ld
+ dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
+ docinto libiberty
+ dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
+ docinto opcodes
+ dodoc opcodes/ChangeLog*
+ # Install pre-generated manpages .. currently we do not ...
+ else
+ rm -rf ${D}/usr/share/man
+ fi
+}
diff --git a/sys-devel/binutils/files/digest-binutils-2.14.90.0.1 b/sys-devel/binutils/files/digest-binutils-2.14.90.0.1
new file mode 100644
index 000000000000..3846350a9e3b
--- /dev/null
+++ b/sys-devel/binutils/files/digest-binutils-2.14.90.0.1
@@ -0,0 +1 @@
+MD5 2018bb21eba8fe09b1a3d53321ebffa4 binutils-2.14.90.0.1.tar.bz2 10314430