summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKito Danya Dietrich <kito@gentoo.org>2005-08-01 21:31:21 +0000
committerKito Danya Dietrich <kito@gentoo.org>2005-08-01 21:31:21 +0000
commit9976a2198983b7b618ccd2a7550d73bd60ee10d1 (patch)
tree9e2d49b146bc3403ed0accadef05462cdfab03d4 /sys-devel/pmake
parentVersion bump, bug #101015 (diff)
downloadgentoo-2-9976a2198983b7b618ccd2a7550d73bd60ee10d1.tar.gz
gentoo-2-9976a2198983b7b618ccd2a7550d73bd60ee10d1.tar.bz2
gentoo-2-9976a2198983b7b618ccd2a7550d73bd60ee10d1.zip
~ppc-macos, add conditional to install bsdmake symlinks on darwin
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sys-devel/pmake')
-rw-r--r--sys-devel/pmake/ChangeLog5
-rw-r--r--sys-devel/pmake/pmake-1.111.1.ebuild7
2 files changed, 9 insertions, 3 deletions
diff --git a/sys-devel/pmake/ChangeLog b/sys-devel/pmake/ChangeLog
index 0dc3ddc45a3e..c0daf2da525f 100644
--- a/sys-devel/pmake/ChangeLog
+++ b/sys-devel/pmake/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/pmake
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.25 2005/07/29 13:14:16 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.26 2005/08/01 21:31:21 kito Exp $
+
+ 01 Aug 2005; Kito <kito@gentoo.org> pmake-1.111.1.ebuild:
+ ~ppc-macos, add conditional to install bsdmake symlinks on darwin
29 Jul 2005; Diego Pettenò <flameeyes@gentoo.org> pmake-1.98.ebuild:
Stable on amd64.
diff --git a/sys-devel/pmake/pmake-1.111.1.ebuild b/sys-devel/pmake/pmake-1.111.1.ebuild
index d7ca74778a15..ac70181cf171 100644
--- a/sys-devel/pmake/pmake-1.111.1.ebuild
+++ b/sys-devel/pmake/pmake-1.111.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.111.1.ebuild,v 1.1 2005/07/29 12:02:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.111.1.ebuild,v 1.2 2005/08/01 21:31:21 kito Exp $
inherit eutils toolchain-funcs versionator
@@ -15,7 +15,7 @@ SRC_URI="mirror://debian/pool/main/p/pmake/${DEBIAN_SOURCE}
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc-macos ~sparc ~x86"
IUSE=""
RDEPEND=""
@@ -69,5 +69,8 @@ src_install() {
if [[ "${USERLAND}" == "BSD" ]]; then
dosym pmake /usr/bin/make
dosym pmake.1.gz /usr/share/man/man1/make.1.gz
+ elif [[ "${USERLAND}" == "Darwin" ]]; then
+ dosym pmake /usr/bin/bsdmake
+ doym pmake.1.gz /usr/share/man/man1/bsdmake.1.gz
fi
}