summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-22 22:27:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-22 22:27:54 +0000
commit067c5fa36bf87614cbcffd014f898db9c5fbf1b4 (patch)
treea238e205656c6503ed53315e21a4692094d35b31 /sys-devel/pmake
parentMask userland_Darwin to make it disappear from portage info. (diff)
downloadgentoo-2-067c5fa36bf87614cbcffd014f898db9c5fbf1b4.tar.gz
gentoo-2-067c5fa36bf87614cbcffd014f898db9c5fbf1b4.tar.bz2
gentoo-2-067c5fa36bf87614cbcffd014f898db9c5fbf1b4.zip
Import changes from gentoo-alt overlay for building on OpenBSD. Thanks to Benigno B. Junior (bbj).
(Portage version: 2.1_rc2)
Diffstat (limited to 'sys-devel/pmake')
-rw-r--r--sys-devel/pmake/ChangeLog7
-rw-r--r--sys-devel/pmake/files/digest-pmake-1.111.16
-rw-r--r--sys-devel/pmake/files/pmake-1.111.1-obsd-inttypes.patch13
-rw-r--r--sys-devel/pmake/pmake-1.111.1.ebuild12
4 files changed, 32 insertions, 6 deletions
diff --git a/sys-devel/pmake/ChangeLog b/sys-devel/pmake/ChangeLog
index 49ac65fe801b..1210bb30b09c 100644
--- a/sys-devel/pmake/ChangeLog
+++ b/sys-devel/pmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/pmake
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.27 2006/01/10 10:51:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/ChangeLog,v 1.28 2006/05/22 22:27:54 flameeyes Exp $
+
+ 22 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +files/pmake-1.111.1-obsd-inttypes.patch, pmake-1.111.1.ebuild:
+ Import changes from gentoo-alt overlay for building on OpenBSD. Thanks to
+ Benigno B. Junior (bbj).
10 Jan 2006; Diego Pettenò <flameeyes@gentoo.org> pmake-1.111.1.ebuild:
Fix typo, thanks to Emanuele Giaquinta in bug #118499.
diff --git a/sys-devel/pmake/files/digest-pmake-1.111.1 b/sys-devel/pmake/files/digest-pmake-1.111.1
index 8df406f50d36..6fc8bceda70a 100644
--- a/sys-devel/pmake/files/digest-pmake-1.111.1
+++ b/sys-devel/pmake/files/digest-pmake-1.111.1
@@ -1,2 +1,6 @@
-MD5 0bfe943567b73b0e80e3a191cd0cbbd3 pmake_1.111.orig.tar.gz 264383
MD5 cb7b78f859bcf737bac900643a23549b pmake_1.111-1.diff.gz 26675
+RMD160 9c42cd8069f30f7dd59dc5aea9d70e15c8aa16eb pmake_1.111-1.diff.gz 26675
+SHA256 4b7878844a422f1fb950f43141d81b228d2f15b0dae79365d15386ed3f2eef40 pmake_1.111-1.diff.gz 26675
+MD5 0bfe943567b73b0e80e3a191cd0cbbd3 pmake_1.111.orig.tar.gz 264383
+RMD160 d1acb558b3b89fa9f1665ab16fb93aad281bd776 pmake_1.111.orig.tar.gz 264383
+SHA256 dde37ac618f19a7cce174754c207e90501cab362b51f904bcfb20dfb24a13539 pmake_1.111.orig.tar.gz 264383
diff --git a/sys-devel/pmake/files/pmake-1.111.1-obsd-inttypes.patch b/sys-devel/pmake/files/pmake-1.111.1-obsd-inttypes.patch
new file mode 100644
index 000000000000..f9ee9a62b759
--- /dev/null
+++ b/sys-devel/pmake/files/pmake-1.111.1-obsd-inttypes.patch
@@ -0,0 +1,13 @@
+--- pmake.orig/buf.c 2006-04-24 10:11:09 -0300
++++ pmake/buf.c 2006-04-24 10:16:46 -0300
+@@ -82,6 +82,10 @@
+ #endif /* not lint */
+ #endif
+
++#if defined(__OpenBSD__)
++# include <inttypes.h>
++#endif
++
+ /*-
+ * buf.c --
+ * Functions for automatically-expanded buffers.
diff --git a/sys-devel/pmake/pmake-1.111.1.ebuild b/sys-devel/pmake/pmake-1.111.1.ebuild
index fe5ae0306795..7e237908abca 100644
--- a/sys-devel/pmake/pmake-1.111.1.ebuild
+++ b/sys-devel/pmake/pmake-1.111.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.111.1.ebuild,v 1.3 2006/01/10 10:51:53 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/pmake/pmake-1.111.1.ebuild,v 1.4 2006/05/22 22:27:54 flameeyes Exp $
inherit eutils toolchain-funcs versionator
@@ -24,14 +24,18 @@ DEPEND=""
S="${WORKDIR}/${PN}"
src_unpack() {
- unpack ${A} && cd ${S} || die
+ unpack ${A}
+ cd "${S}"
- epatch ${WORKDIR}/${DEBIAN_PATCH/.gz/}
+ epatch "${WORKDIR}/${DEBIAN_PATCH/.gz/}"
# pmake makes the assumption that . and .. are the first two
# entries in a directory, which doesn't always appear to be the
# case on ext3... (05 Apr 2004 agriffis)
- epatch ${FILESDIR}/${PN}-1.98-skipdots.patch
+ epatch "${FILESDIR}/${PN}-1.98-skipdots.patch"
+
+ # Add inttypes.h header on OpenBSD
+ epatch "${FILESDIR}/${P}-obsd-inttypes.patch"
# Clean up headers to reduce warnings
sed -i -e 's|^#endif.*|#endif|' *.h */*.h