summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2006-07-16 21:59:01 +0000
committerMichael Imhof <tantive@gentoo.org>2006-07-16 21:59:01 +0000
commitb61171154007efbf494ed5397b908974739a42e4 (patch)
tree3c68c01366e96b42810b0af9acc9f201cae5b899 /sys-devel/icecream
parentdont call prepall #140699 (diff)
downloadgentoo-2-b61171154007efbf494ed5397b908974739a42e4.tar.gz
gentoo-2-b61171154007efbf494ed5397b908974739a42e4.tar.bz2
gentoo-2-b61171154007efbf494ed5397b908974739a42e4.zip
Version bumped. Fixes problems with gcc4.1. Closes #137924.
(Portage version: 2.1.1_pre3)
Diffstat (limited to 'sys-devel/icecream')
-rw-r--r--sys-devel/icecream/ChangeLog9
-rw-r--r--sys-devel/icecream/files/digest-icecream-0.6.20050413-r13
-rw-r--r--sys-devel/icecream/files/icecream-0.6-20050413-gcc41.patch24
-rw-r--r--sys-devel/icecream/icecream-0.6.20050413-r1.ebuild101
4 files changed, 136 insertions, 1 deletions
diff --git a/sys-devel/icecream/ChangeLog b/sys-devel/icecream/ChangeLog
index b6d3e52578e0..e474d8f67b07 100644
--- a/sys-devel/icecream/ChangeLog
+++ b/sys-devel/icecream/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/icecream
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/ChangeLog,v 1.4 2006/07/16 21:51:23 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/ChangeLog,v 1.5 2006/07/16 21:59:01 tantive Exp $
+
+*icecream-0.6.20050413-r1 (16 Jul 2006)
+
+ 16 Jul 2006; Michael Imhof <tantive@gentoo.org>
+ +files/icecream-0.6-20050413-gcc41.patch,
+ +icecream-0.6.20050413-r1.ebuild:
+ Version bumped. Fixes problems with gcc4.1. Closes #137924.
16 Jul 2006; Michael Imhof <tantive@gentoo.org>
icecream-0.6.20050413.ebuild:
diff --git a/sys-devel/icecream/files/digest-icecream-0.6.20050413-r1 b/sys-devel/icecream/files/digest-icecream-0.6.20050413-r1
new file mode 100644
index 000000000000..d77c1bcb1320
--- /dev/null
+++ b/sys-devel/icecream/files/digest-icecream-0.6.20050413-r1
@@ -0,0 +1,3 @@
+MD5 eb304444a47d6b144dbc76b5638020d0 icecream-0.6-20050413.tar.bz2 594135
+RMD160 dca34e902610ad887e926c27f2f4bc21f8416e7c icecream-0.6-20050413.tar.bz2 594135
+SHA256 f47aaa70044342f046a8ca356ae5ec553ac01c940f48e7bf045b91a6ee3517b2 icecream-0.6-20050413.tar.bz2 594135
diff --git a/sys-devel/icecream/files/icecream-0.6-20050413-gcc41.patch b/sys-devel/icecream/files/icecream-0.6-20050413-gcc41.patch
new file mode 100644
index 000000000000..6e0fc9969c60
--- /dev/null
+++ b/sys-devel/icecream/files/icecream-0.6-20050413-gcc41.patch
@@ -0,0 +1,24 @@
+diff -urN icecream.orig/mon/hostinfo.h icecream/mon/hostinfo.h
+--- icecream.orig/mon/hostinfo.h 2004-08-27 12:24:46.000000000 +0100
++++ icecream/mon/hostinfo.h 2006-06-26 00:23:34.000000000 +0100
+@@ -54,7 +54,7 @@
+ protected:
+ static void initColor( const QString &value, const QString &name );
+
+- QColor HostInfo::createColor();
++ QColor createColor();
+ QColor createColor( const QString &name );
+
+ private:
+diff -urN icecream.orig/mon/starview.h icecream/mon/starview.h
+--- icecream.orig/mon/starview.h 2005-01-13 11:56:26.000000000 +0000
++++ icecream/mon/starview.h 2006-06-26 00:24:49.000000000 +0100
+@@ -142,7 +142,7 @@
+
+ QString id() const { return "star"; }
+
+- HostItem *StarView::findHostItem( unsigned int hostid );
++ HostItem *findHostItem( unsigned int hostid );
+
+ void checkNode( unsigned int hostid );
+
diff --git a/sys-devel/icecream/icecream-0.6.20050413-r1.ebuild b/sys-devel/icecream/icecream-0.6.20050413-r1.ebuild
new file mode 100644
index 000000000000..989677d5c898
--- /dev/null
+++ b/sys-devel/icecream/icecream-0.6.20050413-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/icecream-0.6.20050413-r1.ebuild,v 1.1 2006/07/16 21:59:01 tantive Exp $
+
+inherit eutils
+DESCRIPTION="Icecream is a program for distributed compiling of C(++) code across several machines based on ideas and code by distcc."
+HOMEPAGE="http://www.opensuse.org/icecream"
+SRC_URI="ftp://ftp.suse.com/pub/projects/icecream/${PN}-0.6-20050413.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+RDEPEND="virtual/libc
+ kde? ( kde-base/kdelibs )"
+DEPEND="${RDEPEND}"
+IUSE="arts kde"
+
+src_compile() {
+ cd ${WORKDIR}/icecream
+ epatch ${FILESDIR}/icecream-0.6-20050413-add-disable-option.patch || die "error patching icecream"
+ epatch ${FILESDIR}/icecream-0.6-20050413-dont-create-symlinks.patch || die "error patching icecream"
+ epatch ${FILESDIR}/icecream-0.6-20050413-gcc41.patch || die "error patching icecream"
+
+ if ! use kde ; then
+ epatch ${FILESDIR}/${PN}-0.6-20050413-no-kde.patch || die "error patching icecream"
+ aclocal
+ automake
+ autoconf
+ fi
+
+ use amd64 && export CFLAGS="${CFLAGS} -fPIC -DPIC"
+ use amd64 && export CXXFLAGS="${CXXFLAGS} -fPIC -DPIC"
+ use !arts && local myconfig="--without-arts"
+ ./configure --prefix=/usr $myconfig
+ emake || die "error compiling"
+}
+
+src_install() {
+ cd ${WORKDIR}/icecream
+ make DESTDIR=${D} install || die "error installing"
+ newbin ${FILESDIR}/icecream-config icecream-config
+ cp suse/sysconfig.icecream icecream
+ insinto "/etc/conf.d"
+ doins "icecream"
+ newinitd ${FILESDIR}/icecream icecream
+ diropts -m0755
+ dodir /usr/lib/icecream/bin
+ keepdir /usr/lib/icecream/bin
+}
+
+pkg_postinst() {
+ enewgroup icecream || die "Problem creating icecream group"
+
+ #are we doing bootstrap with has no useradd?
+ if [ -x /usr/sbin/useradd ]; then
+ enewuser icecream -1 -1 /var/cache/icecream icecream || die "Problem adding icecream user"
+ else
+ ewarn "You do not have useradd (bootstrap) from shadow so I didn't"
+ ewarn "install the icecream user. Note that attempting to start the daemon"
+ ewarn "will fail. Please install shadow and re-emerge icecream."
+ ebeep 2
+ fi
+
+ if [[ ${ROOT} = "/" ]] ; then
+ einfo "Scanning for compiler front-ends..."
+ /usr/bin/icecream-config --install-links
+ /usr/bin/icecream-config --install-links ${CHOST}
+ else
+ ewarn "Install is incomplete; you must run the following command:"
+ ewarn " # icecream-config --install-links ${CHOST}"
+ ewarn "after booting or chrooting to ${ROOT} to complete installation."
+ fi
+
+ einfo
+ einfo "If you have compiled binutils/gcc/glibc with processor-specific flags"
+ einfo "(as normal using Gentoo), there is a greater chance that your compiler"
+ einfo "won't work on other machines. The best would be to build gcc, glibc and"
+ einfo "binutils without those flags and then copy the needed files into your"
+ einfo "tarball for distribution to other machines. This tarball can be created"
+ einfo "using the /usr/bin/create-env script, and used by setting ICECC_VERSION"
+ einfo "in /etc/conf.d/icecream"
+ einfo ' ICECC_VERSION=<filename_of_archive_containing_your_environment>'
+ einfo
+ einfo "To use icecream with portage add the following line to /etc/make.conf"
+ einfo ' PREROOTPATH=/usr/lib/icecream/bin'
+ einfo
+ einfo "To use icecream with normal make use (e.g. in /etc/profile)"
+ einfo ' PATH=/usr/lib/icecream/bin:$PATH'
+ einfo
+ einfo "N.B. To use icecream with ccache, the ccache PATH should come first:"
+ einfo ' PATH=/usr/lib/ccache/bin:/usr/lib/icecream/bin:$PATH'
+ einfo
+ einfo "Don't forget to open the following ports in your firewall(s):"
+ einfo " TCP/10245 on the daemon computers (required)"
+ einfo " TCP/8765 for the the scheduler computer (required)"
+ einfo " TCP/8766 for the telnet interface to the scheduler (optional)"
+ einfo " UDP/8765 for broadcast to find the scheduler (optional)"
+ einfo
+ einfo "Further usage instructions: http://www.opensuse.org/icecream"
+ einfo
+}